summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-08-27 08:20:48 +0200
committerRemi Collet <remi@remirepo.net>2018-08-27 08:20:48 +0200
commit9ce9e654c370b9be8f4d09fc6a7a310550dceec6 (patch)
tree83e95d1f141a7343ef4a25233cdbd797f7eab0c9
parent782e219c4c31aa51bcb1fa89338b4097c3b41858 (diff)
add patch for PHP 7.3 from https://github.com/zendframework/zend-stdlib/pull/93
-rw-r--r--93.patch23
-rw-r--r--php-zendframework-zend-stdlib.spec11
2 files changed, 32 insertions, 2 deletions
diff --git a/93.patch b/93.patch
new file mode 100644
index 0000000..06143be
--- /dev/null
+++ b/93.patch
@@ -0,0 +1,23 @@
+From 70667fe80d193e1da2975356ecbff0287830d7b8 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 27 Aug 2018 08:15:06 +0200
+Subject: [PATCH] Fix PHP 7.3 warning: "continue" targeting switch is
+ equivalent to "break". Did you mean to use "continue 2"?
+
+---
+ src/ArrayObject.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/ArrayObject.php b/src/ArrayObject.php
+index 926ff6ea..8c77c620 100644
+--- a/src/ArrayObject.php
++++ b/src/ArrayObject.php
+@@ -425,7 +425,7 @@ public function unserialize($data)
+ $this->setIteratorClass($v);
+ break;
+ case 'protectedProperties':
+- continue;
++ break;
+ default:
+ $this->__set($k, $v);
+ }
diff --git a/php-zendframework-zend-stdlib.spec b/php-zendframework-zend-stdlib.spec
index 01cc2ac..2c57677 100644
--- a/php-zendframework-zend-stdlib.spec
+++ b/php-zendframework-zend-stdlib.spec
@@ -21,7 +21,7 @@
Name: php-%{gh_owner}-%{gh_project}
Version: 3.2.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,6 +30,8 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-stdlib/pull/93.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -91,6 +93,7 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
mv LICENSE.md LICENSE
@@ -114,7 +117,7 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72 php73; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
@@ -136,6 +139,10 @@ exit $ret
%changelog
+* Mon Aug 27 2018 Remi Collet <remi@remirepo.net> - 3.2.0-2
+- add patch for PHP 7.3 from
+ https://github.com/zendframework/zend-stdlib/pull/93
+
* Wed May 2 2018 Remi Collet <remi@remirepo.net> - 3.2.0-1
- update to 3.2.0
- switch to phpunit6 or phpunit7