summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-stdlib.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-stdlib.spec')
-rw-r--r--php-zendframework-zend-stdlib.spec11
1 files changed, 9 insertions, 2 deletions
diff --git a/php-zendframework-zend-stdlib.spec b/php-zendframework-zend-stdlib.spec
index 01cc2ac..2c57677 100644
--- a/php-zendframework-zend-stdlib.spec
+++ b/php-zendframework-zend-stdlib.spec
@@ -21,7 +21,7 @@
Name: php-%{gh_owner}-%{gh_project}
Version: 3.2.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,6 +30,8 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-stdlib/pull/93.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -91,6 +93,7 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
mv LICENSE.md LICENSE
@@ -114,7 +117,7 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72 php73; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
@@ -136,6 +139,10 @@ exit $ret
%changelog
+* Mon Aug 27 2018 Remi Collet <remi@remirepo.net> - 3.2.0-2
+- add patch for PHP 7.3 from
+ https://github.com/zendframework/zend-stdlib/pull/93
+
* Wed May 2 2018 Remi Collet <remi@remirepo.net> - 3.2.0-1
- update to 3.2.0
- switch to phpunit6 or phpunit7