summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-02 15:19:59 +0200
committerRemi Collet <remi@remirepo.net>2018-05-02 15:19:59 +0200
commit782e219c4c31aa51bcb1fa89338b4097c3b41858 (patch)
tree2494a0fc6d4e949c14547d9dae743a6ef8c579e2
parent17f540b00069845066c97f717973d5f960d88936 (diff)
update to 3.2.0
switch to phpunit6 or phpunit7
-rw-r--r--composer.json40
-rw-r--r--php-zendframework-zend-stdlib.spec30
2 files changed, 46 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index 679d1f3..8c99009 100644
--- a/composer.json
+++ b/composer.json
@@ -1,29 +1,31 @@
{
"name": "zendframework/zend-stdlib",
- "description": " ",
+ "description": "SPL extensions, array utilities, error handlers, and more",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zf",
+ "zendframework",
"stdlib"
],
- "homepage": "https://github.com/zendframework/zend-stdlib",
- "autoload": {
- "psr-4": {
- "Zend\\Stdlib\\": "src/"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-stdlib/",
+ "issues": "https://github.com/zendframework/zend-stdlib/issues",
+ "source": "https://github.com/zendframework/zend-stdlib",
+ "rss": "https://github.com/zendframework/zend-stdlib/releases.atom",
+ "slack": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
"php": "^5.6 || ^7.0"
},
"require-dev": {
- "athletic/athletic": "~0.1",
- "phpunit/PHPUnit": "~4.0",
+ "phpbench/phpbench": "^0.13",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
"zendframework/zend-coding-standard": "~1.0.0"
},
- "extra": {
- "branch-alias": {
- "dev-master": "3.1-dev",
- "dev-develop": "3.2-dev"
+ "autoload": {
+ "psr-4": {
+ "Zend\\Stdlib\\": "src/"
}
},
"autoload-dev": {
@@ -32,6 +34,15 @@
"ZendBench\\Stdlib\\": "benchmark/"
}
},
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.2.x-dev",
+ "dev-develop": "3.3.x-dev"
+ }
+ },
"scripts": {
"check": [
"@cs-check",
@@ -40,7 +51,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-stdlib.spec b/php-zendframework-zend-stdlib.spec
index cebeff3..01cc2ac 100644
--- a/php-zendframework-zend-stdlib.spec
+++ b/php-zendframework-zend-stdlib.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 10ef03144902d1955f935fff5346ed52f7d99bcc
+%global gh_commit cd164b4a18b5d1aeb69be2c26db035b5ed6925ae
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-stdlib
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.1.1
+Version: 3.2.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -41,11 +41,18 @@ BuildRequires: php-pcre
BuildRequires: php-posix
BuildRequires: php-spl
# From composer, "require-dev": {
-# "athletic/athletic": "~0.1",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0",
+# "phpbench/phpbench": "^0.13",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
# "zendframework/zend-coding-standard": "~1.0.0"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
+# remirepo:4
+%else
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
@@ -107,9 +114,10 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -128,6 +136,10 @@ exit $ret
%changelog
+* Wed May 2 2018 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- update to 3.2.0
+- switch to phpunit6 or phpunit7
+
* Mon Apr 16 2018 Remi Collet <remi@remirepo.net> - 3.1.1-1
- update to 3.1.1