summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-14 07:19:11 +0200
committerRemi Collet <remi@remirepo.net>2018-05-14 07:19:11 +0200
commit5d17b87abd0e24200aa536dc9c0b984285302f1a (patch)
tree24592ac61dd1b6b0915554eb4ca2d8cda68631e9
parent1c8156538dfba4c43aae4cc6cd2bfd101b6ccbfa (diff)
update to 1.3.7 (no change)
switch to phpunit7 use range dependencies
-rw-r--r--composer.json14
-rw-r--r--php-tecnickcom-tc-lib-unicode.spec31
2 files changed, 32 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index 0ad1915..f33713d 100644
--- a/composer.json
+++ b/composer.json
@@ -22,17 +22,17 @@
"php": ">=5.4",
"ext-mbstring": "*",
"ext-pcre": "*",
- "tecnickcom/tc-lib-unicode-data": "^1.6.6"
+ "tecnickcom/tc-lib-unicode-data": "^1.6.7"
},
"require-dev": {
"apigen/apigen": "^4.1.2",
- "bartlett/php-compatinfo": "^5.0.4",
- "pdepend/pdepend": "^2.5.0",
- "phploc/phploc": "^2.1.5 || ^3.0.1",
+ "bartlett/php-compatinfo": "^5.0.10 || ^5.0.12",
+ "pdepend/pdepend": "^2.5.2",
+ "phploc/phploc": "^2.1 || ^3.0 || ^4.0",
"phpmd/phpmd": "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5",
- "sebastian/phpcpd": "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
+ "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.1",
+ "sebastian/phpcpd": "^2.0 || ^3.0 || ^4.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.2.0"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode.spec
index 9f574ec..d9d082c 100644
--- a/php-tecnickcom-tc-lib-unicode.spec
+++ b/php-tecnickcom-tc-lib-unicode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit f8c1cbba5b91f209de4c205614d758cced94793f
+%global gh_commit 2e03aec8d1df99ade2c1ed1309d81349c9f320b3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.3.6
+Version: 1.3.7
Release: 1%{?dist}
Summary: PHP library containing Unicode methods
@@ -27,9 +27,19 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
+%else
+BuildRequires: php-composer(%{c_vendor}/tc-lib-unicode-data) < 2
BuildRequires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3
+%endif
BuildRequires: php-mbstring
BuildRequires: php-pcre
%endif
@@ -42,8 +52,12 @@ BuildRequires: php-pcre
Requires: php(language) >= 5.4
Requires: php-mbstring
Requires: php-pcre
-Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
+%else
Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) < 2
+Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3
+%endif
# From phpcompatinfo report for version 1.2.1
# None
@@ -88,10 +102,10 @@ require '%{php_project}/Data/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -109,6 +123,11 @@ exit $ret
%changelog
+* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 1.3.7-1
+- update to 1.3.7 (no change)
+- switch to phpunit7
+- use range dependencies
+
* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 1.3.6-1
- Update to 1.3.6