summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-unicode.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-tecnickcom-tc-lib-unicode.spec')
-rw-r--r--php-tecnickcom-tc-lib-unicode.spec31
1 files changed, 25 insertions, 6 deletions
diff --git a/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode.spec
index 9f574ec..d9d082c 100644
--- a/php-tecnickcom-tc-lib-unicode.spec
+++ b/php-tecnickcom-tc-lib-unicode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit f8c1cbba5b91f209de4c205614d758cced94793f
+%global gh_commit 2e03aec8d1df99ade2c1ed1309d81349c9f320b3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.3.6
+Version: 1.3.7
Release: 1%{?dist}
Summary: PHP library containing Unicode methods
@@ -27,9 +27,19 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
+%else
+BuildRequires: php-composer(%{c_vendor}/tc-lib-unicode-data) < 2
BuildRequires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3
+%endif
BuildRequires: php-mbstring
BuildRequires: php-pcre
%endif
@@ -42,8 +52,12 @@ BuildRequires: php-pcre
Requires: php(language) >= 5.4
Requires: php-mbstring
Requires: php-pcre
-Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
+%else
Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) < 2
+Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3
+%endif
# From phpcompatinfo report for version 1.2.1
# None
@@ -88,10 +102,10 @@ require '%{php_project}/Data/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -109,6 +123,11 @@ exit $ret
%changelog
+* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 1.3.7-1
+- update to 1.3.7 (no change)
+- switch to phpunit7
+- use range dependencies
+
* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 1.3.6-1
- Update to 1.3.6