summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-02 09:58:24 +0100
committerRemi Collet <remi@remirepo.net>2018-01-02 09:58:24 +0100
commit1c8156538dfba4c43aae4cc6cd2bfd101b6ccbfa (patch)
treef60e2d67c7586830ed32d2230c7d42d3018bc413
parent275ccf1efc243f7a1c39287000e04d514484a116 (diff)
v1.3.6
-rw-r--r--.gitignore8
-rw-r--r--composer.json80
-rw-r--r--php-tecnickcom-tc-lib-unicode.spec28
3 files changed, 58 insertions, 58 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 266b3d4..0ad1915 100644
--- a/composer.json
+++ b/composer.json
@@ -1,42 +1,42 @@
{
- "name": "tecnickcom/tc-lib-unicode",
- "description": "PHP library containing Unicode methods",
- "type": "library",
- "homepage": "http://www.tecnick.com",
- "license": "LGPL-3.0",
- "keywords": ["tc-lib-unicode", "PDF", "font", "UTF-8"],
- "authors": [
- {
- "name": "Nicola Asuni",
- "email": "info@tecnick.com",
- "role": "lead"
- }
- ],
- "require": {
- "php": ">=5.4",
- "ext-mbstring": "*",
- "ext-pcre": "*",
- "tecnickcom/tc-lib-unicode-data": "^1.6.5"
- },
- "require-dev": {
- "apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.4",
- "pdepend/pdepend" : "^2.5.0",
- "phploc/phploc" : "^2.1.5 || ^3.0.1",
- "phpmd/phpmd" : "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
- },
- "autoload": {
- "psr-4":{
- "Com\\Tecnick\\Unicode\\": "src"
- }
- },
- "repositories": [
- {
- "type": "vcs",
- "url": "git@github.com:tecnickcom/tc-lib-unicode-data.git"
- }
- ]
+ "name": "tecnickcom/tc-lib-unicode",
+ "description": "PHP library containing Unicode methods",
+ "type": "library",
+ "homepage": "http://www.tecnick.com",
+ "license": "LGPL-3.0",
+ "keywords": [
+ "tc-lib-unicode",
+ "PDF",
+ "font",
+ "UTF-8",
+ "Unicode"
+ ],
+ "authors": [
+ {
+ "name": "Nicola Asuni",
+ "email": "info@tecnick.com",
+ "role": "lead"
+ }
+ ],
+ "require": {
+ "php": ">=5.4",
+ "ext-mbstring": "*",
+ "ext-pcre": "*",
+ "tecnickcom/tc-lib-unicode-data": "^1.6.6"
+ },
+ "require-dev": {
+ "apigen/apigen": "^4.1.2",
+ "bartlett/php-compatinfo": "^5.0.4",
+ "pdepend/pdepend": "^2.5.0",
+ "phploc/phploc": "^2.1.5 || ^3.0.1",
+ "phpmd/phpmd": "^2.6.0",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5",
+ "sebastian/phpcpd": "^2.0.4 || 3.0.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Com\\Tecnick\\Unicode\\": "src"
+ }
+ }
}
diff --git a/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode.spec
index c81abcb..9f574ec 100644
--- a/php-tecnickcom-tc-lib-unicode.spec
+++ b/php-tecnickcom-tc-lib-unicode.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-unicode
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit e07e2f3c0f8391f8b13a24f32c9f3ec2edd4bef4
+%global gh_commit f8c1cbba5b91f209de4c205614d758cced94793f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.3.5
+Version: 1.3.6
Release: 1%{?dist}
Summary: PHP library containing Unicode methods
@@ -24,7 +24,6 @@ License: LGPLv3+
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
@@ -73,7 +72,6 @@ grep -q '^%{version}$' VERSION
%install
-rm -rf %{buildroot}
mkdir -p $(dirname %{buildroot}%{php_project})
cp -pr src %{buildroot}%{php_project}
cp -p resources/autoload.php \
@@ -90,14 +88,10 @@ require '%{php_project}/Data/autoload.php';
EOF
ret=0
-for cmd in php56 php; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
- fi
-done
-for cmd in php70 php71; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 --no-coverage --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -106,12 +100,7 @@ exit $ret
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -120,6 +109,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 1.3.6-1
+- Update to 1.3.6
+
* Sun Feb 12 2017 Remi Collet <remi@remirepo.net> - 1.3.5-1
- update to 1.3.5 (no change)