summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-02 09:49:35 +0100
committerRemi Collet <remi@remirepo.net>2018-01-02 09:49:35 +0100
commit6bce0587e8d250f2e3e35a6d2efc06ecf722a00b (patch)
tree242177799e2b804a35ca0b3a5512d2243e49b4df
parent0fe99a693c83c96871d18e4092fb72ac2460c7e5 (diff)
simplify
-rw-r--r--php-tecnickcom-tc-lib-file.spec11
1 files changed, 4 insertions, 7 deletions
diff --git a/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file.spec
index a51ddb7..67a826e 100644
--- a/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file.spec
@@ -89,13 +89,10 @@ EOF
sed -i 's:src:File:g' -i test/DirTest.php
ret=0
-for cmd in "php %{phpunit}" \
- "php56 %{_bindir}/phpunit" \
- "php70 %{_bindir}/phpunit6" \
- "php71 %{_bindir}/phpunit6" \
- "php72 %{_bindir}/phpunit6"; do
- if which $cmd; then
- $cmd --no-coverage --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
fi
done
exit $ret