summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-file.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-tecnickcom-tc-lib-file.spec')
-rw-r--r--php-tecnickcom-tc-lib-file.spec11
1 files changed, 4 insertions, 7 deletions
diff --git a/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file.spec
index a51ddb7..67a826e 100644
--- a/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file.spec
@@ -89,13 +89,10 @@ EOF
sed -i 's:src:File:g' -i test/DirTest.php
ret=0
-for cmd in "php %{phpunit}" \
- "php56 %{_bindir}/phpunit" \
- "php70 %{_bindir}/phpunit6" \
- "php71 %{_bindir}/phpunit6" \
- "php72 %{_bindir}/phpunit6"; do
- if which $cmd; then
- $cmd --no-coverage --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
fi
done
exit $ret