summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-02 09:44:46 +0100
committerRemi Collet <remi@remirepo.net>2018-01-02 09:44:46 +0100
commit0fe99a693c83c96871d18e4092fb72ac2460c7e5 (patch)
tree5c9222c1a944a52c992f09f76b38ff4ff10159e3
parent32a15cdd3bb2b2e86efd3feff8ff84aa93f67405 (diff)
v1.6.6
-rw-r--r--.gitignore8
-rw-r--r--composer.json73
-rw-r--r--php-tecnickcom-tc-lib-file.spec32
3 files changed, 61 insertions, 52 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 20b11d5..bd065ba 100644
--- a/composer.json
+++ b/composer.json
@@ -1,35 +1,44 @@
{
- "name": "tecnickcom/tc-lib-file",
- "description": "PHP library to read byte-level data from files",
- "type": "library",
- "homepage": "http://www.tecnick.com",
- "license": "LGPL-3.0",
- "keywords": ["tc-lib-file", "file", "byte", "bit", "read", "short", "long", "double"],
- "authors": [
- {
- "name": "Nicola Asuni",
- "email": "info@tecnick.com",
- "role": "lead"
- }
- ],
- "require": {
- "php": ">=5.4",
- "ext-curl": "*",
- "ext-pcre": "*"
- },
- "require-dev": {
- "apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.4",
- "pdepend/pdepend" : "^2.5.0",
- "phploc/phploc" : "^2.1.5 || ^3.0.1",
- "phpmd/phpmd" : "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
- },
- "autoload": {
- "psr-4":{
- "Com\\Tecnick\\File\\": "src"
- }
+ "name": "tecnickcom/tc-lib-file",
+ "description": "PHP library to read byte-level data from files",
+ "type": "library",
+ "homepage": "http://www.tecnick.com",
+ "license": "LGPL-3.0",
+ "keywords": [
+ "tc-lib-file",
+ "file",
+ "byte",
+ "bit",
+ "read",
+ "short",
+ "long",
+ "double"
+ ],
+ "authors": [
+ {
+ "name": "Nicola Asuni",
+ "email": "info@tecnick.com",
+ "role": "lead"
}
+ ],
+ "require": {
+ "php": ">=5.4",
+ "ext-curl": "*",
+ "ext-pcre": "*"
+ },
+ "require-dev": {
+ "apigen/apigen": "^4.1.2",
+ "bartlett/php-compatinfo": "^5.0.4",
+ "pdepend/pdepend": "^2.5.0",
+ "phploc/phploc": "^2.1.5 || ^3.0.1",
+ "phpmd/phpmd": "^2.6.0",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
+ "sebastian/phpcpd": "^2.0.4 || 3.0.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Com\\Tecnick\\File\\": "src"
+ }
+ }
}
diff --git a/php-tecnickcom-tc-lib-file.spec b/php-tecnickcom-tc-lib-file.spec
index 56d958e..a51ddb7 100644
--- a/php-tecnickcom-tc-lib-file.spec
+++ b/php-tecnickcom-tc-lib-file.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-file
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 69a5aed25e0a98b1f7c86b2aa9ede38ff18146ee
+%global gh_commit f373192e4e6f408633a0ffbb4b5eb2da0d33a24d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.6.5
+Version: 1.6.6
Release: 1%{?dist}
Summary: PHP library to read byte-level data from files
@@ -24,7 +24,6 @@ License: LGPLv3+
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
@@ -73,7 +72,6 @@ grep -q '^%{version}$' VERSION
%install
-rm -rf %{buildroot}
mkdir -p $(dirname %{buildroot}%{php_project})
cp -pr src %{buildroot}%{php_project}
cp -p resources/autoload.php \
@@ -90,18 +88,14 @@ EOF
sed -i 's:src:File:g' -i test/DirTest.php
-%{phpunit} --no-coverage --verbose
-
-#remirepo:12
ret=0
-for cmd in php56; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
- fi
-done
-for cmd in php70 php71; do
+for cmd in "php %{phpunit}" \
+ "php56 %{_bindir}/phpunit" \
+ "php70 %{_bindir}/phpunit6" \
+ "php71 %{_bindir}/phpunit6" \
+ "php72 %{_bindir}/phpunit6"; do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 --no-coverage --verbose || ret=1
+ $cmd --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -110,12 +104,7 @@ exit $ret
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -126,6 +115,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 1.6.6-1
+- Update to 1.6.6 (no change)
+
* Sun Feb 12 2017 Remi Collet <remi@remirepo.net> - 1.6.5-1
- update to 1.6.5 (no change)
- use phpunit6 on F26+