summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-07-03 09:57:47 +0200
committerRemi Collet <remi@remirepo.net>2018-07-03 09:57:47 +0200
commitb19cf181b0ea5977c912767ff9f50c2e648f39ca (patch)
tree3d858eaa09536c85aadd06f9c0499b34120c8065
parentce29c474d94489afb908f5d169a2ea8393a0a1a0 (diff)
v2.7.0 from Fedora:
* Sun Jul 01 2018 Shawn Iwinski <shawn@iwin.ski> - 2.7.0-1 - Update to 2.7.0 (RHBZ #1590046) - Add composer.json to repo
-rw-r--r--Makefile2
-rw-r--r--composer.json3
-rw-r--r--php-react-promise.spec27
3 files changed, 16 insertions, 16 deletions
diff --git a/Makefile b/Makefile
index d095534..eb511d9 100644
--- a/Makefile
+++ b/Makefile
@@ -4,7 +4,7 @@ INCL1 := $(shell php-config --includes)
INCL2 := -I $(shell php-config --include-dir)/sapi/embed
LIBS := -lphp5 $(shell php-config --libs)
-include ../../common/Makefile
+include ../../../common/Makefile
tembed: tembed.c
gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/composer.json b/composer.json
index 7cf1750..2fc4809 100644
--- a/composer.json
+++ b/composer.json
@@ -8,6 +8,9 @@
"require": {
"php": ">=5.4.0"
},
+ "require-dev": {
+ "phpunit/phpunit": "~4.8"
+ },
"autoload": {
"psr-4": {
"React\\Promise\\": "src/"
diff --git a/php-react-promise.spec b/php-react-promise.spec
index 1c14361..8be8e8f 100644
--- a/php-react-promise.spec
+++ b/php-react-promise.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-promise
#
-# Copyright (c) 2014-2016 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2014-2018 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name promise
-%global github_version 2.5.0
-%global github_commit 2760f3898b7e931aa71153852dcd48a75c9b95db
+%global github_version 2.7.0
+%global github_commit f4edc2581617431aea50430749db55cc3fc031b3
%global composer_vendor react
%global composer_project promise
@@ -33,17 +33,16 @@ Summary: A lightweight implementation of CommonJS Promises/A for PHP
Group: Development/Libraries
License: MIT
-URL: https://github.com/%{github_owner}/%{github_name}
-Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+URL: https://reactphp.org/promise/
+Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
%if %{with_tests}
BuildRequires: php-composer(phpunit/phpunit)
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-## phpcompatinfo (computed from version 2.5.0)
+## phpcompatinfo (computed from version 2.7.0)
BuildRequires: php-json
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -53,7 +52,7 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 2.5.0)
+# phpcompatinfo (computed from version 2.7.0)
Requires: php-json
Requires: php-reflection
Requires: php-spl
@@ -94,7 +93,6 @@ AUTOLOAD
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{phpdir}/React/Promise
cp -rp src/* %{buildroot}%{phpdir}/React/Promise/
@@ -114,7 +112,7 @@ BOOTSTRAP
: Upstream tests with SCLs if available
SCL_RETURN_CODE=0
-for SCL in php56 php70 php71; do
+for SCL in php70 php71 php73 php73; do
if which $SCL; then
$SCL %{_bindir}/phpunit --bootstrap ./bootstrap.php || SCL_RETURN_CODE=1
fi
@@ -125,12 +123,7 @@ exit $SCL_RETURN_CODE
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -140,6 +133,10 @@ rm -rf %{buildroot}
%changelog
+* Sun Jul 01 2018 Shawn Iwinski <shawn@iwin.ski> - 2.7.0-1
+- Update to 2.7.0 (RHBZ #1590046)
+- Add composer.json to repo
+
* Sat Dec 24 2016 Shawn Iwinski <shawn.iwinski@gmail.com> - 2.5.0-1
- Updated to 2.5.0 (RHBZ #1408344)
- Use php-composer(fedora/autoloader)