summaryrefslogtreecommitdiffstats
path: root/php-react-promise.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-react-promise.spec')
-rw-r--r--php-react-promise.spec27
1 files changed, 12 insertions, 15 deletions
diff --git a/php-react-promise.spec b/php-react-promise.spec
index 1c14361..8be8e8f 100644
--- a/php-react-promise.spec
+++ b/php-react-promise.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-promise
#
-# Copyright (c) 2014-2016 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2014-2018 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name promise
-%global github_version 2.5.0
-%global github_commit 2760f3898b7e931aa71153852dcd48a75c9b95db
+%global github_version 2.7.0
+%global github_commit f4edc2581617431aea50430749db55cc3fc031b3
%global composer_vendor react
%global composer_project promise
@@ -33,17 +33,16 @@ Summary: A lightweight implementation of CommonJS Promises/A for PHP
Group: Development/Libraries
License: MIT
-URL: https://github.com/%{github_owner}/%{github_name}
-Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+URL: https://reactphp.org/promise/
+Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
%if %{with_tests}
BuildRequires: php-composer(phpunit/phpunit)
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-## phpcompatinfo (computed from version 2.5.0)
+## phpcompatinfo (computed from version 2.7.0)
BuildRequires: php-json
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -53,7 +52,7 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 2.5.0)
+# phpcompatinfo (computed from version 2.7.0)
Requires: php-json
Requires: php-reflection
Requires: php-spl
@@ -94,7 +93,6 @@ AUTOLOAD
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{phpdir}/React/Promise
cp -rp src/* %{buildroot}%{phpdir}/React/Promise/
@@ -114,7 +112,7 @@ BOOTSTRAP
: Upstream tests with SCLs if available
SCL_RETURN_CODE=0
-for SCL in php56 php70 php71; do
+for SCL in php70 php71 php73 php73; do
if which $SCL; then
$SCL %{_bindir}/phpunit --bootstrap ./bootstrap.php || SCL_RETURN_CODE=1
fi
@@ -125,12 +123,7 @@ exit $SCL_RETURN_CODE
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -140,6 +133,10 @@ rm -rf %{buildroot}
%changelog
+* Sun Jul 01 2018 Shawn Iwinski <shawn@iwin.ski> - 2.7.0-1
+- Update to 2.7.0 (RHBZ #1590046)
+- Add composer.json to repo
+
* Sat Dec 24 2016 Shawn Iwinski <shawn.iwinski@gmail.com> - 2.5.0-1
- Updated to 2.5.0 (RHBZ #1408344)
- Use php-composer(fedora/autoloader)