summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-30 09:41:15 +0100
committerRemi Collet <remi@remirepo.net>2020-11-30 09:41:15 +0100
commit4157be0e2a70730927a93ac1ae07dd484367c744 (patch)
tree3254bf92494b342494d95b8e0c8b8314c08c62a7
parentfa0f101cbee431004aa65fcb248c3b6a6c7fbdfc (diff)
update to 3.0.3 (no change)
switch to phpunit8
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-diff3.spec16
2 files changed, 11 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 59520e9..fe2d77f 100644
--- a/composer.json
+++ b/composer.json
@@ -15,7 +15,7 @@
}
],
"require": {
- "php": "^7.1"
+ "php": ">=7.1"
},
"require-dev": {
"phpunit/phpunit": "^7.5 || ^8.0",
diff --git a/php-sebastian-diff3.spec b/php-sebastian-diff3.spec
index 0069ea1..53793e7 100644
--- a/php-sebastian-diff3.spec
+++ b/php-sebastian-diff3.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 720fcc7e9b5cf384ea68d9d930d480907a0c1a29
+%global gh_commit 14f72dd46eaf2f2293cbe79c93cc0bc43161a211
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project diff
@@ -27,7 +27,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.2
+Version: 3.0.3
Release: 1%{?dist}
Summary: Diff implementation
@@ -44,12 +44,12 @@ BuildRequires: php-spl
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^7.5 || ^8.0",
# "symfony/process": "^2 || ^3.3 || ^4"
-BuildRequires: phpunit7 >= 7.5
+BuildRequires: phpunit8
BuildRequires: php-symfony4-process
%endif
# from composer.json
-# "php": "^7.1"
+# "php": ">=7.1"
Requires: php(language) >= 7.1
# from phpcompatinfo report for version 3.0.0
Requires: php-pcre
@@ -96,10 +96,10 @@ rm -r tests/Output/Integration
: Run upstream test suite
ret=0
-for cmd in php php71 php72 php73; do
+for cmd in php php72 php73 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit7 --verbose || ret=1
+ %{_bindir}/phpunit8 --verbose || ret=1
fi
done
exit $ret
@@ -119,6 +119,10 @@ exit $ret
%changelog
+* Mon Nov 30 2020 Remi Collet <remi@remirepo.net> - 3.0.3-1
+- update to 3.0.3 (no change)
+- switch to phpunit8
+
* Mon Feb 4 2019 Remi Collet <remi@remirepo.net> - 3.0.2-1
- update to 3.0.2