summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-02-04 10:27:07 +0100
committerRemi Collet <remi@remirepo.net>2019-02-04 10:27:07 +0100
commitfa0f101cbee431004aa65fcb248c3b6a6c7fbdfc (patch)
tree03e0a0c7050fe21907d44241a6ba991da8f59c4b
parentbc83a9db1e70cfc7fe33da1e0f46fb714fef04b3 (diff)
v3.0.2
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-diff3.spec13
2 files changed, 9 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index aea9c92..59520e9 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"php": "^7.1"
},
"require-dev": {
- "phpunit/phpunit": "^7.0",
+ "phpunit/phpunit": "^7.5 || ^8.0",
"symfony/process": "^2 || ^3.3 || ^4"
},
"autoload": {
diff --git a/php-sebastian-diff3.spec b/php-sebastian-diff3.spec
index 8b8b629..0069ea1 100644
--- a/php-sebastian-diff3.spec
+++ b/php-sebastian-diff3.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-sebastian-diff3
#
-# Copyright (c) 2013-2018 Remi Collet
+# Copyright (c) 2013-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 366541b989927187c4ca70490a35615d3fef2dce
+%global gh_commit 720fcc7e9b5cf384ea68d9d930d480907a0c1a29
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project diff
@@ -27,7 +27,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.1
+Version: 3.0.2
Release: 1%{?dist}
Summary: Diff implementation
@@ -42,9 +42,9 @@ BuildRequires: php(language) >= 7.1
BuildRequires: php-pcre
BuildRequires: php-spl
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^7.0",
+# "phpunit/phpunit": "^7.5 || ^8.0",
# "symfony/process": "^2 || ^3.3 || ^4"
-BuildRequires: phpunit7
+BuildRequires: phpunit7 >= 7.5
BuildRequires: php-symfony4-process
%endif
@@ -119,6 +119,9 @@ exit $ret
%changelog
+* Mon Feb 4 2019 Remi Collet <remi@remirepo.net> - 3.0.2-1
+- update to 3.0.2
+
* Mon Jun 11 2018 Remi Collet <remi@remirepo.net> - 3.0.1-1
- update to 3.0.1 (no change)
- ignore integration tests with old git command