summaryrefslogtreecommitdiffstats
path: root/php-sebastian-diff3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-diff3.spec')
-rw-r--r--php-sebastian-diff3.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/php-sebastian-diff3.spec b/php-sebastian-diff3.spec
index 0069ea1..53793e7 100644
--- a/php-sebastian-diff3.spec
+++ b/php-sebastian-diff3.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 720fcc7e9b5cf384ea68d9d930d480907a0c1a29
+%global gh_commit 14f72dd46eaf2f2293cbe79c93cc0bc43161a211
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project diff
@@ -27,7 +27,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.2
+Version: 3.0.3
Release: 1%{?dist}
Summary: Diff implementation
@@ -44,12 +44,12 @@ BuildRequires: php-spl
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^7.5 || ^8.0",
# "symfony/process": "^2 || ^3.3 || ^4"
-BuildRequires: phpunit7 >= 7.5
+BuildRequires: phpunit8
BuildRequires: php-symfony4-process
%endif
# from composer.json
-# "php": "^7.1"
+# "php": ">=7.1"
Requires: php(language) >= 7.1
# from phpcompatinfo report for version 3.0.0
Requires: php-pcre
@@ -96,10 +96,10 @@ rm -r tests/Output/Integration
: Run upstream test suite
ret=0
-for cmd in php php71 php72 php73; do
+for cmd in php php72 php73 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit7 --verbose || ret=1
+ %{_bindir}/phpunit8 --verbose || ret=1
fi
done
exit $ret
@@ -119,6 +119,10 @@ exit $ret
%changelog
+* Mon Nov 30 2020 Remi Collet <remi@remirepo.net> - 3.0.3-1
+- update to 3.0.3 (no change)
+- switch to phpunit8
+
* Mon Feb 4 2019 Remi Collet <remi@remirepo.net> - 3.0.2-1
- update to 3.0.2