summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-12-20 14:44:34 +0100
committerRemi Collet <remi@remirepo.net>2018-12-20 14:44:34 +0100
commitbf95996dca9b743092547ef1424769529b03705c (patch)
treee19d1409adc6a49f5fe651ca99e59b262eeb6d53
parentd7e37ea0b562b1b35fb40c16f64887d9e21f0cb7 (diff)
v4.2.0
-rw-r--r--PHPINFO3
-rw-r--r--REFLECTION319
-rw-r--r--php-pecl-swoole4.spec10
3 files changed, 149 insertions, 183 deletions
diff --git a/PHPINFO b/PHPINFO
index affa40c..94c7d43 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
swoole
swoole support => enabled
-Version => 4.2.9
+Version => 4.2.10
Author => Swoole Group[email: team@swoole.com]
coroutine => enabled
trace_log => enabled
@@ -29,7 +29,6 @@ Directive => Local Value => Master Value
swoole.enable_coroutine => On => On
swoole.aio_thread_num => 2 => 2
swoole.display_errors => On => On
-swoole.use_namespace => On => On
swoole.use_shortname => On => On
swoole.fast_serialize => Off => Off
swoole.unixsock_buffer_size => 8388608 => 8388608
diff --git a/REFLECTION b/REFLECTION
index ab15450..184664b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
+Extension [ <persistent> extension #149 swoole version 4.2.10 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -10,9 +10,6 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
Entry [ swoole.display_errors <ALL> ]
Current = 'On'
}
- Entry [ swoole.use_namespace <SYSTEM> ]
- Current = 'On'
- }
Entry [ swoole.use_shortname <SYSTEM> ]
Current = 'On'
}
@@ -24,7 +21,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
- - Constants [233] {
+ - Constants [247] {
Constant [ integer SWOOLE_BASE ] { 1 }
Constant [ integer SWOOLE_PROCESS ] { 2 }
Constant [ integer SWOOLE_IPC_UNSOCK ] { 1 }
@@ -68,7 +65,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 4.2.9 }
+ Constant [ string SWOOLE_VERSION ] { 4.2.10 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -159,6 +156,9 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
Constant [ integer SWOOLE_TRACE_AIO ] { 262144 }
Constant [ integer SWOOLE_TRACE_SSL ] { 524288 }
Constant [ integer SWOOLE_TRACE_NORMAL ] { 1048576 }
+ Constant [ integer SWOOLE_TRACE_CHANNEL ] { 2097152 }
+ Constant [ integer SWOOLE_TRACE_TIMER ] { 4194304 }
+ Constant [ integer SWOOLE_TRACE_SOCKET ] { 8388608 }
Constant [ integer SWOOLE_TRACE_ALL ] { 4294967295 }
Constant [ integer SWOOLE_LOG_DEBUG ] { 0 }
Constant [ integer SWOOLE_LOG_TRACE ] { 1 }
@@ -177,9 +177,20 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
Constant [ integer SWOOLE_REDIS_TYPE_LIST ] { 3 }
Constant [ integer SWOOLE_REDIS_TYPE_ZSET ] { 4 }
Constant [ integer SWOOLE_REDIS_TYPE_HASH ] { 5 }
+ Constant [ integer SWOOLE_REDIS_ERR_IO ] { 1 }
+ Constant [ integer SWOOLE_REDIS_ERR_OTHER ] { 2 }
+ Constant [ integer SWOOLE_REDIS_ERR_EOF ] { 3 }
+ Constant [ integer SWOOLE_REDIS_ERR_PROTOCOL ] { 4 }
+ Constant [ integer SWOOLE_REDIS_ERR_OOM ] { 5 }
+ Constant [ integer SWOOLE_REDIS_ERR_CLOSED ] { 6 }
+ Constant [ integer SWOOLE_REDIS_ERR_NOAUTH ] { 7 }
+ Constant [ integer SWOOLE_REDIS_ERR_ALLOC ] { 8 }
Constant [ integer SW_PGSQL_ASSOC ] { 1 }
Constant [ integer SW_PGSQL_NUM ] { 2 }
Constant [ integer SW_PGSQL_BOTH ] { 3 }
+ Constant [ integer SWOOLE_HTTP_CLIENT_ESTATUS_CONNECT_FAILED ] { -1 }
+ Constant [ integer SWOOLE_HTTP_CLIENT_ESTATUS_REQUEST_TIMEOUT ] { -2 }
+ Constant [ integer SWOOLE_HTTP_CLIENT_ESTATUS_SERVER_RESET ] { -3 }
Constant [ integer SWOOLE_DEFAULT_MAX_CORO_NUM ] { 3000 }
Constant [ integer SWOOLE_MAX_CORO_NUM_LIMIT ] { 9223372036854775807 }
Constant [ integer SWOOLE_MAX_CORO_NESTING_LEVEL ] { 128 }
@@ -418,8 +429,9 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
Function [ <internal:swoole> function swoole_async_dns_lookup_coro ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $domain_name ]
+ Parameter #1 [ <optional> $timeout ]
}
}
Function [ <internal:swoole> function swoole_coroutine_create ] {
@@ -531,23 +543,23 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
- Properties [29] {
- Property [ <default> public $onConnect ]
- Property [ <default> public $onReceive ]
- Property [ <default> public $onClose ]
- Property [ <default> public $onPacket ]
- Property [ <default> public $onBufferFull ]
- Property [ <default> public $onBufferEmpty ]
- Property [ <default> public $onStart ]
- Property [ <default> public $onShutdown ]
- Property [ <default> public $onWorkerStart ]
- Property [ <default> public $onWorkerStop ]
- Property [ <default> public $onWorkerExit ]
- Property [ <default> public $onWorkerError ]
- Property [ <default> public $onTask ]
- Property [ <default> public $onFinish ]
- Property [ <default> public $onManagerStart ]
- Property [ <default> public $onManagerStop ]
- Property [ <default> public $onPipeMessage ]
+ Property [ <default> private $onConnect ]
+ Property [ <default> private $onReceive ]
+ Property [ <default> private $onClose ]
+ Property [ <default> private $onPacket ]
+ Property [ <default> private $onBufferFull ]
+ Property [ <default> private $onBufferEmpty ]
+ Property [ <default> private $onStart ]
+ Property [ <default> private $onShutdown ]
+ Property [ <default> private $onWorkerStart ]
+ Property [ <default> private $onWorkerStop ]
+ Property [ <default> private $onWorkerExit ]
+ Property [ <default> private $onWorkerError ]
+ Property [ <default> private $onTask ]
+ Property [ <default> private $onFinish ]
+ Property [ <default> private $onManagerStart ]
+ Property [ <default> private $onManagerStop ]
+ Property [ <default> private $onPipeMessage ]
Property [ <default> public $setting ]
Property [ <default> public $connections ]
Property [ <default> public $host ]
@@ -1057,8 +1069,9 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
Method [ <internal:swoole> static public method dnsLookupCoro ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $domain_name ]
+ Parameter #1 [ <optional> $timeout ]
}
}
@@ -1495,7 +1508,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
- Class [ <internal:swoole> final class Swoole\Coroutine\Socket ] {
+ Class [ <internal:swoole> class Swoole\Coroutine\Socket ] {
- Constants [0] {
}
@@ -1610,7 +1623,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
- Class [ <internal:swoole> class Swoole\Coroutine\Socket\Exception extends Exception implements Throwable ] {
+ Class [ <internal:swoole> class Swoole\Coroutine\Socket\Exception extends Swoole\Exception implements Throwable ] {
- Constants [0] {
}
@@ -1830,17 +1843,18 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
- Static methods [0] {
}
- - Properties [7] {
- Property [ <default> public $setting ]
+ - Properties [8] {
Property [ <default> public $host ]
Property [ <default> public $port ]
+ Property [ <default> public $setting ]
Property [ <default> public $sock ]
Property [ <default> public $connected ]
+ Property [ <default> public $errType ]
Property [ <default> public $errCode ]
Property [ <default> public $errMsg ]
}
- - Methods [155] {
+ - Methods [156] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -1858,11 +1872,18 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
- Parameters [3] {
Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
+ Parameter #1 [ <optional> $port ]
Parameter #2 [ <optional> $serialize ]
}
}
+ Method [ <internal:swoole> public method setOptions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $options ]
+ }
+ }
+
Method [ <internal:swoole> public method setDefer ] {
}
@@ -3186,7 +3207,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
- Properties [9] {
- Property [ <default> private $serverInfo ]
+ Property [ <default> public $serverInfo ]
Property [ <default> public $sock ]
Property [ <default> public $connected ]
Property [ <default> public $connect_error ]
@@ -3348,7 +3369,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
- Class [ <internal:swoole> class Swoole\Coroutine\MySQL\Exception extends Exception implements Throwable ] {
+ Class [ <internal:swoole> class Swoole\Coroutine\MySQL\Exception extends Swoole\Exception implements Throwable ] {
- Constants [0] {
}
@@ -3416,13 +3437,14 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
- Static methods [0] {
}
- - Properties [17] {
+ - Properties [18] {
Property [ <default> public $errCode ]
- Property [ <default> public $type ]
- Property [ <default> public $setting ]
+ Property [ <default> public $errMsg ]
Property [ <default> public $connected ]
Property [ <default> public $host ]
Property [ <default> public $port ]
+ Property [ <default> public $ssl ]
+ Property [ <default> public $setting ]
Property [ <default> public $requestMethod ]
Property [ <default> public $requestHeaders ]
Property [ <default> public $requestBody ]
@@ -3436,7 +3458,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
Property [ <default> public $body ]
}
- - Methods [20] {
+ - Methods [19] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [3] {
@@ -3459,6 +3481,19 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
+ Method [ <internal:swoole> public method getDefer ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> public method setDefer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $defer ]
+ }
+ }
+
Method [ <internal:swoole> public method setMethod ] {
- Parameters [1] {
@@ -3547,31 +3582,6 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
- Method [ <internal:swoole> public method isConnected ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole> public method close ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole> public method setDefer ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $defer ]
- }
- }
-
- Method [ <internal:swoole> public method getDefer ] {
-
- - Parameters [0] {
- }
- }
-
Method [ <internal:swoole> public method recv ] {
- Parameters [1] {
@@ -3587,6 +3597,12 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
Parameter #2 [ <optional> $finish ]
}
}
+
+ Method [ <internal:swoole> public method close ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -3598,7 +3614,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
- Static properties [0] {
}
- - Static methods [20] {
+ - Static methods [21] {
Method [ <internal:swoole> static public method create ] {
- Parameters [2] {
@@ -3661,6 +3677,12 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
+ Method [ <internal:swoole> static public method getCid ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> static public method getuid ] {
- Parameters [0] {
@@ -3814,7 +3836,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
- Class [ <internal:swoole> class Swoole\ExitException extends Exception implements Throwable ] {
+ Class [ <internal:swoole> class Swoole\ExitException extends Swoole\Exception implements Throwable ] {
- Constants [0] {
}
@@ -3894,12 +3916,14 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
- Static methods [0] {
}
- - Properties [18] {
+ - Properties [20] {
Property [ <default> public $type ]
Property [ <default> public $errCode ]
+ Property [ <default> public $errMsg ]
Property [ <default> public $statusCode ]
Property [ <default> public $host ]
Property [ <default> public $port ]
+ Property [ <default> public $ssl ]
Property [ <default> public $requestMethod ]
Property [ <default> public $requestHeaders ]
Property [ <default> public $requestBody ]
@@ -4153,9 +4177,10 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
Method [ <internal:swoole> public method useQueue ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <optional> $key ]
Parameter #1 [ <optional> $mode ]
+ Parameter #2 [ <optional> $capacity ]
}
}
@@ -4779,24 +4804,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
- Static methods [0] {
}
- - Properties [31] {
- Property [ <default> public $onConnect ]
- Property [ <default> public $onReceive ]
- Property [ <default> public $onClose ]
- Property [ <default> public $onPacket ]
- Property [ <default> public $onBufferFull ]
- Property [ <default> public $onBufferEmpty ]
- Property [ <default> public $onStart ]
- Property [ <default> public $onShutdown ]
- Property [ <default> public $onWorkerStart ]
- Property [ <default> public $onWorkerStop ]
- Property [ <default> public $onWorkerExit ]
- Property [ <default> public $onWorkerError ]
- Property [ <default> public $onTask ]
- Property [ <default> public $onFinish ]
- Property [ <default> public $onManagerStart ]
- Property [ <default> public $onManagerStop ]
- Property [ <default> public $onPipeMessage ]
+ - Properties [14] {
Property [ <default> public $connections ]
Property [ <default> public $host ]
Property [ <default> public $port ]
@@ -5124,6 +5132,51 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
+ Class [ <internal:swoole> class Swoole\Http\Request ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [10] {
+ Property [ <default> public $fd ]
+ Property [ <default> public $streamId ]
+ Property [ <default> public $header ]
+ Property [ <default> public $server ]
+ Property [ <default> public $request ]
+ Property [ <default> public $cookie ]
+ Property [ <default> public $get ]
+ Property [ <default> public $files ]
+ Property [ <default> public $post ]
+ Property [ <default> public $tmpfiles ]
+ }
+
+ - Methods [3] {
+ Method [ <internal:swoole> public method rawcontent ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> public method getData ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, dtor> public method __destruct ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
Class [ <internal:swoole> class Swoole\Http\Response ] {
- Constants [0] {
@@ -5259,51 +5312,6 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
- Class [ <internal:swoole> class Swoole\Http\Request ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [10] {
- Property [ <default> public $fd ]
- Property [ <default> public $streamId ]
- Property [ <default> public $header ]
- Property [ <default> public $server ]
- Property [ <default> public $request ]
- Property [ <default> public $cookie ]
- Property [ <default> public $get ]
- Property [ <default> public $files ]
- Property [ <default> public $post ]
- Property [ <default> public $tmpfiles ]
- }
-
- - Methods [3] {
- Method [ <internal:swoole> public method rawcontent ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole> public method getData ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole, dtor> public method __destruct ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
Class [ <internal:swoole> class Swoole\Buffer ] {
- Constants [0] {
@@ -5418,24 +5426,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
- - Properties [31] {
- Property [ <default> public $onConnect ]
- Property [ <default> public $onReceive ]
- Property [ <default> public $onClose ]
- Property [ <default> public $onPacket ]
- Property [ <default> public $onBufferFull ]
- Property [ <default> public $onBufferEmpty ]
- Property [ <default> public $onStart ]
- Property [ <default> public $onShutdown ]
- Property [ <default> public $onWorkerStart ]
- Property [ <default> public $onWorkerStop ]
- Property [ <default> public $onWorkerExit ]
- Property [ <default> public $onWorkerError ]
- Property [ <default> public $onTask ]
- Property [ <default> public $onFinish ]
- Property [ <default> public $onManagerStart ]
- Property [ <default> public $onManagerStop ]
- Property [ <default> public $onPipeMessage ]
+ - Properties [14] {
Property [ <default> public $connections ]
Property [ <default> public $host ]
Property [ <default> public $port ]
@@ -5859,10 +5850,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
- - Properties [6] {
- Property [ <default> public $fd ]
- Property [ <default> public $data ]
- Property [ <default> public $finish ]
+ - Properties [3] {
Property [ <default> public $opcode ]
Property [ <default> public $code ]
Property [ <default> public $reason ]
@@ -5988,7 +5976,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
- Class [ <internal:swoole> class Swoole\MySQL\Exception extends Exception implements Throwable ] {
+ Class [ <internal:swoole> class Swoole\MySQL\Exception extends Swoole\Exception implements Throwable ] {
- Constants [0] {
}
@@ -6142,7 +6130,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
Property [ <default> public $errCode ]
}
- - Methods [9] {
+ - Methods [8] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -6150,12 +6138,6 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
- Method [ <internal:swoole, dtor> public method __destruct ] {
-
- - Parameters [0] {
- }
- }
-
Method [ <internal:swoole> public method push ] {
- Parameters [1] {
@@ -6705,24 +6687,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
}
}
- - Properties [29] {
- Property [ <default> public $onConnect ]
- Property [ <default> public $onReceive ]
- Property [ <default> public $onClose ]
- Property [ <default> public $onPacket ]
- Property [ <default> public $onBufferFull ]
- Property [ <default> public $onBufferEmpty ]
- Property [ <default> public $onStart ]
- Property [ <default> public $onShutdown ]
- Property [ <default> public $onWorkerStart ]
- Property [ <default> public $onWorkerStop ]
- Property [ <default> public $onWorkerExit ]
- Property [ <default> public $onWorkerError ]
- Property [ <default> public $onTask ]
- Property [ <default> public $onFinish ]
- Property [ <default> public $onManagerStart ]
- Property [ <default> public $onManagerStop ]
- Property [ <default> public $onPipeMessage ]
+ - Properties [12] {
Property [ <default> public $setting ]
Property [ <default> public $connections ]
Property [ <default> public $host ]
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 5219fa3..0249ad6 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -35,7 +35,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.2.9
+Version: 4.2.10
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
@@ -171,7 +171,7 @@ sed \
cd NTS
# Sanity check, really often broken
-extver=$(sed -n '/#define SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' include/swoole.h)
+extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
exit 1
@@ -185,14 +185,13 @@ cp -pr NTS ZTS
# Create configuration file
cat << 'EOF' | tee %{ini_name}
-; Enable %{summary} extension module
+; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
; Configuration
;swoole.enable_coroutine = On
;swoole.aio_thread_num = 2
;swoole.display_errors = On
-;swoole.use_namespace = On
:swoole.use_shortname = On
;swoole.fast_serialize = Off
;swoole.unixsock_buffer_size = 8388608
@@ -342,6 +341,9 @@ cd ../ZTS
%changelog
+* Thu Dec 20 2018 Remi Collet <remi@remirepo.net> - 4.2.10-1
+- update to 4.2.10
+
* Mon Nov 26 2018 Remi Collet <remi@remirepo.net> - 4.2.9-1
- update to 4.2.9