summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-26 08:59:33 +0100
committerRemi Collet <remi@remirepo.net>2018-11-26 08:59:33 +0100
commitd7e37ea0b562b1b35fb40c16f64887d9e21f0cb7 (patch)
tree2a039f0d4faee49bab58e6127aac71d64a75b229
parentea74626345809ce89433d563d3751ee1fe508bb8 (diff)
v4.2.9
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION52
-rw-r--r--php-pecl-swoole4.spec5
3 files changed, 42 insertions, 17 deletions
diff --git a/PHPINFO b/PHPINFO
index 7b6b059..affa40c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
swoole
swoole support => enabled
-Version => 4.2.8
+Version => 4.2.9
Author => Swoole Group[email: team@swoole.com]
coroutine => enabled
trace_log => enabled
diff --git a/REFLECTION b/REFLECTION
index a2f16fb..ab15450 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #150 swoole version 4.2.8 ] {
+Extension [ <persistent> extension #150 swoole version 4.2.9 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -24,7 +24,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.8 ] {
}
}
- - Constants [225] {
+ - Constants [233] {
Constant [ integer SWOOLE_BASE ] { 1 }
Constant [ integer SWOOLE_PROCESS ] { 2 }
Constant [ integer SWOOLE_IPC_UNSOCK ] { 1 }
@@ -68,7 +68,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.8 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 4.2.8 }
+ Constant [ string SWOOLE_VERSION ] { 4.2.9 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -81,6 +81,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.8 ] {
Constant [ integer SWOOLE_ERROR_DNSLOOKUP_DUPLICATE_REQUEST ] { 703 }
Constant [ integer SWOOLE_ERROR_DNSLOOKUP_RESOLVE_FAILED ] { 704 }
Constant [ integer SWOOLE_ERROR_BAD_IPV6_ADDRESS ] { 705 }
+ Constant [ integer SWOOLE_ERROR_UNREGISTERED_SIGNAL ] { 706 }
Constant [ integer SWOOLE_ERROR_SESSION_CLOSED_BY_SERVER ] { 1001 }
Constant [ integer SWOOLE_ERROR_SESSION_CLOSED_BY_CLIENT ] { 1002 }
Constant [ integer SWOOLE_ERROR_SESSION_CLOSING ] { 1003 }
@@ -104,6 +105,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.8 ] {
Constant [ integer SWOOLE_ERROR_HTTP2_STREAM_NOT_FOUND ] { 3003 }
Constant [ integer SWOOLE_ERROR_AIO_BAD_REQUEST ] { 4001 }
Constant [ integer SWOOLE_ERROR_CLIENT_NO_CONNECTION ] { 5001 }
+ Constant [ integer SWOOLE_ERROR_SOCKET_CLOSED ] { 5002 }
Constant [ integer SWOOLE_ERROR_SOCKS5_UNSUPPORT_VERSION ] { 7001 }
Constant [ integer SWOOLE_ERROR_SOCKS5_UNSUPPORT_METHOD ] { 7002 }
Constant [ integer SWOOLE_ERROR_SOCKS5_AUTH_FAILED ] { 7003 }
@@ -123,7 +125,8 @@ Extension [ <persistent> extension #150 swoole version 4.2.8 ] {
Constant [ integer SWOOLE_ERROR_SERVER_NO_IDLE_WORKER ] { 9007 }
Constant [ integer SWOOLE_ERROR_SERVER_ONLY_START_ONE ] { 9008 }
Constant [ integer SWOOLE_ERROR_SERVER_SEND_IN_MASTER ] { 9009 }
- Constant [ integer SWOOLE_ERROR_SERVER_WORKER_EXIT_TIMEOUT ] { 9010 }
+ Constant [ integer SWOOLE_ERROR_SERVER_INVALID_REQUEST ] { 9010 }
+ Constant [ integer SWOOLE_ERROR_SERVER_WORKER_EXIT_TIMEOUT ] { 9011 }
Constant [ integer SWOOLE_ERROR_CO_OUT_OF_COROUTINE ] { 10001 }
Constant [ integer SWOOLE_ERROR_CO_HAS_BEEN_BOUND ] { 10002 }
Constant [ integer SWOOLE_ERROR_CO_MUTEX_DOUBLE_UNLOCK ] { 10003 }
@@ -178,7 +181,12 @@ Extension [ <persistent> extension #150 swoole version 4.2.8 ] {
Constant [ integer SW_PGSQL_NUM ] { 2 }
Constant [ integer SW_PGSQL_BOTH ] { 3 }
Constant [ integer SWOOLE_DEFAULT_MAX_CORO_NUM ] { 3000 }
- Constant [ integer SWOOLE_MAX_CORO_NUM_LIMIT ] { 524288 }
+ Constant [ integer SWOOLE_MAX_CORO_NUM_LIMIT ] { 9223372036854775807 }
+ Constant [ integer SWOOLE_MAX_CORO_NESTING_LEVEL ] { 128 }
+ Constant [ integer SWOOLE_CORO_INIT ] { 0 }
+ Constant [ integer SWOOLE_CORO_WAITING ] { 1 }
+ Constant [ integer SWOOLE_CORO_RUNNING ] { 2 }
+ Constant [ integer SWOOLE_CORO_END ] { 3 }
Constant [ integer SWOOLE_EXIT_IN_COROUTINE ] { 2 }
Constant [ integer SWOOLE_EXIT_IN_SERVER ] { 4 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
@@ -426,6 +434,12 @@ Extension [ <persistent> extension #150 swoole version 4.2.8 ] {
Parameter #0 [ <required> $command ]
}
}
+ Function [ <internal:swoole> function swoole_coroutine_defer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
Function [ <internal:swoole> function go ] {
- Parameters [1] {
@@ -1308,13 +1322,13 @@ Extension [ <persistent> extension #150 swoole version 4.2.8 ] {
Property [ <default> public $type ]
Property [ <default> public $id ]
Property [ <default> public $setting ]
- Property [ <default> public $onConnect ]
- Property [ <default> public $onError ]
- Property [ <default> public $onReceive ]
- Property [ <default> public $onClose ]
- Property [ <default> public $onBufferFull ]
- Property [ <default> public $onBufferEmpty ]
- Property [ <default> public $onSSLReady ]
+ Property [ <default> private $onConnect ]
+ Property [ <default> private $onError ]
+ Property [ <default> private $onReceive ]
+ Property [ <default> private $onClose ]
+ Property [ <default> private $onBufferFull ]
+ Property [ <default> private $onBufferEmpty ]
+ Property [ <default> private $onSSLReady ]
}
- Methods [23] {
@@ -3584,11 +3598,12 @@ Extension [ <persistent> extension #150 swoole version 4.2.8 ] {
- Static properties [0] {
}
- - Static methods [19] {
+ - Static methods [20] {
Method [ <internal:swoole> static public method create ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $func ]
+ Parameter #1 [ <optional> ...$params ]
}
}
@@ -3607,6 +3622,13 @@ Extension [ <persistent> extension #150 swoole version 4.2.8 ] {
}
}
+ Method [ <internal:swoole> static public method defer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
+
Method [ <internal:swoole> static public method set ] {
- Parameters [1] {
@@ -6297,7 +6319,7 @@ Extension [ <persistent> extension #150 swoole version 4.2.8 ] {
}
}
- Method [ <internal:swoole> public method destory ] {
+ Method [ <internal:swoole> public method destroy ] {
- Parameters [0] {
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 868559f..5219fa3 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -35,7 +35,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.2.8
+Version: 4.2.9
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
@@ -342,6 +342,9 @@ cd ../ZTS
%changelog
+* Mon Nov 26 2018 Remi Collet <remi@remirepo.net> - 4.2.9-1
+- update to 4.2.9
+
* Mon Nov 19 2018 Remi Collet <remi@remirepo.net> - 4.2.8-1
- update to 4.2.8