summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole4.spec')
-rw-r--r--php-pecl-swoole4.spec10
1 files changed, 6 insertions, 4 deletions
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 5219fa3..0249ad6 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -35,7 +35,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.2.9
+Version: 4.2.10
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
@@ -171,7 +171,7 @@ sed \
cd NTS
# Sanity check, really often broken
-extver=$(sed -n '/#define SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' include/swoole.h)
+extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
exit 1
@@ -185,14 +185,13 @@ cp -pr NTS ZTS
# Create configuration file
cat << 'EOF' | tee %{ini_name}
-; Enable %{summary} extension module
+; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
; Configuration
;swoole.enable_coroutine = On
;swoole.aio_thread_num = 2
;swoole.display_errors = On
-;swoole.use_namespace = On
:swoole.use_shortname = On
;swoole.fast_serialize = Off
;swoole.unixsock_buffer_size = 8388608
@@ -342,6 +341,9 @@ cd ../ZTS
%changelog
+* Thu Dec 20 2018 Remi Collet <remi@remirepo.net> - 4.2.10-1
+- update to 4.2.10
+
* Mon Nov 26 2018 Remi Collet <remi@remirepo.net> - 4.2.9-1
- update to 4.2.9