summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-09 14:54:05 +0200
committerRemi Collet <remi@remirepo.net>2021-04-09 14:54:05 +0200
commit3e8c1ef24c2258f298c31b83695ac252d8a4b67a (patch)
tree5b3c7a47e2c2bfa13c6500fc0357608896623fac
parent15c48d81f599f61d1dff494ce13bbf38be41016d (diff)
update to 1.10.0alpha1
with libbson and libmongoc 1.18.0alpha with libmongocrypt 1.2.1dev
-rw-r--r--PHPINFO13
-rw-r--r--REFLECTION60
-rw-r--r--php-pecl-mongodb.spec43
3 files changed, 85 insertions, 31 deletions
diff --git a/PHPINFO b/PHPINFO
index 3596e6f..fcdc160 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,10 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.9.1
-MongoDB extension stability => stable
-libbson headers version => 1.17.4
-libbson library version => 1.17.4
-libmongoc headers version => 1.17.4
-libmongoc library version => 1.17.4
+MongoDB extension version => 1.10.0alpha1
+MongoDB extension stability => alpha
+libbson bundled version => 1.18.0-alpha
+libmongoc bundled version => 1.18.0-alpha
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
@@ -19,8 +17,7 @@ libmongoc compression => enabled
libmongoc compression snappy => enabled
libmongoc compression zlib => enabled
libmongoc compression zstd => enabled
-libmongocrypt headers version => 1.2.0
-libmongocrypt library version => 1.2.0
+libmongocrypt bundled version => 1.2.1-dev+20210209git79f5bda042
libmongocrypt crypto => enabled
libmongocrypt crypto library => libcrypto
diff --git a/REFLECTION b/REFLECTION
index 361b86e..ddb1f13 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #115 mongodb version 1.9.1 ] {
+Extension [ <persistent> extension #115 mongodb version 1.10.0alpha1 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,8 +14,8 @@ Extension [ <persistent> extension #115 mongodb version 1.9.1 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.9.1 }
- Constant [ string MONGODB_STABILITY ] { stable }
+ Constant [ string MONGODB_VERSION ] { 1.10.0alpha1 }
+ Constant [ string MONGODB_STABILITY ] { alpha }
}
- Functions {
@@ -70,7 +70,7 @@ Extension [ <persistent> extension #115 mongodb version 1.9.1 ] {
}
}
- - Classes [62] {
+ - Classes [63] {
Interface [ <internal:mongodb> interface MongoDB\BSON\Type ] {
- Constants [0] {
@@ -1965,6 +1965,58 @@ Extension [ <persistent> extension #115 mongodb version 1.9.1 ] {
}
}
+ Class [ <internal:mongodb> final class MongoDB\Driver\ServerApi implements MongoDB\BSON\Serializable, MongoDB\BSON\Type, Serializable ] {
+
+ - Constants [1] {
+ Constant [ public string V1 ] { 1 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $version ]
+ Parameter #1 [ <optional> bool or NULL $strict ]
+ Parameter #2 [ <optional> bool or NULL $deprecationErrors ]
+ }
+ }
+
+ Method [ <internal:mongodb, prototype MongoDB\BSON\Serializable> final public method bsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ }
+ }
+ }
+
Class [ <internal:mongodb> final class MongoDB\Driver\Session ] {
- Constants [5] {
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 75106c2..0e8f74d 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -26,24 +26,28 @@
%bcond_with tests
# temp for EL-8 until available in EPEL
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 8
-%global with_syslib 1
-%global libmongo 1.17.4
+%if 0%{?fedora} >= 99 || 0%{?rhel} >= 9
+%bcond_without syslib
+%else
+%bcond_with syslib
+%endif
+
+%if %{with syslib}
+%global libmongo 1.18.0
#global libmongover #{libmongo}
%global libmongover %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libmongo})
-%global libcrypt 1.2.0
+%global libcrypt 1.2.1
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
-%global with_syslib 0
-%global libmongo 1.17.4
-%global libcrypt 1.0.4
+%global libmongo 1.18.0~alpha
+%global libcrypt 1.2.1~dev
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.9.1
-#global upstream_prever RC1
-#global upstream_lower ~rc1
+%global upstream_version 1.10.0
+%global upstream_prever alpha1
+%global upstream_lower ~alpha1
Version: %{upstream_version}%{?upstream_lower}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
@@ -55,7 +59,7 @@ BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
-%if %{with_syslib}
+%if %{with syslib}
BuildRequires: pkgconfig(libbson-1.0) >= %{libmongo}
BuildRequires: pkgconfig(libmongoc-1.0) >= %{libmongo}
BuildRequires: pkgconfig(libmongocrypt) >= %{libcrypt}
@@ -173,27 +177,23 @@ EOF
peclbuild() {
%{_bindir}/${1}ize
-%if %{with_syslib}
+%if %{with syslib}
# Ensure we use system library
# Need to be removed only after phpize because of m4_include
rm -r src/libmongoc*
%configure \
- --with-php-config=%{_bindir}/${1}-config \
--with-mongodb-system-libs \
- --with-mongodb-client-side-encryption \
- --enable-mongodb
%else
-
%configure \
- --with-php-config=%{_bindir}/${1}-config \
--enable-mongodb-crypto-system-profile \
- --with-mongodb-client-side-encryption \
--with-mongodb-sasl=cyrus \
--with-mongodb-icu=yes \
--with-mongodb-ssl=openssl \
- --enable-mongodb
%endif
+ --with-php-config=%{_bindir}/${1}-config \
+ --with-mongodb-client-side-encryption \
+ --enable-mongodb
make %{?_smp_mflags}
}
@@ -335,6 +335,11 @@ exit $ret
%changelog
+* Fri Apr 9 2021 Remi Collet <remi@remirepo.net> - 1.10.0~alpha1-1
+- update to 1.10.0alpha1
+- with libbson and libmongoc 1.18.0alpha
+- with libmongocrypt 1.2.1dev
+
* Wed Apr 7 2021 Remi Collet <remi@remirepo.net> - 1.9.1-1
- update to 1.9.1
- with libbson and libmongoc 1.17.4