summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec43
1 files changed, 24 insertions, 19 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 75106c2..0e8f74d 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -26,24 +26,28 @@
%bcond_with tests
# temp for EL-8 until available in EPEL
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 8
-%global with_syslib 1
-%global libmongo 1.17.4
+%if 0%{?fedora} >= 99 || 0%{?rhel} >= 9
+%bcond_without syslib
+%else
+%bcond_with syslib
+%endif
+
+%if %{with syslib}
+%global libmongo 1.18.0
#global libmongover #{libmongo}
%global libmongover %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libmongo})
-%global libcrypt 1.2.0
+%global libcrypt 1.2.1
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
-%global with_syslib 0
-%global libmongo 1.17.4
-%global libcrypt 1.0.4
+%global libmongo 1.18.0~alpha
+%global libcrypt 1.2.1~dev
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.9.1
-#global upstream_prever RC1
-#global upstream_lower ~rc1
+%global upstream_version 1.10.0
+%global upstream_prever alpha1
+%global upstream_lower ~alpha1
Version: %{upstream_version}%{?upstream_lower}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
@@ -55,7 +59,7 @@ BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
-%if %{with_syslib}
+%if %{with syslib}
BuildRequires: pkgconfig(libbson-1.0) >= %{libmongo}
BuildRequires: pkgconfig(libmongoc-1.0) >= %{libmongo}
BuildRequires: pkgconfig(libmongocrypt) >= %{libcrypt}
@@ -173,27 +177,23 @@ EOF
peclbuild() {
%{_bindir}/${1}ize
-%if %{with_syslib}
+%if %{with syslib}
# Ensure we use system library
# Need to be removed only after phpize because of m4_include
rm -r src/libmongoc*
%configure \
- --with-php-config=%{_bindir}/${1}-config \
--with-mongodb-system-libs \
- --with-mongodb-client-side-encryption \
- --enable-mongodb
%else
-
%configure \
- --with-php-config=%{_bindir}/${1}-config \
--enable-mongodb-crypto-system-profile \
- --with-mongodb-client-side-encryption \
--with-mongodb-sasl=cyrus \
--with-mongodb-icu=yes \
--with-mongodb-ssl=openssl \
- --enable-mongodb
%endif
+ --with-php-config=%{_bindir}/${1}-config \
+ --with-mongodb-client-side-encryption \
+ --enable-mongodb
make %{?_smp_mflags}
}
@@ -335,6 +335,11 @@ exit $ret
%changelog
+* Fri Apr 9 2021 Remi Collet <remi@remirepo.net> - 1.10.0~alpha1-1
+- update to 1.10.0alpha1
+- with libbson and libmongoc 1.18.0alpha
+- with libmongocrypt 1.2.1dev
+
* Wed Apr 7 2021 Remi Collet <remi@remirepo.net> - 1.9.1-1
- update to 1.9.1
- with libbson and libmongoc 1.17.4