summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-08 08:54:53 +0200
committerRemi Collet <remi@remirepo.net>2021-04-08 08:54:53 +0200
commit15c48d81f599f61d1dff494ce13bbf38be41016d (patch)
treef3aadf88ecc07f2d93e4639bd5bb30aac8e37140
parentd8195e99a648861b6fe04ad7d0f8e9764f782823 (diff)
update to 1.9.1
with libbson and libmongoc 1.17.4
-rw-r--r--PHPINFO14
-rw-r--r--REFLECTION6
-rw-r--r--php-pecl-mongodb.spec35
3 files changed, 24 insertions, 31 deletions
diff --git a/PHPINFO b/PHPINFO
index bcd3b1a..3596e6f 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.9.0
+MongoDB extension version => 1.9.1
MongoDB extension stability => stable
-libbson headers version => 1.17.2
-libbson library version => 1.17.2
-libmongoc headers version => 1.17.2
-libmongoc library version => 1.17.2
+libbson headers version => 1.17.4
+libbson library version => 1.17.4
+libmongoc headers version => 1.17.4
+libmongoc library version => 1.17.4
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
@@ -19,8 +19,8 @@ libmongoc compression => enabled
libmongoc compression snappy => enabled
libmongoc compression zlib => enabled
libmongoc compression zstd => enabled
-libmongocrypt headers version => 1.0.4
-libmongocrypt library version => 1.0.4
+libmongocrypt headers version => 1.2.0
+libmongocrypt library version => 1.2.0
libmongocrypt crypto => enabled
libmongocrypt crypto library => libcrypto
diff --git a/REFLECTION b/REFLECTION
index 96818b6..361b86e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #113 mongodb version 1.9.0 ] {
+Extension [ <persistent> extension #115 mongodb version 1.9.1 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #113 mongodb version 1.9.0 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.9.0 }
+ Constant [ string MONGODB_VERSION ] { 1.9.1 }
Constant [ string MONGODB_STABILITY ] { stable }
}
@@ -1599,7 +1599,7 @@ Extension [ <persistent> extension #113 mongodb version 1.9.0 ] {
Method [ <internal:mongodb> final public method selectServer ] {
- Parameters [1] {
- Parameter #0 [ <required> MongoDB\Driver\ReadPreference or NULL $readPreference ]
+ Parameter #0 [ <required> MongoDB\Driver\ReadPreference $readPreference ]
}
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 73adbbb..75106c2 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-mongodb
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -26,22 +26,22 @@
%bcond_with tests
# temp for EL-8 until available in EPEL
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 8
%global with_syslib 1
-%global libmongo 1.17
+%global libmongo 1.17.4
#global libmongover #{libmongo}
%global libmongover %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libmongo})
-%global libcrypt 1.0.1
+%global libcrypt 1.2.0
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
%global with_syslib 0
-%global libmongo 1.17.2
+%global libmongo 1.17.4
%global libcrypt 1.0.4
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.9.0
+%global upstream_version 1.9.1
#global upstream_prever RC1
#global upstream_lower ~rc1
Version: %{upstream_version}%{?upstream_lower}
@@ -50,13 +50,11 @@ License: ASL 2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7.0
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
-%if 0%{?rhel} == 6
-BuildRequires: autoconf268
-%endif
%if %{with_syslib}
BuildRequires: pkgconfig(libbson-1.0) >= %{libmongo}
BuildRequires: pkgconfig(libmongoc-1.0) >= %{libmongo}
@@ -69,8 +67,8 @@ BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
BuildRequires: snappy-devel
BuildRequires: zlib-devel
-# We require 50 to ensure use of libicu-last (same version than PHP)
-BuildRequires: libicu-devel >= 50
+# We require 65 to ensure use of libicu-last (same version than PHP)
+BuildRequires: libicu-devel >= 65
Provides: bundled(libbson) = %{libmongo}
Provides: bundled(mongo-c-driver) = %{libmongo}
Provides: bundled(libmongocrypt) = %{libcrypt}
@@ -122,12 +120,6 @@ Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
The purpose of this driver is to provide exceptionally thin glue between
@@ -176,9 +168,6 @@ EOF
%build
-%if 0%{?rhel} == 6
-export PHP_AUTOCONF=autoconf268;export PHP_AUTOHEADER=autoheader268
-%endif
%{?dtsenable}
peclbuild() {
@@ -346,6 +335,10 @@ exit $ret
%changelog
+* Wed Apr 7 2021 Remi Collet <remi@remirepo.net> - 1.9.1-1
+- update to 1.9.1
+- with libbson and libmongoc 1.17.4
+
* Wed Nov 25 2020 Remi Collet <remi@remirepo.net> - 1.9.0-1
- update to 1.9.0 (stable)