summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0001-add-extension-version-in-phpinfo.patch26
-rw-r--r--0002-drop-null-value-deprecated-in-8.1.patch100
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION26
-rw-r--r--php-pecl-mcrypt.spec91
5 files changed, 60 insertions, 185 deletions
diff --git a/0001-add-extension-version-in-phpinfo.patch b/0001-add-extension-version-in-phpinfo.patch
deleted file mode 100644
index 44af7f2..0000000
--- a/0001-add-extension-version-in-phpinfo.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 6cf8c800f2926b65867b10dfe582bbb4596d1b7e Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Wed, 2 Dec 2020 11:37:43 +0100
-Subject: [PATCH 1/2] add extension version in phpinfo
-
----
- mcrypt.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/mcrypt.c b/mcrypt.c
-index 20f6aae..b834ffe 100644
---- a/mcrypt.c
-+++ b/mcrypt.c
-@@ -480,7 +480,8 @@ PHP_MINFO_FUNCTION(mcrypt) /* {{{ */
- php_info_print_table_start();
- php_info_print_table_header(2, "mcrypt support", "enabled");
- php_info_print_table_header(2, "mcrypt_filter support", "enabled");
-- php_info_print_table_row(2, "Version", LIBMCRYPT_VERSION);
-+ php_info_print_table_row(2, "Extension version", PHP_MCRYPT_VERSION);
-+ php_info_print_table_row(2, "Library version", LIBMCRYPT_VERSION);
- php_info_print_table_row(2, "Api No", mcrypt_api_no);
- php_info_print_table_row(2, "Supported ciphers", ZSTR_VAL(tmp1.s));
- php_info_print_table_row(2, "Supported modes", ZSTR_VAL(tmp2.s));
---
-2.31.1
-
diff --git a/0002-drop-null-value-deprecated-in-8.1.patch b/0002-drop-null-value-deprecated-in-8.1.patch
deleted file mode 100644
index 3554ff3..0000000
--- a/0002-drop-null-value-deprecated-in-8.1.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-From 5b16bf1c97c1bbab400fc877285bf0919ae73256 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Wed, 9 Jun 2021 10:49:51 +0200
-Subject: [PATCH 2/2] drop null value, deprecated in 8.1
-
----
- tests/mcrypt_rijndael128_128BitKey.phpt | 30 ++++++-------------------
- 1 file changed, 7 insertions(+), 23 deletions(-)
-
-diff --git a/tests/mcrypt_rijndael128_128BitKey.phpt b/tests/mcrypt_rijndael128_128BitKey.phpt
-index ffc5e39..84abac8 100644
---- a/tests/mcrypt_rijndael128_128BitKey.phpt
-+++ b/tests/mcrypt_rijndael128_128BitKey.phpt
-@@ -32,14 +32,12 @@ $data = 'This is the secret message which must be encrypted';
-
- // keys up to 128 bits (16 bytes)
- $keys = array(
-- null,
- '',
- '12345678',
- '1234567890123456'
- );
- // rijndael128 is a block cipher of 128 bits (16 bytes)
- $ivs = array(
-- null,
- '',
- '12345678',
- '1234567890123456',
-@@ -72,61 +70,47 @@ foreach ($ivs as $iv) {
-
- key length=0
-
--Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 45
--
--Warning: mcrypt_encrypt(): Key of size 0 not supported by this algorithm. Only keys of sizes 16, 24 or 32 supported in %s on line %d
--string(0) ""
--
--key length=0
--
--Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 45
-+Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
-
- Warning: mcrypt_encrypt(): Key of size 0 not supported by this algorithm. Only keys of sizes 16, 24 or 32 supported in %s on line %d
- string(0) ""
-
- key length=8
-
--Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 45
-+Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
-
- Warning: mcrypt_encrypt(): Key of size 8 not supported by this algorithm. Only keys of sizes 16, 24 or 32 supported in %s on line %d
- string(0) ""
-
- key length=16
-
--Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 45
-+Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
- string(128) "dc8f957ec530acf10cd95ba7da7b6405380fe19a2941e9a8de54680512f18491bc374e5464885ae6c2ae2aa7a6cdd2fbe12a06bbc4bd59dbbfaa15f09044f101"
-
- --- testing different iv lengths
-
- iv length=0
-
--Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 53
--
--Warning: mcrypt_decrypt(): Received initialization vector of size 0, but size 16 is required for this encryption mode in %s on line %d
--string(0) ""
--
--iv length=0
--
--Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 53
-+Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
-
- Warning: mcrypt_decrypt(): Received initialization vector of size 0, but size 16 is required for this encryption mode in %s on line %d
- string(0) ""
-
- iv length=8
-
--Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 53
-+Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
-
- Warning: mcrypt_decrypt(): Received initialization vector of size 8, but size 16 is required for this encryption mode in %s on line %d
- string(0) ""
-
- iv length=16
-
--Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 53
-+Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
- string(32) "42adc8c0db19473f2c684ff2d6e828a5"
-
- iv length=17
-
--Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 53
-+Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
-
- Warning: mcrypt_decrypt(): Received initialization vector of size 17, but size 16 is required for this encryption mode in %s on line %d
- string(0) ""
---
-2.31.1
-
diff --git a/PHPINFO b/PHPINFO
index b11e4d6..1e5b6c4 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,7 +3,7 @@ mcrypt
mcrypt support => enabled
mcrypt_filter support => enabled
-Extension version => 1.0.4
+Extension version => 1.0.7
Library version => 2.5.8
Api No => 20021217
Supported ciphers => cast-128 gost rijndael-128 twofish arcfour cast-256 loki97 rijndael-192 saferplus wake blowfish-compat des rijndael-256 serpent xtea blowfish enigma rc2 tripledes
diff --git a/REFLECTION b/REFLECTION
index 7d48f0b..198db76 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 mcrypt version 1.0.4 ] {
+Extension [ <persistent> extension #55 mcrypt version 1.0.7 ] {
- INI {
Entry [ mcrypt.algorithms_dir <ALL> ]
@@ -78,19 +78,19 @@ Extension [ <persistent> extension #119 mcrypt version 1.0.4 ] {
- Parameters [2] {
Parameter #0 [ <required> $size ]
- Parameter #1 [ <optional> $source ]
+ Parameter #1 [ <optional> $source = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_list_algorithms ] {
- Parameters [1] {
- Parameter #0 [ <optional> $lib_dir ]
+ Parameter #0 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_list_modes ] {
- Parameters [1] {
- Parameter #0 [ <optional> $lib_dir ]
+ Parameter #0 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_get_iv_size ] {
@@ -107,7 +107,7 @@ Extension [ <persistent> extension #119 mcrypt version 1.0.4 ] {
Parameter #1 [ <required> $key ]
Parameter #2 [ <required> $data ]
Parameter #3 [ <required> $mode ]
- Parameter #4 [ <optional> $iv ]
+ Parameter #4 [ <optional> $iv = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_decrypt ] {
@@ -117,7 +117,7 @@ Extension [ <persistent> extension #119 mcrypt version 1.0.4 ] {
Parameter #1 [ <required> $key ]
Parameter #2 [ <required> $data ]
Parameter #3 [ <required> $mode ]
- Parameter #4 [ <optional> $iv ]
+ Parameter #4 [ <optional> $iv = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_open ] {
@@ -221,49 +221,49 @@ Extension [ <persistent> extension #119 mcrypt version 1.0.4 ] {
- Parameters [2] {
Parameter #0 [ <required> $algorithm ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_is_block_algorithm_mode ] {
- Parameters [2] {
Parameter #0 [ <required> $mode ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_is_block_algorithm ] {
- Parameters [2] {
Parameter #0 [ <required> $algorithm ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_is_block_mode ] {
- Parameters [2] {
Parameter #0 [ <required> $mode ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_get_algo_block_size ] {
- Parameters [2] {
Parameter #0 [ <required> $algorithm ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_get_algo_key_size ] {
- Parameters [2] {
Parameter #0 [ <required> $algorithm ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_get_supported_key_sizes ] {
- Parameters [2] {
Parameter #0 [ <required> $algorithm ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_close ] {
diff --git a/php-pecl-mcrypt.spec b/php-pecl-mcrypt.spec
index f1c126f..97a4534 100644
--- a/php-pecl-mcrypt.spec
+++ b/php-pecl-mcrypt.spec
@@ -1,32 +1,30 @@
# remirepo spec file for php-pecl-mcrypt
#
-# Copyright (c) 2017-2021 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2017-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
+%{?scl:%scl_package php-pecl-mcrypt}
-%{?scl: %scl_package php-pecl-mcrypt}
+%bcond_without tests
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name mcrypt
%global ini_name 30-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: Bindings for the libmcrypt library
Name: %{?scl_prefix}php-pecl-mcrypt
-Version: 1.0.4
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: PHP
+Version: 1.0.7
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: PHP-3.01
URL: https://pecl.php.net/package/mcrypt
-Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-
-Patch0: 0001-add-extension-version-in-phpinfo.patch
-Patch1: 0002-drop-null-value-deprecated-in-8.1.patch
+Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -36,7 +34,6 @@ BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
@@ -46,7 +43,7 @@ Provides: %{?scl_prefix}php-%{pecl_name} = 1:%{version}-%{release}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = 1:%{version}-%{release}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel} == 7
Obsoletes: php54u-%{pecl_name} < 7.2
Obsoletes: php54w-%{pecl_name} < 7.2
Obsoletes: php55u-%{pecl_name} < 7.2
@@ -66,12 +63,6 @@ Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
%endif
@@ -83,54 +74,51 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -c -q
-mv %{pecl_name}-%{version}%{?prever} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
-cd NTS
-%patch0 -p1
-%patch1 -p1
-
+cd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_MCRYPT_VERSION/{s/.* "//;s/".*$//;p}' php_mcrypt.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
exit 1
fi
-
cd ..
+
: Create the configuration file
cat >%{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}
EOF
+mkdir NTS
%if %{with_zts}
-: Duplicate sources tree for ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
--with-mcrypt \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--with-mcrypt \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -151,22 +139,21 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
-cd NTS
+cd %{sources}
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
%check
+cd %{sources}
# Warning: Use of undefined constant MCRYPT_CBC - assumed 'MCRYPT_CBC'
-rm ?TS/tests/bug8040.phpt
+rm tests/bug8040.phpt
-cd NTS
: minimal load test of NTS extension
-%{_bindir}/php --no-php-ini \
- --define extension_dir=modules \
- --define extension=%{pecl_name} \
- --modules | grep %{pecl_name}
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
%if "%{php_version}" > "7.4"
OPT="%{?_smp_mflags} -q --show-diff"
@@ -174,24 +161,26 @@ OPT="%{?_smp_mflags} -q --show-diff"
OPT="-q --show-diff"
%endif
+%if %{with tests}
: upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
%{__php} -n run-tests.php $OPT
+%endif
%if %{with_zts}
-cd ../ZTS
: minimal load test of ZTS extension
%{__ztsphp} --no-php-ini \
- --define extension_dir=modules \
- --define extension=%{pecl_name} \
- --modules | grep %{pecl_name}
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+%if %{with tests}
: upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%{__ztsphp} -n run-tests.php $OPT
%endif
+%endif
%if 0%{?fedora} < 24 && 0%{?rhel} < 8
@@ -215,7 +204,7 @@ fi
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%{!?_licensedir:%doc %{pecl_docdir}/%{pecl_name}}
%{pecl_xmldir}/%{name}.xml
@@ -229,6 +218,18 @@ fi
%changelog
+* Tue Dec 19 2023 Remi Collet <remi@remirepo.net> - 1.0.7-1
+- update to 1.0.7 (no change)
+
+* Fri Sep 1 2023 Remi Collet <remi@remirepo.net> - 1.0.6-2
+- build out of sources tree
+
+* Wed Mar 1 2023 Remi Collet <remi@remirepo.net> - 1.0.6-1
+- update to 1.0.6 (no change)
+
+* Mon May 23 2022 Remi Collet <remi@remirepo.net> - 1.0.5-1
+- update to 1.0.5
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 1.0.4-5
- rebuild for 8.1.0RC1