summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-19 12:46:27 +0100
committerRemi Collet <remi@php.net>2023-12-19 12:46:27 +0100
commitb186c7bc550b2b522dd4c2f64ac2ff24dd173432 (patch)
treeabbfd2a3726be0ec5626766f192ee06b5985fa9a
parentf775baccc19dc341e4a1d229c65fbab80c172387 (diff)
update to 1.0.7 (no change)HEADmaster
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-mcrypt.spec59
3 files changed, 32 insertions, 31 deletions
diff --git a/PHPINFO b/PHPINFO
index f2935f8..1e5b6c4 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,7 +3,7 @@ mcrypt
mcrypt support => enabled
mcrypt_filter support => enabled
-Extension version => 1.0.6
+Extension version => 1.0.7
Library version => 2.5.8
Api No => 20021217
Supported ciphers => cast-128 gost rijndael-128 twofish arcfour cast-256 loki97 rijndael-192 saferplus wake blowfish-compat des rijndael-256 serpent xtea blowfish enigma rc2 tripledes
diff --git a/REFLECTION b/REFLECTION
index 6021340..198db76 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #56 mcrypt version 1.0.6 ] {
+Extension [ <persistent> extension #55 mcrypt version 1.0.7 ] {
- INI {
Entry [ mcrypt.algorithms_dir <ALL> ]
diff --git a/php-pecl-mcrypt.spec b/php-pecl-mcrypt.spec
index 4d0998a..97a4534 100644
--- a/php-pecl-mcrypt.spec
+++ b/php-pecl-mcrypt.spec
@@ -7,25 +7,24 @@
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
-
-%{?scl: %scl_package php-pecl-mcrypt}
+%{?scl:%scl_package php-pecl-mcrypt}
%bcond_without tests
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name mcrypt
%global ini_name 30-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: Bindings for the libmcrypt library
Name: %{?scl_prefix}php-pecl-mcrypt
-Version: 1.0.6
+Version: 1.0.7
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
URL: https://pecl.php.net/package/mcrypt
-Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -35,7 +34,6 @@ BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
@@ -76,51 +74,51 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -c -q
-mv %{pecl_name}-%{version}%{?prever} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
-cd NTS
+cd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_MCRYPT_VERSION/{s/.* "//;s/".*$//;p}' php_mcrypt.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
exit 1
fi
-
cd ..
+
: Create the configuration file
cat >%{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}
EOF
+mkdir NTS
%if %{with_zts}
-: Duplicate sources tree for ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
--with-mcrypt \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--with-mcrypt \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -141,22 +139,21 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
-cd NTS
+cd %{sources}
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
%check
+cd %{sources}
# Warning: Use of undefined constant MCRYPT_CBC - assumed 'MCRYPT_CBC'
-rm ?TS/tests/bug8040.phpt
+rm tests/bug8040.phpt
-cd NTS
: minimal load test of NTS extension
-%{_bindir}/php --no-php-ini \
- --define extension_dir=modules \
- --define extension=%{pecl_name} \
- --modules | grep %{pecl_name}
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
%if "%{php_version}" > "7.4"
OPT="%{?_smp_mflags} -q --show-diff"
@@ -172,12 +169,10 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
%endif
%if %{with_zts}
-cd ../ZTS
: minimal load test of ZTS extension
%{__ztsphp} --no-php-ini \
- --define extension_dir=modules \
- --define extension=%{pecl_name} \
- --modules | grep %{pecl_name}
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
%if %{with tests}
: upstream test suite for ZTS extension
@@ -209,7 +204,7 @@ fi
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%{!?_licensedir:%doc %{pecl_docdir}/%{pecl_name}}
%{pecl_xmldir}/%{name}.xml
@@ -223,6 +218,12 @@ fi
%changelog
+* Tue Dec 19 2023 Remi Collet <remi@remirepo.net> - 1.0.7-1
+- update to 1.0.7 (no change)
+
+* Fri Sep 1 2023 Remi Collet <remi@remirepo.net> - 1.0.6-2
+- build out of sources tree
+
* Wed Mar 1 2023 Remi Collet <remi@remirepo.net> - 1.0.6-1
- update to 1.0.6 (no change)