summaryrefslogtreecommitdiffstats
path: root/php-pecl-mcrypt.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-mcrypt.spec')
-rw-r--r--php-pecl-mcrypt.spec91
1 files changed, 46 insertions, 45 deletions
diff --git a/php-pecl-mcrypt.spec b/php-pecl-mcrypt.spec
index f1c126f..97a4534 100644
--- a/php-pecl-mcrypt.spec
+++ b/php-pecl-mcrypt.spec
@@ -1,32 +1,30 @@
# remirepo spec file for php-pecl-mcrypt
#
-# Copyright (c) 2017-2021 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2017-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
+%{?scl:%scl_package php-pecl-mcrypt}
-%{?scl: %scl_package php-pecl-mcrypt}
+%bcond_without tests
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name mcrypt
%global ini_name 30-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: Bindings for the libmcrypt library
Name: %{?scl_prefix}php-pecl-mcrypt
-Version: 1.0.4
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: PHP
+Version: 1.0.7
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: PHP-3.01
URL: https://pecl.php.net/package/mcrypt
-Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-
-Patch0: 0001-add-extension-version-in-phpinfo.patch
-Patch1: 0002-drop-null-value-deprecated-in-8.1.patch
+Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -36,7 +34,6 @@ BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
@@ -46,7 +43,7 @@ Provides: %{?scl_prefix}php-%{pecl_name} = 1:%{version}-%{release}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = 1:%{version}-%{release}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel} == 7
Obsoletes: php54u-%{pecl_name} < 7.2
Obsoletes: php54w-%{pecl_name} < 7.2
Obsoletes: php55u-%{pecl_name} < 7.2
@@ -66,12 +63,6 @@ Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
%endif
@@ -83,54 +74,51 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -c -q
-mv %{pecl_name}-%{version}%{?prever} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
-cd NTS
-%patch0 -p1
-%patch1 -p1
-
+cd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_MCRYPT_VERSION/{s/.* "//;s/".*$//;p}' php_mcrypt.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
exit 1
fi
-
cd ..
+
: Create the configuration file
cat >%{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}
EOF
+mkdir NTS
%if %{with_zts}
-: Duplicate sources tree for ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
--with-mcrypt \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--with-mcrypt \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -151,22 +139,21 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
-cd NTS
+cd %{sources}
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
%check
+cd %{sources}
# Warning: Use of undefined constant MCRYPT_CBC - assumed 'MCRYPT_CBC'
-rm ?TS/tests/bug8040.phpt
+rm tests/bug8040.phpt
-cd NTS
: minimal load test of NTS extension
-%{_bindir}/php --no-php-ini \
- --define extension_dir=modules \
- --define extension=%{pecl_name} \
- --modules | grep %{pecl_name}
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
%if "%{php_version}" > "7.4"
OPT="%{?_smp_mflags} -q --show-diff"
@@ -174,24 +161,26 @@ OPT="%{?_smp_mflags} -q --show-diff"
OPT="-q --show-diff"
%endif
+%if %{with tests}
: upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
%{__php} -n run-tests.php $OPT
+%endif
%if %{with_zts}
-cd ../ZTS
: minimal load test of ZTS extension
%{__ztsphp} --no-php-ini \
- --define extension_dir=modules \
- --define extension=%{pecl_name} \
- --modules | grep %{pecl_name}
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+%if %{with tests}
: upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%{__ztsphp} -n run-tests.php $OPT
%endif
+%endif
%if 0%{?fedora} < 24 && 0%{?rhel} < 8
@@ -215,7 +204,7 @@ fi
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%{!?_licensedir:%doc %{pecl_docdir}/%{pecl_name}}
%{pecl_xmldir}/%{name}.xml
@@ -229,6 +218,18 @@ fi
%changelog
+* Tue Dec 19 2023 Remi Collet <remi@remirepo.net> - 1.0.7-1
+- update to 1.0.7 (no change)
+
+* Fri Sep 1 2023 Remi Collet <remi@remirepo.net> - 1.0.6-2
+- build out of sources tree
+
+* Wed Mar 1 2023 Remi Collet <remi@remirepo.net> - 1.0.6-1
+- update to 1.0.6 (no change)
+
+* Mon May 23 2022 Remi Collet <remi@remirepo.net> - 1.0.5-1
+- update to 1.0.5
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 1.0.4-5
- rebuild for 8.1.0RC1