summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-04 15:56:09 +0200
committerRemi Collet <remi@remirepo.net>2019-10-04 15:56:09 +0200
commit549e548ebe2115e050c6ef007e356f3035ca49d0 (patch)
tree95b9653b084787fbc18f98e54e112c0204a2915e
parent5f554fbc1f585252559473e57181ad7c3ffc7f2b (diff)
- update to 0.12.8
- drop patch merged upstream
-rw-r--r--650708de9df9039f04eda0fc150bd94e5a5b9753.patch35
-rw-r--r--8380460c38d4e6d8f00c5596f8ebcd3a6be4f25a.patch42
-rw-r--r--zephir.spec21
3 files changed, 13 insertions, 85 deletions
diff --git a/650708de9df9039f04eda0fc150bd94e5a5b9753.patch b/650708de9df9039f04eda0fc150bd94e5a5b9753.patch
deleted file mode 100644
index fd81576..0000000
--- a/650708de9df9039f04eda0fc150bd94e5a5b9753.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 650708de9df9039f04eda0fc150bd94e5a5b9753 Mon Sep 17 00:00:00 2001
-From: Serghei Iakovlev <sadhooklay@gmail.com>
-Date: Fri, 4 Oct 2019 15:39:16 +0300
-Subject: [PATCH] Fixed tests to be able run full test suite without Phalcon
-
----
- CHANGELOG.md | 2 ++
- unit-tests/Extension/InternalClassesTest.php | 8 ++++++++
- 2 files changed, 10 insertions(+)
-
-diff --git a/unit-tests/Extension/InternalClassesTest.php b/unit-tests/Extension/InternalClassesTest.php
-index 6333a8666..d5caee8e5 100644
---- a/unit-tests/Extension/InternalClassesTest.php
-+++ b/unit-tests/Extension/InternalClassesTest.php
-@@ -20,12 +20,20 @@ class InternalClassesTest extends TestCase
- {
- public function testStaticMethodCall()
- {
-+ if (false === class_exists(Di::class)) {
-+ $this->markTestSkipped('Class Phalcon\Di not found');
-+ }
-+
- $class = new InternalClasses();
- $this->assertSame(Di::getDefault(), $class->testStaticCall());
- }
-
- public function testStaticPropertyFetch()
- {
-+ if (false === class_exists(Query::class)) {
-+ $this->markTestSkipped('Class Phalcon\Mvc\Model\Query not found');
-+ }
-+
- $class = new InternalClasses();
- $this->assertSame(Query::TYPE_DELETE, $class->testStaticPropertyFetch());
- }
diff --git a/8380460c38d4e6d8f00c5596f8ebcd3a6be4f25a.patch b/8380460c38d4e6d8f00c5596f8ebcd3a6be4f25a.patch
deleted file mode 100644
index 2b3f038..0000000
--- a/8380460c38d4e6d8f00c5596f8ebcd3a6be4f25a.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 8380460c38d4e6d8f00c5596f8ebcd3a6be4f25a Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 4 Oct 2019 14:04:03 +0200
-Subject: [PATCH] Fix #1946 use ZVAL_NULL
-
----
- kernels/ZendEngine3/string.c | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/kernels/ZendEngine3/string.c b/kernels/ZendEngine3/string.c
-index 69c596364..8c9d4fd70 100644
---- a/kernels/ZendEngine3/string.c
-+++ b/kernels/ZendEngine3/string.c
-@@ -1106,8 +1106,8 @@ void zephir_preg_match(zval *return_value, zval *regex, zval *subject, zval *mat
- zval rv, tmp_matches;
- zval *rvp = return_value ? return_value : &rv;
-
-- ZEPHIR_NULL(&tmp_flags);
-- ZEPHIR_NULL(&tmp_offset);
-+ ZVAL_NULL(&tmp_flags);
-+ ZVAL_NULL(&tmp_offset);
-
- ZVAL_LONG(&tmp_flags, flags);
- ZVAL_LONG(&tmp_offset, offset);
-@@ -1183,7 +1183,7 @@ int zephir_json_encode(zval *return_value, zval *v, int opts)
- zval zopts;
- zval *params[2];
-
-- ZEPHIR_NULL(&zopts);
-+ ZVAL_NULL(&zopts);
- ZVAL_LONG(&zopts, opts);
-
- params[0] = v;
-@@ -1197,7 +1197,7 @@ int zephir_json_decode(zval *return_value, zval *v, zend_bool assoc)
- zval zassoc;
- zval *params[2];
-
-- ZEPHIR_NULL(&zassoc);
-+ ZVAL_NULL(&zassoc);
- ZVAL_BOOL(&zassoc, assoc);
-
- params[0] = v;
diff --git a/zephir.spec b/zephir.spec
index 9e212d1..487810a 100644
--- a/zephir.spec
+++ b/zephir.spec
@@ -9,14 +9,14 @@
%if 0%{?scl:1}
%global with_tests 0
-%scl_package zephyr-parser
+%scl_package zephyr
%else
%global with_tests 0%{!?_without_tests:1}
%endif
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit 1c107e0c8966233f0d35156419e2c97729dcc4ce
+%global gh_commit 42ea9f174be1bc0cf72081b12db6bace9b983139
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -25,8 +25,8 @@
%global parser_ver 1.1.1
Name: %{?scl_prefix}%{gh_project}
-Version: 0.12.7
-Release: 3%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
+Version: 0.12.8
+Release: 1%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
Summary: Zephir language for creation of extensions for PHP.
License: MIT
@@ -35,8 +35,6 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Adapt path used in RPM
Patch0: %{gh_project}-rpm.patch
-Patch1: https://github.com/phalcon/zephir/commit/8380460c38d4e6d8f00c5596f8ebcd3a6be4f25a.patch
-Patch2: https://github.com/phalcon/zephir/commit/650708de9df9039f04eda0fc150bd94e5a5b9753.patch
BuildArch: noarch
BuildRequires: %{?scl_prefix}php-devel > 7.0
@@ -203,8 +201,6 @@ Compiler design goals:
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p0 -b .rpm
-%patch1 -p1 -b .up
-%patch2 -p1 -b .up
sed -e 's/\$Id\$/%{gh_short}/' \
-i Library/Zephir.php
@@ -257,7 +253,12 @@ EOF
cd ext
%{_bindir}/phpize
+%if 0%{?rhel} == 6
+# to avoid Invalid configuration `noarch-redhat-linux-gnu'
+./configure
+%else
%configure
+%endif
make %{?_smp_mflags}
@@ -337,6 +338,10 @@ esac
%changelog
+* Fri Oct 4 2019 Remi Collet <remi@remirepo.net> - 0.12.8-1
+- update to 0.12.8
+- drop patch merged upstream
+
* Fri Oct 4 2019 Remi Collet <remi@remirepo.net> - 0.12.7-3
- disable timecop extension in launcher
see https://github.com/phalcon/cphalcon/issues/14446