summaryrefslogtreecommitdiffstats
path: root/zephir.spec
diff options
context:
space:
mode:
Diffstat (limited to 'zephir.spec')
-rw-r--r--zephir.spec21
1 files changed, 13 insertions, 8 deletions
diff --git a/zephir.spec b/zephir.spec
index 9e212d1..487810a 100644
--- a/zephir.spec
+++ b/zephir.spec
@@ -9,14 +9,14 @@
%if 0%{?scl:1}
%global with_tests 0
-%scl_package zephyr-parser
+%scl_package zephyr
%else
%global with_tests 0%{!?_without_tests:1}
%endif
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit 1c107e0c8966233f0d35156419e2c97729dcc4ce
+%global gh_commit 42ea9f174be1bc0cf72081b12db6bace9b983139
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -25,8 +25,8 @@
%global parser_ver 1.1.1
Name: %{?scl_prefix}%{gh_project}
-Version: 0.12.7
-Release: 3%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
+Version: 0.12.8
+Release: 1%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
Summary: Zephir language for creation of extensions for PHP.
License: MIT
@@ -35,8 +35,6 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Adapt path used in RPM
Patch0: %{gh_project}-rpm.patch
-Patch1: https://github.com/phalcon/zephir/commit/8380460c38d4e6d8f00c5596f8ebcd3a6be4f25a.patch
-Patch2: https://github.com/phalcon/zephir/commit/650708de9df9039f04eda0fc150bd94e5a5b9753.patch
BuildArch: noarch
BuildRequires: %{?scl_prefix}php-devel > 7.0
@@ -203,8 +201,6 @@ Compiler design goals:
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p0 -b .rpm
-%patch1 -p1 -b .up
-%patch2 -p1 -b .up
sed -e 's/\$Id\$/%{gh_short}/' \
-i Library/Zephir.php
@@ -257,7 +253,12 @@ EOF
cd ext
%{_bindir}/phpize
+%if 0%{?rhel} == 6
+# to avoid Invalid configuration `noarch-redhat-linux-gnu'
+./configure
+%else
%configure
+%endif
make %{?_smp_mflags}
@@ -337,6 +338,10 @@ esac
%changelog
+* Fri Oct 4 2019 Remi Collet <remi@remirepo.net> - 0.12.8-1
+- update to 0.12.8
+- drop patch merged upstream
+
* Fri Oct 4 2019 Remi Collet <remi@remirepo.net> - 0.12.7-3
- disable timecop extension in launcher
see https://github.com/phalcon/cphalcon/issues/14446