summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-17 09:48:50 +0200
committerRemi Collet <remi@php.net>2023-08-17 09:48:50 +0200
commitb44ebed360a81cd8ca341e47f752ca84d6598fa1 (patch)
treefa5623809b3527114eecc45555cc80f37ae443cb
parent842be679f665ec048b8e5337d804c7c5a4fb9669 (diff)
update to 2.0.22
-rw-r--r--uwsgi-plugin-php.spec9
-rw-r--r--uwsgi_fix_php82.patch15
2 files changed, 5 insertions, 19 deletions
diff --git a/uwsgi-plugin-php.spec b/uwsgi-plugin-php.spec
index 27ea16b..d336a2f 100644
--- a/uwsgi-plugin-php.spec
+++ b/uwsgi-plugin-php.spec
@@ -28,7 +28,7 @@ Requires: %{scl_prefix}php-embedded
%endif
Name: %{?scl_prefix}%{project}-plugin-php
-Version: 2.0.21
+Version: 2.0.22
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: uWSGI - Plugin for PHP support
License: GPLv2 with exceptions
@@ -38,7 +38,6 @@ Source0: http://projects.unbit.it/downloads/%{project}-%{version}.tar.gz
# https://github.com/unbit/uwsgi/issues/2283
Patch1: uwsgi_fix_php8.patch
-Patch4: uwsgi_fix_php82.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -68,8 +67,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qn %{project}-%{version}
-%patch1 -p1
-%patch4 -p1
+%patch -P1 -p1
# Fix makefile
sed -e 's:/lib:/%{_lib}:' -i plugins/php/uwsgiplugin.py
@@ -96,6 +94,9 @@ install -Dpm 755 %{?scl}%{!?scl:php}_plugin.so %{buildroot}%{_root_libdir}/%{pro
%changelog
+* Thu Aug 17 2023 Remi Collet <remi@remirepo.net> - 2.0.22-1
+- update to 2.0.22
+
* Fri Nov 4 2022 Remi Collet <remi@remirepo.net> - 2.0.21-1
- update to 2.0.21
diff --git a/uwsgi_fix_php82.patch b/uwsgi_fix_php82.patch
deleted file mode 100644
index 66a8e49..0000000
--- a/uwsgi_fix_php82.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -uNr a/plugins/php/php_plugin.c b/plugins/php/php_plugin.c
---- a/plugins/php/php_plugin.c 2022-10-06 19:52:07.237882916 +0200
-+++ b/plugins/php/php_plugin.c 2022-10-06 19:56:29.232418542 +0200
-@@ -607,7 +607,11 @@
- static int php_uwsgi_startup(sapi_module_struct *sapi_module)
- {
-
-+#if PHP_VERSION_ID >= 80200
-+ if (php_module_startup(&uwsgi_sapi_module, &uwsgi_module_entry)==FAILURE) {
-+#else
- if (php_module_startup(&uwsgi_sapi_module, &uwsgi_module_entry, 1)==FAILURE) {
-+#endif
- return FAILURE;
- } else {
- return SUCCESS;