summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-04 09:18:06 +0100
committerRemi Collet <remi@php.net>2022-11-04 09:18:06 +0100
commit842be679f665ec048b8e5337d804c7c5a4fb9669 (patch)
tree14d448f01c1732592d18d7680570813ef8715592
parent6e5d7189a9e051f5ead5082ada51c876e99bac74 (diff)
update to 2.0.21
-rw-r--r--uwsgi-plugin-php.spec39
-rw-r--r--uwsgi_fix_php81.patch42
-rw-r--r--uwsgi_fix_php_arginfo.patch43
3 files changed, 6 insertions, 118 deletions
diff --git a/uwsgi-plugin-php.spec b/uwsgi-plugin-php.spec
index acc0da1..27ea16b 100644
--- a/uwsgi-plugin-php.spec
+++ b/uwsgi-plugin-php.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for uwsgi-plugin-php
#
-# Copyright (c) 2017-2020 Remi Collet
+# Copyright (c) 2017-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -28,8 +28,8 @@ Requires: %{scl_prefix}php-embedded
%endif
Name: %{?scl_prefix}%{project}-plugin-php
-Version: 2.0.20
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.0.21
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: uWSGI - Plugin for PHP support
License: GPLv2 with exceptions
URL: http://projects.unbit.it/uwsgi
@@ -38,10 +38,6 @@ Source0: http://projects.unbit.it/downloads/%{project}-%{version}.tar.gz
# https://github.com/unbit/uwsgi/issues/2283
Patch1: uwsgi_fix_php8.patch
-# https://github.com/unbit/uwsgi/issues/2356
-Patch2: uwsgi_fix_php_arginfo.patch
-# https://github.com/unbit/uwsgi/issues/2394
-Patch3: uwsgi_fix_php81.patch
Patch4: uwsgi_fix_php82.patch
BuildRequires: %{?dtsprefix}gcc
@@ -62,30 +58,6 @@ BuildRequires: libargon2-devel
Requires: %{project}-plugin-common = %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: %{project}-plugin-php56u <= %{version}
-Obsoletes: %{project}-plugin-php70u <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: %{project}-plugin-php71u <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: %{project}-plugin-php72u <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: %{project}-plugin-php73 <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: %{project}-plugin-php74 <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: %{project}-plugin-php80 <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: %{project}-plugin-php81 <= %{version}
-%endif
-%endif
-
%description
This package contains the PHP plugin for uWSGI,
@@ -97,8 +69,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qn %{project}-%{version}
%patch1 -p1
-%patch2 -p1
-%patch3 -p1
%patch4 -p1
# Fix makefile
@@ -126,6 +96,9 @@ install -Dpm 755 %{?scl}%{!?scl:php}_plugin.so %{buildroot}%{_root_libdir}/%{pro
%changelog
+* Fri Nov 4 2022 Remi Collet <remi@remirepo.net> - 2.0.21-1
+- update to 2.0.21
+
* Mon Oct 17 2022 Remi Collet <remi@remirepo.net> - 2.0.20-3
- add upstream patch for PHP 8.2
diff --git a/uwsgi_fix_php81.patch b/uwsgi_fix_php81.patch
deleted file mode 100644
index 81d9025..0000000
--- a/uwsgi_fix_php81.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 8ca18da9a01eee19156243c5c0d28d2572698e4a Mon Sep 17 00:00:00 2001
-From: Riccardo Magliocchetti <riccardo.magliocchetti@gmail.com>
-Date: Sun, 30 Jan 2022 14:31:50 +0100
-Subject: [PATCH] plugins/php: handle php8.1 zend_file_handle signature change
-
-filename is now a zend_string.
-
-Refs #2394
----
- plugins/php/php_plugin.c | 17 +++++++++++------
- 1 file changed, 11 insertions(+), 6 deletions(-)
-
-diff --git a/plugins/php/php_plugin.c b/plugins/php/php_plugin.c
-index d336adddc..8b5a24156 100644
---- a/plugins/php/php_plugin.c
-+++ b/plugins/php/php_plugin.c
-@@ -1096,14 +1096,19 @@ int uwsgi_php_request(struct wsgi_request *wsgi_req) {
-
- SG(request_info).path_translated = wsgi_req->file;
-
-- memset(&file_handle, 0, sizeof(zend_file_handle));
-- file_handle.type = ZEND_HANDLE_FILENAME;
-- file_handle.filename = real_filename;
-+#if PHP_VERSION_ID >= 80100
-+ zend_string *handle_filename = zend_string_init(real_filename, real_filename_len, 0);
-+#else
-+ const char *handle_filename = real_filename;
-+#endif
-+ memset(&file_handle, 0, sizeof(zend_file_handle));
-+ file_handle.type = ZEND_HANDLE_FILENAME;
-+ file_handle.filename = handle_filename;
-
-- if (php_request_startup() == FAILURE) {
-+ if (php_request_startup() == FAILURE) {
- uwsgi_500(wsgi_req);
-- return -1;
-- }
-+ return -1;
-+ }
-
- struct uwsgi_string_list *usl=NULL;
-
diff --git a/uwsgi_fix_php_arginfo.patch b/uwsgi_fix_php_arginfo.patch
deleted file mode 100644
index 5228066..0000000
--- a/uwsgi_fix_php_arginfo.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff --git a/plugins/php/php_plugin.c b/plugins/php/php_plugin.c
-index 717d6317b..d336adddc 100644
---- a/plugins/php/php_plugin.c
-+++ b/plugins/php/php_plugin.c
-@@ -497,21 +497,24 @@ PHP_FUNCTION(uwsgi_signal) {
- RETURN_NULL();
- }
-
-+ZEND_BEGIN_ARG_INFO_EX(arginfo_void, 0, 0, 0)
-+ZEND_END_ARG_INFO()
-+
- zend_function_entry uwsgi_php_functions[] = {
-- PHP_FE(uwsgi_version, NULL)
-- PHP_FE(uwsgi_setprocname, NULL)
-- PHP_FE(uwsgi_worker_id, NULL)
-- PHP_FE(uwsgi_masterpid, NULL)
-- PHP_FE(uwsgi_signal, NULL)
--
-- PHP_FE(uwsgi_rpc, NULL)
--
-- PHP_FE(uwsgi_cache_get, NULL)
-- PHP_FE(uwsgi_cache_set, NULL)
-- PHP_FE(uwsgi_cache_update, NULL)
-- PHP_FE(uwsgi_cache_del, NULL)
-- PHP_FE(uwsgi_cache_clear, NULL)
-- PHP_FE(uwsgi_cache_exists, NULL)
-+ PHP_FE(uwsgi_version, arginfo_void)
-+ PHP_FE(uwsgi_setprocname, arginfo_void)
-+ PHP_FE(uwsgi_worker_id, arginfo_void)
-+ PHP_FE(uwsgi_masterpid, arginfo_void)
-+ PHP_FE(uwsgi_signal, arginfo_void)
-+
-+ PHP_FE(uwsgi_rpc, arginfo_void)
-+
-+ PHP_FE(uwsgi_cache_get, arginfo_void)
-+ PHP_FE(uwsgi_cache_set, arginfo_void)
-+ PHP_FE(uwsgi_cache_update, arginfo_void)
-+ PHP_FE(uwsgi_cache_del, arginfo_void)
-+ PHP_FE(uwsgi_cache_clear, arginfo_void)
-+ PHP_FE(uwsgi_cache_exists, arginfo_void)
- { NULL, NULL, NULL},
- };
-