summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-02-20 16:20:31 +0100
committerRemi Collet <remi@php.net>2024-02-20 16:20:31 +0100
commit4d4bc736d241ed98b5087e3b80ae3f53330fa3c7 (patch)
treef11f6510b30d4cc86ccc0e7b438ae5c2d66b325a
parenta1e1d831ba94edbf65152a76d347eebeebbd4736 (diff)
update to 2.0.24
-rw-r--r--uwsgi-plugin-php.spec11
-rw-r--r--uwsgi_fix_php8.patch17
2 files changed, 5 insertions, 23 deletions
diff --git a/uwsgi-plugin-php.spec b/uwsgi-plugin-php.spec
index a3ccc44..874a029 100644
--- a/uwsgi-plugin-php.spec
+++ b/uwsgi-plugin-php.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for uwsgi-plugin-php
#
-# Copyright (c) 2017-2023 Remi Collet
+# Copyright (c) 2017-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -28,7 +28,7 @@ Requires: %{scl_prefix}php-embedded
%endif
Name: %{?scl_prefix}%{project}-plugin-php
-Version: 2.0.23
+Version: 2.0.24
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: uWSGI - Plugin for PHP support
License: GPL-2.0-only with exceptions
@@ -36,9 +36,6 @@ URL: http://projects.unbit.it/uwsgi
Source0: http://projects.unbit.it/downloads/%{project}-%{version}.tar.gz
-# https://github.com/unbit/uwsgi/issues/2283
-Patch1: uwsgi_fix_php8.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-embedded
@@ -67,7 +64,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qn %{project}-%{version}
-%patch -P1 -p1
# Fix makefile
sed -e 's:/lib:/%{_lib}:' -i plugins/php/uwsgiplugin.py
@@ -94,6 +90,9 @@ install -Dpm 755 %{?scl}%{!?scl:php}_plugin.so %{buildroot}%{_root_libdir}/%{pro
%changelog
+* Tue Feb 20 2024 Remi Collet <remi@remirepo.net> - 2.0.24-1
+- update to 2.0.24
+
* Mon Nov 13 2023 Remi Collet <remi@remirepo.net> - 2.0.23-1
- update to 2.0.23
diff --git a/uwsgi_fix_php8.patch b/uwsgi_fix_php8.patch
deleted file mode 100644
index 1685a0f..0000000
--- a/uwsgi_fix_php8.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -uNr a/plugins/php/uwsgiplugin.py b/plugins/php/uwsgiplugin.py
---- a/plugins/php/uwsgiplugin.py 2022-01-22 22:40:33.783038869 +0100
-+++ b/plugins/php/uwsgiplugin.py 2022-01-22 22:41:45.261394898 +0100
-@@ -21,7 +21,12 @@ if ld_run_path:
- LDFLAGS.append('-L%s' % ld_run_path)
- os.environ['LD_RUN_PATH'] = ld_run_path
-
--LIBS = [os.popen(PHPPATH + ' --libs').read().rstrip(), '-lphp' + php_version]
-+# PHP8 and above does not add the version to the library
-+# name
-+if int(php_version) < 8:
-+ LIBS = [os.popen(PHPPATH + ' --libs').read().rstrip(), '-lphp' + php_version]
-+else:
-+ LIBS = [os.popen(PHPPATH + ' --libs').read().rstrip(), '-lphp']
-
- phplibdir = os.environ.get('UWSGICONFIG_PHPLIBDIR')
- if phplibdir: