summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-13 07:32:24 +0100
committerRemi Collet <remi@php.net>2023-11-13 07:32:24 +0100
commita1e1d831ba94edbf65152a76d347eebeebbd4736 (patch)
tree65e4c1925febfa9cd125de0c5d2e18f420b3e7e6
parentecebe9de5e996c9ef01a25c4a6431951042c7b95 (diff)
update to 2.0.23
-rw-r--r--uwsgi-plugin-php.spec12
-rw-r--r--uwsgi_fix_php83.patch52
2 files changed, 5 insertions, 59 deletions
diff --git a/uwsgi-plugin-php.spec b/uwsgi-plugin-php.spec
index 5561286..a3ccc44 100644
--- a/uwsgi-plugin-php.spec
+++ b/uwsgi-plugin-php.spec
@@ -28,8 +28,8 @@ Requires: %{scl_prefix}php-embedded
%endif
Name: %{?scl_prefix}%{project}-plugin-php
-Version: 2.0.22
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.0.23
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: uWSGI - Plugin for PHP support
License: GPL-2.0-only with exceptions
URL: http://projects.unbit.it/uwsgi
@@ -38,8 +38,6 @@ Source0: http://projects.unbit.it/downloads/%{project}-%{version}.tar.gz
# https://github.com/unbit/uwsgi/issues/2283
Patch1: uwsgi_fix_php8.patch
-# https://github.com/unbit/uwsgi/pull/2559
-Patch2: uwsgi_fix_php83.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -70,9 +68,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qn %{project}-%{version}
%patch -P1 -p1
-%if "%{php_version}" > "8.3"
-%patch -P2 -p1
-%endif
# Fix makefile
sed -e 's:/lib:/%{_lib}:' -i plugins/php/uwsgiplugin.py
@@ -99,6 +94,9 @@ install -Dpm 755 %{?scl}%{!?scl:php}_plugin.so %{buildroot}%{_root_libdir}/%{pro
%changelog
+* Mon Nov 13 2023 Remi Collet <remi@remirepo.net> - 2.0.23-1
+- update to 2.0.23
+
* Mon Sep 4 2023 Remi Collet <remi@remirepo.net> - 2.0.22-2
- add patch for PHP 8.3 from
https://github.com/unbit/uwsgi/pull/2559
diff --git a/uwsgi_fix_php83.patch b/uwsgi_fix_php83.patch
deleted file mode 100644
index ed343a9..0000000
--- a/uwsgi_fix_php83.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 064984116e86ac0a5d5d3805765395b661fc4455 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 4 Sep 2023 13:10:52 +0200
-Subject: [PATCH] ini_entries is read-only PHP 8.3
-
----
- plugins/php/php_plugin.c | 18 ++++++++++--------
- 1 file changed, 10 insertions(+), 8 deletions(-)
-
-diff --git a/plugins/php/php_plugin.c b/plugins/php/php_plugin.c
-index b3efa006a..d9b615bac 100644
---- a/plugins/php/php_plugin.c
-+++ b/plugins/php/php_plugin.c
-@@ -27,6 +27,7 @@ struct uwsgi_php {
- char *fallback;
- char *fallback2;
- char *fallback_qs;
-+ char *ini_entries;
- size_t ini_size;
- int dump_config;
- char *server_software;
-@@ -232,21 +233,22 @@ static sapi_module_struct uwsgi_sapi_module;
-
- void uwsgi_php_append_config(char *filename) {
- size_t file_size = 0;
-- char *file_content = uwsgi_open_and_read(filename, &file_size, 1, NULL);
-- uwsgi_sapi_module.ini_entries = realloc(uwsgi_sapi_module.ini_entries, uphp.ini_size + file_size);
-- memcpy(uwsgi_sapi_module.ini_entries + uphp.ini_size, file_content, file_size);
-+ char *file_content = uwsgi_open_and_read(filename, &file_size, 1, NULL);
-+ uphp.ini_entries = realloc(uphp.ini_entries, uphp.ini_size + file_size);
-+ memcpy(uphp.ini_entries + uphp.ini_size, file_content, file_size);
- uphp.ini_size += file_size-1;
- free(file_content);
-+ uwsgi_sapi_module.ini_entries = uphp.ini_entries;
- }
-
- void uwsgi_php_set(char *opt) {
-
-- uwsgi_sapi_module.ini_entries = realloc(uwsgi_sapi_module.ini_entries, uphp.ini_size + strlen(opt)+2);
-- memcpy(uwsgi_sapi_module.ini_entries + uphp.ini_size, opt, strlen(opt));
--
-+ uphp.ini_entries = realloc(uphp.ini_entries, uphp.ini_size + strlen(opt)+2);
-+ memcpy(uphp.ini_entries + uphp.ini_size, opt, strlen(opt));
- uphp.ini_size += strlen(opt)+1;
-- uwsgi_sapi_module.ini_entries[uphp.ini_size-1] = '\n';
-- uwsgi_sapi_module.ini_entries[uphp.ini_size] = 0;
-+ uphp.ini_entries[uphp.ini_size-1] = '\n';
-+ uphp.ini_entries[uphp.ini_size] = 0;
-+ uwsgi_sapi_module.ini_entries = uphp.ini_entries;
- }
-
- extern ps_module ps_mod_uwsgi;