summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-18 09:05:48 +0200
committerRemi Collet <fedora@famillecollet.com>2015-10-18 09:05:48 +0200
commit5b5b57a8754552d642c3d7a8b0cab10d0c5dac96 (patch)
treee32b06a4d2c01c4ec414597be5cb42ad8d3a92da
parent08213f59fbfc6a2aa81a8cbec7f8191ea32ec7f1 (diff)
add help for PHP 7 extension build
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index d7d7d9e..2e8d44e 100644
--- a/Makefile
+++ b/Makefile
@@ -91,6 +91,15 @@ rpmdiff:
devsrc:
spectool -g -S $(NAME)-dev.spec
+php7src:
+ spectool -g -S $(NAME)-php7.spec
+
+php7build:
+ time rpmbuild $(RPMDEFINES) --define "scl php70" --without zts -bb $(NAME)-php7.spec
+
+php7srpm:
+ rpmbuild $(RPMDEFINES) $(SRCDEFINES) -bs $(NAME)-php7.spec
+
src:
spectool -g -S $(NAME).spec