summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-08 08:56:26 +0100
committerRemi Collet <remi@php.net>2023-11-08 08:56:26 +0100
commitd18456b6024776ef82854c1d3e920075eb1d4927 (patch)
tree37eeaa64747711813e9d3b726ed3c50fbe5f5c8e /php.spec
parent3202c8bd1739cc94dd1d129bac79bcb865dd5920 (diff)
build sockets extension statically
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec10
1 files changed, 6 insertions, 4 deletions
diff --git a/php.spec b/php.spec
index fbea3d1..f7d7753 100644
--- a/php.spec
+++ b/php.spec
@@ -1177,6 +1177,7 @@ mkdir Zend && cp ../Zend/zend_{language,ini}_{parser,scanner}.[ch] Zend
# date, filter, libxml, reflection, spl: not supported
# hash: for PHAR_SIG_SHA256 and PHAR_SIG_SHA512
# session: dep on hash, used by soap
+# sockets: heavily used by FPM test suite
# pcre: used by filter, zip
# pcntl, readline: only used by CLI sapi
# openssl: for PHAR_SIG_OPENSSL
@@ -1215,6 +1216,7 @@ ln -sf ../configure
%if %{with dtrace}
--enable-dtrace \
%endif
+ --enable-sockets \
$*
if test $? != 0; then
tail -500 config.log
@@ -1263,7 +1265,6 @@ build --libdir=%{_libdir}/php \
--enable-ftp=shared \
--with-gettext=shared \
--with-iconv=shared \
- --enable-sockets=shared \
--enable-tokenizer=shared \
--with-ldap=shared --with-ldap-sasl \
--enable-mysqlnd=shared \
@@ -1333,7 +1334,7 @@ without_shared="--disable-gd \
--without-curl --disable-posix --disable-xml \
--disable-simplexml --disable-exif --without-gettext \
--without-iconv --disable-ftp --without-bz2 --disable-ctype \
- --disable-shmop --disable-sockets --disable-tokenizer \
+ --disable-shmop --disable-tokenizer \
--disable-sysvmsg --disable-sysvshm --disable-sysvsem"
# Build Apache module, and the CLI SAPI, /usr/bin/php
@@ -1553,7 +1554,7 @@ for mod in pgsql odbc ldap snmp \
%endif
mbstring gd dom xsl soap bcmath dba \
simplexml bz2 calendar ctype exif ftp gettext gmp iconv \
- sockets tokenizer opcache \
+ tokenizer opcache \
pdo \
%if %{with sqlite3}
sqlite3 \
@@ -1646,7 +1647,7 @@ cat files.sqlite3 >> files.pdo
# Package curl, phar and fileinfo in -common.
cat files.curl files.phar files.fileinfo \
files.exif files.gettext files.iconv files.calendar \
- files.ftp files.bz2 files.ctype files.sockets \
+ files.ftp files.bz2 files.ctype \
files.tokenizer > files.common
# The default Zend OPcache blacklist file
@@ -1878,6 +1879,7 @@ fi
- update to 8.3.0RC6
- use oracle client library version 21.12 on x86_64
- use ICU 73.2
+- build sockets extension statically
* Tue Oct 24 2023 Remi Collet <remi@remirepo.net> - 8.3.0~rc5-1
- update to 8.3.0RC5