summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-08 08:56:26 +0100
committerRemi Collet <remi@php.net>2023-11-08 08:56:26 +0100
commitd18456b6024776ef82854c1d3e920075eb1d4927 (patch)
tree37eeaa64747711813e9d3b726ed3c50fbe5f5c8e
parent3202c8bd1739cc94dd1d129bac79bcb865dd5920 (diff)
build sockets extension statically
-rw-r--r--failed.txt19
-rw-r--r--php.spec10
2 files changed, 15 insertions, 14 deletions
diff --git a/failed.txt b/failed.txt
index f1bca4c..f0c5b32 100644
--- a/failed.txt
+++ b/failed.txt
@@ -2,19 +2,18 @@
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
-/var/lib/mock/scl83el7x/build.log:Tests failed : 2
-/var/lib/mock/scl83el8a/build.log:Tests failed : 2
-/var/lib/mock/scl83el8x/build.log:Tests failed : 2
-/var/lib/mock/scl83el9a/build.log:Tests failed : 3
-/var/lib/mock/scl83el9x/build.log:Tests failed : 3
-/var/lib/mock/scl83fc37x/build.log:Tests failed : 3
-/var/lib/mock/scl83fc38x/build.log:Tests failed : 4
-/var/lib/mock/scl83fc39a/build.log:Tests failed : 4
-/var/lib/mock/scl83fc39x/build.log:Tests failed : 4
+/var/lib/mock/scl83el7x/build.log:Tests failed : 1
+/var/lib/mock/scl83el8a/build.log:Tests failed : 1
+/var/lib/mock/scl83el8x/build.log:Tests failed : 1
+/var/lib/mock/scl83el9a/build.log:Tests failed : 2
+/var/lib/mock/scl83el9x/build.log:Tests failed : 2
+/var/lib/mock/scl83fc37x/build.log:Tests failed : 2
+/var/lib/mock/scl83fc38x/build.log:Tests failed : 3
+/var/lib/mock/scl83fc39a/build.log:Tests failed : 3
+/var/lib/mock/scl83fc39x/build.log:Tests failed : 3
all:
- 3 FPM: bug76922 - FCGI conn termination after FCGI_GET_VALUES [sapi/fpm/tests/bug76922-fcgi-get-value-conn.phpt]
3 GH-11374 (PCRE regular expression without JIT enabled gives different result) [ext/pcre/tests/gh11374.phpt]
el7x:
5 ext/standard/tests/directory/bug74589_utf8.phpt
diff --git a/php.spec b/php.spec
index fbea3d1..f7d7753 100644
--- a/php.spec
+++ b/php.spec
@@ -1177,6 +1177,7 @@ mkdir Zend && cp ../Zend/zend_{language,ini}_{parser,scanner}.[ch] Zend
# date, filter, libxml, reflection, spl: not supported
# hash: for PHAR_SIG_SHA256 and PHAR_SIG_SHA512
# session: dep on hash, used by soap
+# sockets: heavily used by FPM test suite
# pcre: used by filter, zip
# pcntl, readline: only used by CLI sapi
# openssl: for PHAR_SIG_OPENSSL
@@ -1215,6 +1216,7 @@ ln -sf ../configure
%if %{with dtrace}
--enable-dtrace \
%endif
+ --enable-sockets \
$*
if test $? != 0; then
tail -500 config.log
@@ -1263,7 +1265,6 @@ build --libdir=%{_libdir}/php \
--enable-ftp=shared \
--with-gettext=shared \
--with-iconv=shared \
- --enable-sockets=shared \
--enable-tokenizer=shared \
--with-ldap=shared --with-ldap-sasl \
--enable-mysqlnd=shared \
@@ -1333,7 +1334,7 @@ without_shared="--disable-gd \
--without-curl --disable-posix --disable-xml \
--disable-simplexml --disable-exif --without-gettext \
--without-iconv --disable-ftp --without-bz2 --disable-ctype \
- --disable-shmop --disable-sockets --disable-tokenizer \
+ --disable-shmop --disable-tokenizer \
--disable-sysvmsg --disable-sysvshm --disable-sysvsem"
# Build Apache module, and the CLI SAPI, /usr/bin/php
@@ -1553,7 +1554,7 @@ for mod in pgsql odbc ldap snmp \
%endif
mbstring gd dom xsl soap bcmath dba \
simplexml bz2 calendar ctype exif ftp gettext gmp iconv \
- sockets tokenizer opcache \
+ tokenizer opcache \
pdo \
%if %{with sqlite3}
sqlite3 \
@@ -1646,7 +1647,7 @@ cat files.sqlite3 >> files.pdo
# Package curl, phar and fileinfo in -common.
cat files.curl files.phar files.fileinfo \
files.exif files.gettext files.iconv files.calendar \
- files.ftp files.bz2 files.ctype files.sockets \
+ files.ftp files.bz2 files.ctype \
files.tokenizer > files.common
# The default Zend OPcache blacklist file
@@ -1878,6 +1879,7 @@ fi
- update to 8.3.0RC6
- use oracle client library version 21.12 on x86_64
- use ICU 73.2
+- build sockets extension statically
* Tue Oct 24 2023 Remi Collet <remi@remirepo.net> - 8.3.0~rc5-1
- update to 8.3.0RC5