summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-GH8059.patch23
-rw-r--r--php.spec7
2 files changed, 29 insertions, 1 deletions
diff --git a/php-GH8059.patch b/php-GH8059.patch
new file mode 100644
index 0000000..817d044
--- /dev/null
+++ b/php-GH8059.patch
@@ -0,0 +1,23 @@
+From 3b463749f544a7b538264ee2a9647e4bca92f9b0 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 8 Feb 2022 09:36:37 +0100
+Subject: [PATCH] Fix GH-8059 use $PHP_EXECUTABLE when $PHP not set
+
+---
+ build/Makefile.global | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/build/Makefile.global b/build/Makefile.global
+index 6941bab6ad41..f93a874ce1b5 100644
+--- a/build/Makefile.global
++++ b/build/Makefile.global
+@@ -148,6 +148,9 @@ prof-use:
+ if test ! -z "$(PHP)"; then \
+ echo Parse $< to generate $@;\
+ $(PHP) $(top_srcdir)/build/gen_stub.php $<; \
++ elif test ! -z "$(PHP_EXECUTABLE)" && test -x "$(PHP_EXECUTABLE)"; then \
++ echo Parse $< to generate $@;\
++ $(PHP_EXECUTABLE) $(top_srcdir)/build/gen_stub.php $<; \
+ fi; \
+ fi;
+
diff --git a/php.spec b/php.spec
index 7a406cf..a891a91 100644
--- a/php.spec
+++ b/php.spec
@@ -133,7 +133,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -196,6 +196,7 @@ Patch47: php-8.1.0-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-GH8059.patch
# Security fixes (200+)
@@ -969,6 +970,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .gh8059
# security patches
@@ -1845,6 +1847,9 @@ fi
%changelog
+* Tue Feb 8 2022 Remi Collet <remi@remirepo.net> - 8.1.3~RC1-2
+- fix GH-8059 arginfo not regenerated for extension
+
* Thu Feb 3 2022 Remi Collet <remi@remirepo.net> - 8.1.3~RC1-1
- update to 8.1.3RC1