summaryrefslogtreecommitdiffstats
path: root/php-GH8059.patch
diff options
context:
space:
mode:
Diffstat (limited to 'php-GH8059.patch')
-rw-r--r--php-GH8059.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/php-GH8059.patch b/php-GH8059.patch
new file mode 100644
index 0000000..817d044
--- /dev/null
+++ b/php-GH8059.patch
@@ -0,0 +1,23 @@
+From 3b463749f544a7b538264ee2a9647e4bca92f9b0 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 8 Feb 2022 09:36:37 +0100
+Subject: [PATCH] Fix GH-8059 use $PHP_EXECUTABLE when $PHP not set
+
+---
+ build/Makefile.global | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/build/Makefile.global b/build/Makefile.global
+index 6941bab6ad41..f93a874ce1b5 100644
+--- a/build/Makefile.global
++++ b/build/Makefile.global
+@@ -148,6 +148,9 @@ prof-use:
+ if test ! -z "$(PHP)"; then \
+ echo Parse $< to generate $@;\
+ $(PHP) $(top_srcdir)/build/gen_stub.php $<; \
++ elif test ! -z "$(PHP_EXECUTABLE)" && test -x "$(PHP_EXECUTABLE)"; then \
++ echo Parse $< to generate $@;\
++ $(PHP_EXECUTABLE) $(top_srcdir)/build/gen_stub.php $<; \
+ fi; \
+ fi;
+