summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-04-09 15:36:00 +0200
committerRemi Collet <remi@remirepo.net>2020-04-09 15:36:00 +0200
commit1cb3e4f757727a3584f5aac738cc3ca92762da5e (patch)
tree9581dadd391abf401142f989640fd434b30562ad /php.spec
parent615a5edd3272c380b5c911b459794d82e4857c96 (diff)
update to 8.0.0-dev
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec57
1 files changed, 32 insertions, 25 deletions
diff --git a/php.spec b/php.spec
index e966bb0..84f6933 100644
--- a/php.spec
+++ b/php.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for php74-php
+# remirepo spec file for php80-php
# with SCL and backport stuff, adapted from
#
# Fedora spec file for php
@@ -23,8 +23,8 @@
%endif
# API/ABI check
-%global apiver 20190902
-%global zendver 20190902
+%global apiver 20190128
+%global zendver 20190128
%global pdover 20170320
# Extension version
%global oci8ver 2.2.0
@@ -33,7 +33,7 @@
%global _hardened_build 1
# version used for php embedded library soname
-%global embed_version 7.4
+%global embed_version 8.0
# Ugly hack. Harcoded values to avoid relocation.
%global _httpd_mmn %(cat %{_root_includedir}/httpd/.mmn 2>/dev/null || echo 0)
@@ -97,14 +97,14 @@
%global with_zip 0
-%global gh_commit eac238fb6cb6f38c2f3ba1d0fa129ea8d42fec38
+%global gh_commit 175e5ed4bf85b68a5a60cb481322c18f2f9f8f46
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_date 20190612
+%global gh_date 20190612
%global gh_owner php
%global gh_project php-src
-%global upver 7.4.5
-%global rcver RC1
-%global lower RC1
+%global upver 8.0.0
+#global rcver DEV
+%global lower DEV
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -124,6 +124,9 @@ URL: http://www.php.net/
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{upver}-%{gh_short}.tar.gz
%else
Source0: http://www.php.net/distributions/php-%{upver}%{?rcver}.tar.xz
+# See https://secure.php.net/gpg-keys.php
+Source20: https://www.php.net/distributions/php-keyring.gpg
+Source21: https://www.php.net/distributions/php-%{upver}%{?rcver}.tar.xz.asc
%endif
Source1: php.conf
Source2: php.ini
@@ -136,9 +139,6 @@ Source8: php-fpm.sysconfig
Source9: php.modconf
Source10: php.conf2
Source12: php-fpm.wants
-# See https://secure.php.net/gpg-keys.php
-Source20: https://www.php.net/distributions/php-keyring.gpg
-Source21: https://www.php.net/distributions/php-%{upver}%{?rcver}.tar.xz.asc
# Configuration files for some extensions
Source50: 10-opcache.ini
Source51: opcache-default.blacklist
@@ -149,7 +149,7 @@ Source53: 20-ffi.ini
Patch1: php-7.4.0-httpd.patch
Patch5: php-7.2.0-includedir.patch
Patch6: php-7.4.0-embed.patch
-Patch8: php-7.2.0-libdb.patch
+Patch8: php-7.4.0-libdb.patch
Patch9: php-7.0.7-curl.patch
# Functional changes
@@ -172,13 +172,13 @@ Patch91: php-7.2.0-oci8conf.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
-Patch300: php-7.0.10-datetests.patch
+Patch300: php-7.4.0-datetests.patch
# WIP
BuildRequires: gnupg2
BuildRequires: bzip2-devel
-BuildRequires: pkgconfig(libcurl) >= 7.15.5
+BuildRequires: pkgconfig(libcurl) >= 7.29.0
BuildRequires: libdb-devel
BuildRequires: httpd-devel >= 2.0.46-1
BuildRequires: pam-devel
@@ -247,7 +247,7 @@ Requires: %{?scl_prefix}php-sodium%{?_isa} = %{version}-%{release}
# Don't provides extensions, or shared libraries (embedded)
-%{?filter_from_requires: %filter_from_requires /libphp7.*so/d}
+%{?filter_from_requires: %filter_from_requires /libphp.*so/d}
%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
%{?filter_setup}
@@ -910,7 +910,11 @@ in pure PHP.
%prep
+%if 0%{?gh_date}
+: no gpg check for git snapshot
+%else
%{?gpgverify:%{gpgverify} --keyring='%{SOURCE20}' --signature='%{SOURCE21}' --data='%{SOURCE0}'}
+%endif
: Building %{name}-%{version}-%{release} with imap=%{with_imap} freetds=%{with_freetds} sqlite3=%{with_sqlite3} tidy=%{with_tidy} zip=%{with_zip}
%if 0%{?gh_date}
@@ -1294,7 +1298,7 @@ build --enable-fpm \
popd
# Build for inclusion as embedded script language into applications,
-# /usr/lib[64]/libphp7.so
+# /usr/lib[64]/libphp.so
pushd build-embedded
build --enable-embed \
--without-mysqli \
@@ -1355,13 +1359,13 @@ install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/php/preload
# install the DSO
install -m 755 -d $RPM_BUILD_ROOT%{_httpd_moddir}
-install -m 755 build-apache/libs/libphp7.so $RPM_BUILD_ROOT%{_httpd_moddir}
+install -m 755 build-apache/libs/libphp.so $RPM_BUILD_ROOT%{_httpd_moddir}
# Apache config fragment
%if %{?scl:1}0
-sed -e 's/libphp7/lib%{scl}/' %{SOURCE9} >modconf
+sed -e 's/libphp/lib%{scl}/' %{SOURCE9} >modconf
install -m 755 -d $RPM_BUILD_ROOT%{_root_httpd_moddir}
-ln -s %{_httpd_moddir}/libphp7.so $RPM_BUILD_ROOT%{_root_httpd_moddir}/lib%{scl}.so
+ln -s %{_httpd_moddir}/libphp.so $RPM_BUILD_ROOT%{_root_httpd_moddir}/lib%{scl}.so
%else
cp %{SOURCE9} modconf
%endif
@@ -1590,8 +1594,8 @@ install -m 644 -D macros.php \
rm -rf $RPM_BUILD_ROOT%{_libdir}/php/modules/*.a \
$RPM_BUILD_ROOT%{_bindir}/{phptar} \
$RPM_BUILD_ROOT%{_datadir}/pear \
- $RPM_BUILD_ROOT%{_libdir}/libphp7.a \
- $RPM_BUILD_ROOT%{_libdir}/libphp7.la
+ $RPM_BUILD_ROOT%{_libdir}/libphp.a \
+ $RPM_BUILD_ROOT%{_libdir}/libphp.la
# Remove irrelevant docs
rm -f README.{Zeus,QNX,CVS-RULES}
@@ -1650,7 +1654,7 @@ fi
%{!?_licensedir:%global license %%doc}
%files
-%{_httpd_moddir}/libphp7.so
+%{_httpd_moddir}/libphp.so
%if 0%{?scl:1}
%dir %{_libdir}/httpd
%dir %{_libdir}/httpd/modules
@@ -1747,8 +1751,8 @@ fi
%endif
%files embedded
-%{_libdir}/libphp7.so
-%{_libdir}/libphp7-%{embed_version}.so
+%{_libdir}/libphp.so
+%{_libdir}/libphp-%{embed_version}.so
%files devel
%{_bindir}/php-config
@@ -1810,6 +1814,9 @@ fi
%changelog
+* Thu Apr 9 2020 Remi Collet <remi@remirepo.net> - 8.0.0~DEV.20190612-1
+- update to 8.0.0-dev
+
* Tue Mar 31 2020 Remi Collet <remi@remirepo.net> - 7.4.5~RC1-1
- update to 7.4.5RC1