summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-04-09 15:36:00 +0200
committerRemi Collet <remi@remirepo.net>2020-04-09 15:36:00 +0200
commit1cb3e4f757727a3584f5aac738cc3ca92762da5e (patch)
tree9581dadd391abf401142f989640fd434b30562ad
parent615a5edd3272c380b5c911b459794d82e4857c96 (diff)
update to 8.0.0-dev
-rw-r--r--php-7.4.0-datetests.patch (renamed from php-7.0.10-datetests.patch)95
-rw-r--r--php-7.4.0-libdb.patch (renamed from php-7.2.0-libdb.patch)26
-rw-r--r--php.modconf8
-rw-r--r--php.spec57
4 files changed, 98 insertions, 88 deletions
diff --git a/php-7.0.10-datetests.patch b/php-7.4.0-datetests.patch
index fc42326..8c437e5 100644
--- a/php-7.0.10-datetests.patch
+++ b/php-7.4.0-datetests.patch
@@ -1,50 +1,6 @@
---- a/ext/date/tests/bug66985.phpt 2014-10-30 07:32:03.297693403 +0100
-+++ b/ext/date/tests/bug66985.phpt 2014-10-30 07:32:45.138877977 +0100
-@@ -3,7 +3,7 @@
- --FILE--
- <?php
- $zones = array(
-- "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "Factory", "GB-Eire",
-+ "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "GB-Eire",
- "GMT0", "Greenwich", "Hongkong", "Iceland", "Iran", "Israel", "Jamaica",
- "Japan", "Kwajalein", "Libya", "MST7MDT", "Navajo", "NZ-CHAT", "Poland",
- "Portugal", "PST8PDT", "Singapore", "Turkey", "Universal", "W-SU",
-@@ -45,11 +45,6 @@
- )
- DateTimeZone Object
- (
-- [timezone_type] => 3
-- [timezone] => Factory
--)
--DateTimeZone Object
--(
- [timezone_type] => 3
- [timezone] => GB-Eire
- )
-diff -up ./ext/date/tests/strtotime3-64bit.phpt.datetests ./ext/date/tests/strtotime3-64bit.phpt
---- ./ext/date/tests/strtotime3-64bit.phpt.datetests 2016-07-21 02:23:03.000000000 +0200
-+++ ./ext/date/tests/strtotime3-64bit.phpt 2016-07-26 07:39:45.713272263 +0200
-@@ -44,7 +44,7 @@ foreach ($strs as $str) {
- }
-
- ?>
----EXPECT--
-+--EXPECTF--
- bool(false)
- bool(false)
- string(31) "Thu, 15 Jun 2006 00:00:00 +0100"
-@@ -53,7 +53,7 @@ bool(false)
- string(31) "Fri, 16 Jun 2006 23:49:12 +0100"
- bool(false)
- string(31) "Fri, 16 Jun 2006 02:22:00 +0100"
--string(31) "Sun, 16 Jun 0222 02:22:00 -0036"
-+string(31) "Sun, 16 Jun 0222 02:22:00 %s"
- string(31) "Fri, 16 Jun 2006 02:22:33 +0100"
- bool(false)
- string(31) "Tue, 02 Mar 2004 00:00:00 +0000"
-diff -up ./ext/date/tests/bug33414-2.phpt.old ./ext/date/tests/bug33414-2.phpt
---- ./ext/date/tests/bug33414-2.phpt.old 2017-04-25 15:47:21.675700587 +0200
-+++ ./ext/date/tests/bug33414-2.phpt 2017-04-25 15:57:14.034681111 +0200
+diff -up ./ext/date/tests/bug33414-2.phpt.datetests ./ext/date/tests/bug33414-2.phpt
+--- ./ext/date/tests/bug33414-2.phpt.datetests 2020-04-09 14:06:11.000000000 +0200
++++ ./ext/date/tests/bug33414-2.phpt 2020-04-09 14:40:00.809433489 +0200
@@ -74,10 +74,10 @@ $strtotime_tstamp = strtotime("next Frid
print "result=".date("l Y-m-d H:i:s T I", $strtotime_tstamp)."\n";
print "wanted=Friday 00:00:00\n\n";
@@ -95,3 +51,48 @@ diff -up ./ext/date/tests/bug33414-2.phpt.old ./ext/date/tests/bug33414-2.phpt
wanted=Saturday 00:00:00
TZ=Pacific/Johnston - wrong day.
+diff -up ./ext/date/tests/bug66985.phpt.datetests ./ext/date/tests/bug66985.phpt
+--- ./ext/date/tests/bug66985.phpt.datetests 2020-04-09 14:06:11.000000000 +0200
++++ ./ext/date/tests/bug66985.phpt 2020-04-09 14:40:37.099288185 +0200
+@@ -3,7 +3,7 @@ Bug #66985 (Some timezones are no longer
+ --FILE--
+ <?php
+ $zones = array(
+- "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "Factory", "GB-Eire",
++ "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "GB-Eire",
+ "GMT0", "Greenwich", "Hongkong", "Iceland", "Iran", "Israel", "Jamaica",
+ "Japan", "Kwajalein", "Libya", "MST7MDT", "Navajo", "NZ-CHAT", "Poland",
+ "Portugal", "PST8PDT", "Singapore", "Turkey", "Universal", "W-SU",
+@@ -45,11 +45,6 @@ DateTimeZone Object
+ )
+ DateTimeZone Object
+ (
+- [timezone_type] => 3
+- [timezone] => Factory
+-)
+-DateTimeZone Object
+-(
+ [timezone_type] => 3
+ [timezone] => GB-Eire
+ )
+diff -up ./ext/date/tests/strtotime3-64bit.phpt.datetests ./ext/date/tests/strtotime3-64bit.phpt
+--- ./ext/date/tests/strtotime3-64bit.phpt.datetests 2020-04-09 14:06:11.000000000 +0200
++++ ./ext/date/tests/strtotime3-64bit.phpt 2020-04-09 14:40:00.809433489 +0200
+@@ -44,7 +44,7 @@ foreach ($strs as $str) {
+ }
+
+ ?>
+---EXPECT--
++--EXPECTF--
+ bool(false)
+ bool(false)
+ string(31) "Thu, 15 Jun 2006 00:00:00 +0100"
+@@ -53,7 +53,7 @@ bool(false)
+ string(31) "Fri, 16 Jun 2006 23:49:12 +0100"
+ bool(false)
+ string(31) "Fri, 16 Jun 2006 02:22:00 +0100"
+-string(31) "Sun, 16 Jun 0222 02:22:00 -0036"
++string(31) "Sun, 16 Jun 0222 02:22:00 %s"
+ string(31) "Fri, 16 Jun 2006 02:22:33 +0100"
+ bool(false)
+ string(31) "Tue, 02 Mar 2004 00:00:00 +0000"
diff --git a/php-7.2.0-libdb.patch b/php-7.4.0-libdb.patch
index ca36d1a..d7c6289 100644
--- a/php-7.2.0-libdb.patch
+++ b/php-7.4.0-libdb.patch
@@ -1,7 +1,7 @@
-diff -up php-7.2.0alpha0/ext/dba/config.m4.libdb php-7.2.0alpha0/ext/dba/config.m4
---- php-7.2.0alpha0/ext/dba/config.m4.libdb 2017-05-29 08:56:06.000000000 +0200
-+++ php-7.2.0alpha0/ext/dba/config.m4 2017-05-29 09:13:52.014823282 +0200
-@@ -346,61 +346,13 @@ if test "$PHP_DB4" != "no"; then
+diff -up ./ext/dba/config.m4.libdb ./ext/dba/config.m4
+--- ./ext/dba/config.m4.libdb 2020-04-09 14:06:11.000000000 +0200
++++ ./ext/dba/config.m4 2020-04-09 14:35:08.208605065 +0200
+@@ -375,61 +375,13 @@ if test "$PHP_DB4" != "no"; then
dbdp4="/usr/local/BerkeleyDB.4."
dbdp5="/usr/local/BerkeleyDB.5."
for i in $PHP_DB4 ${dbdp5}1 ${dbdp5}0 ${dbdp4}8 ${dbdp4}7 ${dbdp4}6 ${dbdp4}5 ${dbdp4}4 ${dbdp4}3 ${dbdp4}2 ${dbdp4}1 ${dbdp}0 /usr/local /usr; do
@@ -65,21 +65,21 @@ diff -up php-7.2.0alpha0/ext/dba/config.m4.libdb php-7.2.0alpha0/ext/dba/config.
fi
PHP_DBA_STD_RESULT(db4,Berkeley DB4)
-diff -up php-7.2.0alpha0/ext/dba/dba.c.libdb php-7.2.0alpha0/ext/dba/dba.c
---- php-7.2.0alpha0/ext/dba/dba.c.libdb 2017-05-29 09:16:15.736628202 +0200
-+++ php-7.2.0alpha0/ext/dba/dba.c 2017-05-29 09:16:20.494654746 +0200
-@@ -53,6 +53,10 @@
- #include "php_tcadb.h"
+diff -up ./ext/dba/dba.c.libdb ./ext/dba/dba.c
+--- ./ext/dba/dba.c.libdb 2020-04-09 14:06:11.000000000 +0200
++++ ./ext/dba/dba.c 2020-04-09 14:36:30.593275190 +0200
+@@ -50,6 +50,10 @@
#include "php_lmdb.h"
+ #include "dba_arginfo.h"
+#ifdef DB4_INCLUDE_FILE
+#include DB4_INCLUDE_FILE
+#endif
+
- /* {{{ arginfo */
- ZEND_BEGIN_ARG_INFO_EX(arginfo_dba_popen, 0, 0, 2)
- ZEND_ARG_INFO(0, path)
-@@ -558,6 +562,10 @@ PHP_MINFO_FUNCTION(dba)
+ PHP_MINIT_FUNCTION(dba);
+ PHP_MSHUTDOWN_FUNCTION(dba);
+ PHP_MINFO_FUNCTION(dba);
+@@ -459,6 +463,10 @@ PHP_MINFO_FUNCTION(dba)
php_info_print_table_start();
php_info_print_table_row(2, "DBA support", "enabled");
diff --git a/php.modconf b/php.modconf
index 3377f72..6f678e6 100644
--- a/php.modconf
+++ b/php.modconf
@@ -3,10 +3,12 @@
# easy for developers to write dynamically generated webpages.
#
-# Cannot load both php5 and php7 modules
+# Cannot load both php5, php7 and php modules
<IfModule !mod_php5.c>
- <IfModule prefork.c>
- LoadModule php7_module modules/libphp7.so
+ <IfModule !mod_php7.c>
+ <IfModule prefork.c>
+ LoadModule php_module modules/libphp.so
+ </IfModule>
</IfModule>
</IfModule>
diff --git a/php.spec b/php.spec
index e966bb0..84f6933 100644
--- a/php.spec
+++ b/php.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for php74-php
+# remirepo spec file for php80-php
# with SCL and backport stuff, adapted from
#
# Fedora spec file for php
@@ -23,8 +23,8 @@
%endif
# API/ABI check
-%global apiver 20190902
-%global zendver 20190902
+%global apiver 20190128
+%global zendver 20190128
%global pdover 20170320
# Extension version
%global oci8ver 2.2.0
@@ -33,7 +33,7 @@
%global _hardened_build 1
# version used for php embedded library soname
-%global embed_version 7.4
+%global embed_version 8.0
# Ugly hack. Harcoded values to avoid relocation.
%global _httpd_mmn %(cat %{_root_includedir}/httpd/.mmn 2>/dev/null || echo 0)
@@ -97,14 +97,14 @@
%global with_zip 0
-%global gh_commit eac238fb6cb6f38c2f3ba1d0fa129ea8d42fec38
+%global gh_commit 175e5ed4bf85b68a5a60cb481322c18f2f9f8f46
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_date 20190612
+%global gh_date 20190612
%global gh_owner php
%global gh_project php-src
-%global upver 7.4.5
-%global rcver RC1
-%global lower RC1
+%global upver 8.0.0
+#global rcver DEV
+%global lower DEV
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -124,6 +124,9 @@ URL: http://www.php.net/
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{upver}-%{gh_short}.tar.gz
%else
Source0: http://www.php.net/distributions/php-%{upver}%{?rcver}.tar.xz
+# See https://secure.php.net/gpg-keys.php
+Source20: https://www.php.net/distributions/php-keyring.gpg
+Source21: https://www.php.net/distributions/php-%{upver}%{?rcver}.tar.xz.asc
%endif
Source1: php.conf
Source2: php.ini
@@ -136,9 +139,6 @@ Source8: php-fpm.sysconfig
Source9: php.modconf
Source10: php.conf2
Source12: php-fpm.wants
-# See https://secure.php.net/gpg-keys.php
-Source20: https://www.php.net/distributions/php-keyring.gpg
-Source21: https://www.php.net/distributions/php-%{upver}%{?rcver}.tar.xz.asc
# Configuration files for some extensions
Source50: 10-opcache.ini
Source51: opcache-default.blacklist
@@ -149,7 +149,7 @@ Source53: 20-ffi.ini
Patch1: php-7.4.0-httpd.patch
Patch5: php-7.2.0-includedir.patch
Patch6: php-7.4.0-embed.patch
-Patch8: php-7.2.0-libdb.patch
+Patch8: php-7.4.0-libdb.patch
Patch9: php-7.0.7-curl.patch
# Functional changes
@@ -172,13 +172,13 @@ Patch91: php-7.2.0-oci8conf.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
-Patch300: php-7.0.10-datetests.patch
+Patch300: php-7.4.0-datetests.patch
# WIP
BuildRequires: gnupg2
BuildRequires: bzip2-devel
-BuildRequires: pkgconfig(libcurl) >= 7.15.5
+BuildRequires: pkgconfig(libcurl) >= 7.29.0
BuildRequires: libdb-devel
BuildRequires: httpd-devel >= 2.0.46-1
BuildRequires: pam-devel
@@ -247,7 +247,7 @@ Requires: %{?scl_prefix}php-sodium%{?_isa} = %{version}-%{release}
# Don't provides extensions, or shared libraries (embedded)
-%{?filter_from_requires: %filter_from_requires /libphp7.*so/d}
+%{?filter_from_requires: %filter_from_requires /libphp.*so/d}
%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
%{?filter_setup}
@@ -910,7 +910,11 @@ in pure PHP.
%prep
+%if 0%{?gh_date}
+: no gpg check for git snapshot
+%else
%{?gpgverify:%{gpgverify} --keyring='%{SOURCE20}' --signature='%{SOURCE21}' --data='%{SOURCE0}'}
+%endif
: Building %{name}-%{version}-%{release} with imap=%{with_imap} freetds=%{with_freetds} sqlite3=%{with_sqlite3} tidy=%{with_tidy} zip=%{with_zip}
%if 0%{?gh_date}
@@ -1294,7 +1298,7 @@ build --enable-fpm \
popd
# Build for inclusion as embedded script language into applications,
-# /usr/lib[64]/libphp7.so
+# /usr/lib[64]/libphp.so
pushd build-embedded
build --enable-embed \
--without-mysqli \
@@ -1355,13 +1359,13 @@ install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/php/preload
# install the DSO
install -m 755 -d $RPM_BUILD_ROOT%{_httpd_moddir}
-install -m 755 build-apache/libs/libphp7.so $RPM_BUILD_ROOT%{_httpd_moddir}
+install -m 755 build-apache/libs/libphp.so $RPM_BUILD_ROOT%{_httpd_moddir}
# Apache config fragment
%if %{?scl:1}0
-sed -e 's/libphp7/lib%{scl}/' %{SOURCE9} >modconf
+sed -e 's/libphp/lib%{scl}/' %{SOURCE9} >modconf
install -m 755 -d $RPM_BUILD_ROOT%{_root_httpd_moddir}
-ln -s %{_httpd_moddir}/libphp7.so $RPM_BUILD_ROOT%{_root_httpd_moddir}/lib%{scl}.so
+ln -s %{_httpd_moddir}/libphp.so $RPM_BUILD_ROOT%{_root_httpd_moddir}/lib%{scl}.so
%else
cp %{SOURCE9} modconf
%endif
@@ -1590,8 +1594,8 @@ install -m 644 -D macros.php \
rm -rf $RPM_BUILD_ROOT%{_libdir}/php/modules/*.a \
$RPM_BUILD_ROOT%{_bindir}/{phptar} \
$RPM_BUILD_ROOT%{_datadir}/pear \
- $RPM_BUILD_ROOT%{_libdir}/libphp7.a \
- $RPM_BUILD_ROOT%{_libdir}/libphp7.la
+ $RPM_BUILD_ROOT%{_libdir}/libphp.a \
+ $RPM_BUILD_ROOT%{_libdir}/libphp.la
# Remove irrelevant docs
rm -f README.{Zeus,QNX,CVS-RULES}
@@ -1650,7 +1654,7 @@ fi
%{!?_licensedir:%global license %%doc}
%files
-%{_httpd_moddir}/libphp7.so
+%{_httpd_moddir}/libphp.so
%if 0%{?scl:1}
%dir %{_libdir}/httpd
%dir %{_libdir}/httpd/modules
@@ -1747,8 +1751,8 @@ fi
%endif
%files embedded
-%{_libdir}/libphp7.so
-%{_libdir}/libphp7-%{embed_version}.so
+%{_libdir}/libphp.so
+%{_libdir}/libphp-%{embed_version}.so
%files devel
%{_bindir}/php-config
@@ -1810,6 +1814,9 @@ fi
%changelog
+* Thu Apr 9 2020 Remi Collet <remi@remirepo.net> - 8.0.0~DEV.20190612-1
+- update to 8.0.0-dev
+
* Tue Mar 31 2020 Remi Collet <remi@remirepo.net> - 7.4.5~RC1-1
- update to 7.4.5RC1