summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-02 09:10:19 +0200
committerRemi Collet <remi@remirepo.net>2020-09-02 09:10:19 +0200
commit526ab4bd8fedcd3bf1a400b2a68be0da8c653d2c (patch)
tree64706aa723a76d52380035b4d358d8f890c916f1
parent19f7991bd5abf6e9d197464bf3c393f6016ea782 (diff)
update to 8.0.0beta3
adapt systzdata patch (v19)
-rw-r--r--failed.txt2
-rw-r--r--php-8.0.0-parser.patch2
-rw-r--r--php-8.0.0-systzdata-v19.patch (renamed from php-7.3.3-systzdata-v18.patch)39
-rw-r--r--php-upstream.patch47
-rw-r--r--php.spec12
5 files changed, 29 insertions, 73 deletions
diff --git a/failed.txt b/failed.txt
index a735c09..ca773d5 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.8.0beta2 (2020-08-20)
+===== 7.8.0beta3 (2020-09-03)
$ grep -ar 'Tests failed' /var/lib/mock/scl80*/build.log
diff --git a/php-8.0.0-parser.patch b/php-8.0.0-parser.patch
index 4260b50..f5da3b5 100644
--- a/php-8.0.0-parser.patch
+++ b/php-8.0.0-parser.patch
@@ -11,6 +11,6 @@ diff -up ./build/gen_stub.php.syslib ./build/gen_stub.php
+ return;
+ }
+
- $version = "4.3.0";
+ $version = "4.9.0";
$phpParserDir = __DIR__ . "/PHP-Parser-$version";
if (!is_dir($phpParserDir)) {
diff --git a/php-7.3.3-systzdata-v18.patch b/php-8.0.0-systzdata-v19.patch
index eac3cc3..902d3ce 100644
--- a/php-7.3.3-systzdata-v18.patch
+++ b/php-8.0.0-systzdata-v19.patch
@@ -5,6 +5,7 @@ Add support for use of the system timezone database, rather
than embedding a copy. Discussed upstream but was not desired.
History:
+r19: adapt for timelib 2020.02 (in 8.0.0beta2)
r18: adapt for autotool change in 7.3.3RC1
r17: adapt for timelib 2018.01 (in 7.3.2RC1)
r16: adapt for timelib 2017.06 (in 7.2.3RC1)
@@ -29,10 +30,10 @@ r3: fix a crash if /usr/share/zoneinfo doesn't exist (Raphael Geissert)
r2: add filesystem trawl to set up name alias index
r1: initial revision
-diff -up php-7.3.3RC1/ext/date/config0.m4.systzdata php-7.3.3RC1/ext/date/config0.m4
---- php-7.3.3RC1/ext/date/config0.m4.systzdata 2019-02-19 14:57:51.314601701 +0100
-+++ php-7.3.3RC1/ext/date/config0.m4 2019-02-19 14:58:29.050812587 +0100
-@@ -9,6 +9,19 @@ io.h
+diff -up php-8.0.0beta3/ext/date/config0.m4.systzdata php-8.0.0beta3/ext/date/config0.m4
+--- php-8.0.0beta3/ext/date/config0.m4.systzdata 2020-09-01 19:13:26.000000000 +0200
++++ php-8.0.0beta3/ext/date/config0.m4 2020-09-02 08:07:51.039979873 +0200
+@@ -4,6 +4,19 @@ AC_CHECK_HEADERS([io.h])
dnl Check for strtoll, atoll
AC_CHECK_FUNCS(strtoll atoll)
@@ -52,10 +53,10 @@ diff -up php-7.3.3RC1/ext/date/config0.m4.systzdata php-7.3.3RC1/ext/date/config
PHP_DATE_CFLAGS="-I@ext_builddir@/lib -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -DHAVE_TIMELIB_CONFIG_H=1"
timelib_sources="lib/astro.c lib/dow.c lib/parse_date.c lib/parse_tz.c
lib/timelib.c lib/tm2unixtime.c lib/unixtime2tm.c lib/parse_iso_intervals.c lib/interval.c"
-diff -up php-7.3.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.3.3RC1/ext/date/lib/parse_tz.c
---- php-7.3.3RC1/ext/date/lib/parse_tz.c.systzdata 2019-02-19 12:18:27.000000000 +0100
-+++ php-7.3.3RC1/ext/date/lib/parse_tz.c 2019-02-19 14:57:20.397428931 +0100
-@@ -25,8 +25,21 @@
+diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/date/lib/parse_tz.c
+--- php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata 2020-09-01 19:13:26.000000000 +0200
++++ php-8.0.0beta3/ext/date/lib/parse_tz.c 2020-09-02 08:07:51.039979873 +0200
+@@ -26,8 +26,21 @@
#include "timelib.h"
#include "timelib_private.h"
@@ -77,7 +78,7 @@ diff -up php-7.3.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.3.3RC1/ext/date/li
#if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
# if defined(__LITTLE_ENDIAN__)
-@@ -87,6 +100,11 @@ static int read_php_preamble(const unsig
+@@ -94,6 +107,11 @@ static int read_php_preamble(const unsig
{
uint32_t version;
@@ -89,11 +90,11 @@ diff -up php-7.3.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.3.3RC1/ext/date/li
/* read ID */
version = (*tzf)[3] - '0';
*tzf += 4;
-@@ -411,7 +429,429 @@ void timelib_dump_tzinfo(timelib_tzinfo
+@@ -418,7 +436,429 @@ void timelib_dump_tzinfo(timelib_tzinfo
}
}
--static int seek_to_tz_position(const unsigned char **tzf, char *timezone, const timelib_tzdb *tzdb)
+-static int seek_to_tz_position(const unsigned char **tzf, const char *timezone, const timelib_tzdb *tzdb)
+#ifdef HAVE_SYSTEM_TZDATA
+
+#ifdef HAVE_SYSTEM_TZDATA_PREFIX
@@ -516,15 +517,15 @@ diff -up php-7.3.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.3.3RC1/ext/date/li
+
+#endif
+
-+static int inmem_seek_to_tz_position(const unsigned char **tzf, char *timezone, const timelib_tzdb *tzdb)
++static int inmem_seek_to_tz_position(const unsigned char **tzf, const char *timezone, const timelib_tzdb *tzdb)
{
int left = 0, right = tzdb->index_size - 1;
-@@ -437,9 +877,48 @@ static int seek_to_tz_position(const uns
+@@ -444,9 +884,48 @@ static int seek_to_tz_position(const uns
return 0;
}
-+static int seek_to_tz_position(const unsigned char **tzf, char *timezone,
++static int seek_to_tz_position(const unsigned char **tzf, const char *timezone,
+ char **map, size_t *maplen,
+ const timelib_tzdb *tzdb)
+{
@@ -569,8 +570,8 @@ diff -up php-7.3.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.3.3RC1/ext/date/li
}
const timelib_tzdb_index_entry *timelib_timezone_identifiers_list(const timelib_tzdb *tzdb, int *count)
-@@ -451,7 +930,30 @@ const timelib_tzdb_index_entry *timelib_
- int timelib_timezone_id_is_valid(char *timezone, const timelib_tzdb *tzdb)
+@@ -458,7 +937,30 @@ const timelib_tzdb_index_entry *timelib_
+ int timelib_timezone_id_is_valid(const char *timezone, const timelib_tzdb *tzdb)
{
const unsigned char *tzf;
- return (seek_to_tz_position(&tzf, timezone, tzdb));
@@ -601,8 +602,8 @@ diff -up php-7.3.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.3.3RC1/ext/date/li
}
static int skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
-@@ -493,12 +995,14 @@ static timelib_tzinfo* timelib_tzinfo_ct
- timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb, int *error_code)
+@@ -500,12 +1002,14 @@ static timelib_tzinfo* timelib_tzinfo_ct
+ timelib_tzinfo *timelib_parse_tzfile(const char *timezone, const timelib_tzdb *tzdb, int *error_code)
{
const unsigned char *tzf;
+ char *memmap = NULL;
@@ -617,7 +618,7 @@ diff -up php-7.3.3RC1/ext/date/lib/parse_tz.c.systzdata php-7.3.3RC1/ext/date/li
tmp = timelib_tzinfo_ctor(timezone);
version = read_preamble(&tzf, tmp, &type);
-@@ -537,11 +1041,36 @@ timelib_tzinfo *timelib_parse_tzfile(cha
+@@ -540,11 +1044,36 @@ timelib_tzinfo *timelib_parse_tzfile(con
}
skip_posix_string(&tzf, tmp);
diff --git a/php-upstream.patch b/php-upstream.patch
deleted file mode 100644
index a26c127..0000000
--- a/php-upstream.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 55798e0e391d18d7e7d321c1149b12aa89d7d4ff Mon Sep 17 00:00:00 2001
-From: Nikita Popov <nikita.ppv@gmail.com>
-Date: Wed, 26 Aug 2020 15:19:23 +0200
-Subject: [PATCH] Lowercase method name in zend_call_method()
-
----
- Zend/zend_interfaces.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Zend/zend_interfaces.c b/Zend/zend_interfaces.c
-index 16c193e42060..808de7c170da 100644
---- a/Zend/zend_interfaces.c
-+++ b/Zend/zend_interfaces.c
-@@ -53,7 +53,7 @@ ZEND_API zval* zend_call_method(zend_object *object, zend_class_entry *obj_ce, z
- }
- if (!fn_proxy || !*fn_proxy) {
- if (EXPECTED(obj_ce)) {
-- fn = zend_hash_str_find_ptr(
-+ fn = zend_hash_str_find_ptr_lc(
- &obj_ce->function_table, function_name, function_name_len);
- if (UNEXPECTED(fn == NULL)) {
- /* error at c-level */
-From 8c57474e35fa1ae9c256ac224ea646673c9d404c Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Fri, 21 Aug 2020 14:41:35 +0200
-Subject: [PATCH] ensure installed ini don't interfere
-
----
- sapi/cli/tests/bug62294.phpt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/sapi/cli/tests/bug62294.phpt b/sapi/cli/tests/bug62294.phpt
-index b300729939f..04d0d8b60e4 100644
---- a/sapi/cli/tests/bug62294.phpt
-+++ b/sapi/cli/tests/bug62294.phpt
-@@ -4,7 +4,7 @@ Bug #62294: register_shutdown_function() does not handle exit code correctly
- <?php
-
- $php = getenv('TEST_PHP_EXECUTABLE');
--exec($php . ' ' . __DIR__ . '/bug62294.inc', $output, $exit_status);
-+exec($php . ' -n ' . __DIR__ . '/bug62294.inc', $output, $exit_status);
- var_dump($exit_status);
-
- ?>
---
-2.11.0
-
diff --git a/php.spec b/php.spec
index a699e9e..17114ad 100644
--- a/php.spec
+++ b/php.spec
@@ -106,13 +106,13 @@
%global gh_owner php
%global gh_project php-src
%global upver 8.0.0
-%global rcver beta2
+%global rcver beta3
%global lower %{rcver}
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 30%{?dist}
+Release: 31%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -158,7 +158,7 @@ Patch9: php-7.0.7-curl.patch
# Use system nikic/php-parser
Patch41: php-8.0.0-parser.patch
# use system tzdata
-Patch42: php-7.3.3-systzdata-v18.patch
+Patch42: php-8.0.0-systzdata-v19.patch
# See http://bugs.php.net/53436
Patch43: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -171,7 +171,6 @@ Patch47: php-8.0.0-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-upstream.patch
# Security fixes (200+)
@@ -892,7 +891,6 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1
# security patches
@@ -1765,6 +1763,10 @@ fi
%changelog
+* Wed Sep 2 2020 Remi Collet <remi@remirepo.net> - 8.0.0~beta3-31
+- update to 8.0.0beta3
+- adapt systzdata patch (v19)
+
* Wed Aug 26 2020 Remi Collet <remi@remirepo.net> - 8.0.0~beta2-30
- build with upstream fix for zend_call_method