summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-26 15:57:52 +0200
committerRemi Collet <remi@remirepo.net>2020-08-26 15:57:52 +0200
commit19f7991bd5abf6e9d197464bf3c393f6016ea782 (patch)
treed06174a2b2e99a45a44a85200b4ab2db718b4fd5
parentd0e06a3e823c957f4e41e57930aa8999e34da971 (diff)
build with upstream fix for zend_call_method
-rw-r--r--failed.txt12
-rw-r--r--php-upstream.patch47
-rw-r--r--php.spec7
3 files changed, 58 insertions, 8 deletions
diff --git a/failed.txt b/failed.txt
index 14ae40d..a735c09 100644
--- a/failed.txt
+++ b/failed.txt
@@ -2,15 +2,13 @@
$ grep -ar 'Tests failed' /var/lib/mock/scl80*/build.log
-/var/lib/mock/scl80el7x/build.log:Tests failed : 1
-/var/lib/mock/scl80el8x/build.log:Tests failed : 2
-/var/lib/mock/scl80fc31x/build.log:Tests failed : 1
-/var/lib/mock/scl80fc32x/build.log:Tests failed : 1
-/var/lib/mock/scl80fc33x/build.log:Tests failed : 1
+/var/lib/mock/scl80el7x/build.log:Tests failed : 0
+/var/lib/mock/scl80el8x/build.log:Tests failed : 1
+/var/lib/mock/scl80fc31x/build.log:Tests failed : 0
+/var/lib/mock/scl80fc32x/build.log:Tests failed : 0
+/var/lib/mock/scl80fc33x/build.log:Tests failed : 0
-all
- 2 Bug #62294: register_shutdown_function() does not handle exit code correctly [sapi/cli/tests/bug62294.phpt]
el8x:
3 Bug #78338 (Array cross-border reading in PCRE) [ext/pcre/tests/bug78338.phpt]
diff --git a/php-upstream.patch b/php-upstream.patch
new file mode 100644
index 0000000..a26c127
--- /dev/null
+++ b/php-upstream.patch
@@ -0,0 +1,47 @@
+From 55798e0e391d18d7e7d321c1149b12aa89d7d4ff Mon Sep 17 00:00:00 2001
+From: Nikita Popov <nikita.ppv@gmail.com>
+Date: Wed, 26 Aug 2020 15:19:23 +0200
+Subject: [PATCH] Lowercase method name in zend_call_method()
+
+---
+ Zend/zend_interfaces.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Zend/zend_interfaces.c b/Zend/zend_interfaces.c
+index 16c193e42060..808de7c170da 100644
+--- a/Zend/zend_interfaces.c
++++ b/Zend/zend_interfaces.c
+@@ -53,7 +53,7 @@ ZEND_API zval* zend_call_method(zend_object *object, zend_class_entry *obj_ce, z
+ }
+ if (!fn_proxy || !*fn_proxy) {
+ if (EXPECTED(obj_ce)) {
+- fn = zend_hash_str_find_ptr(
++ fn = zend_hash_str_find_ptr_lc(
+ &obj_ce->function_table, function_name, function_name_len);
+ if (UNEXPECTED(fn == NULL)) {
+ /* error at c-level */
+From 8c57474e35fa1ae9c256ac224ea646673c9d404c Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Fri, 21 Aug 2020 14:41:35 +0200
+Subject: [PATCH] ensure installed ini don't interfere
+
+---
+ sapi/cli/tests/bug62294.phpt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/sapi/cli/tests/bug62294.phpt b/sapi/cli/tests/bug62294.phpt
+index b300729939f..04d0d8b60e4 100644
+--- a/sapi/cli/tests/bug62294.phpt
++++ b/sapi/cli/tests/bug62294.phpt
+@@ -4,7 +4,7 @@ Bug #62294: register_shutdown_function() does not handle exit code correctly
+ <?php
+
+ $php = getenv('TEST_PHP_EXECUTABLE');
+-exec($php . ' ' . __DIR__ . '/bug62294.inc', $output, $exit_status);
++exec($php . ' -n ' . __DIR__ . '/bug62294.inc', $output, $exit_status);
+ var_dump($exit_status);
+
+ ?>
+--
+2.11.0
+
diff --git a/php.spec b/php.spec
index 0863c5c..a699e9e 100644
--- a/php.spec
+++ b/php.spec
@@ -112,7 +112,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 29%{?dist}
+Release: 30%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -171,6 +171,7 @@ Patch47: php-8.0.0-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-upstream.patch
# Security fixes (200+)
@@ -891,6 +892,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1
# security patches
@@ -1763,6 +1765,9 @@ fi
%changelog
+* Wed Aug 26 2020 Remi Collet <remi@remirepo.net> - 8.0.0~beta2-30
+- build with upstream fix for zend_call_method
+
* Wed Aug 19 2020 Remi Collet <remi@remirepo.net> - 8.0.0~beta2-29
- update to 8.0.0beta2