summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-07-16 13:56:14 +0200
committerRemi Collet <remi@remirepo.net>2019-07-16 13:56:14 +0200
commit07b6234f76a03619e7fee8e681d9a3f114758811 (patch)
tree64f801380b624da46b066c37dbff302b1f4cff2b
parentf43fa65c5fd8383af3b5eb033f74d66db70a2ff4 (diff)
- update to 7.3.8RC1
- add upstream patch for #78297 - main package now recommends commonly used extensions (json, mbstring, opcache, pdo, xml)
-rw-r--r--failed.txt2
-rw-r--r--php-bug78297.patch62
-rw-r--r--php.spec22
3 files changed, 81 insertions, 5 deletions
diff --git a/failed.txt b/failed.txt
index 754676a..f13f1eb 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.3.7 (2019-07-04)
+===== 7.3.8RC1 (2019-07-18)
$ grep -ar 'Tests failed' /var/lib/mock/scl73*/build.log
diff --git a/php-bug78297.patch b/php-bug78297.patch
new file mode 100644
index 0000000..396a161
--- /dev/null
+++ b/php-bug78297.patch
@@ -0,0 +1,62 @@
+From f3e71b3b730eabc2b12871b3a19dad815219bcb9 Mon Sep 17 00:00:00 2001
+From: Nikita Popov <nikita.ppv@gmail.com>
+Date: Tue, 16 Jul 2019 11:08:27 +0200
+Subject: [PATCH] Fixed bug #78297
+
+(cherry picked from commit 8a19fe29de77d7477d59db472dd6aadabd5ac249)
+---
+ NEWS | 5 +++++
+ sapi/phpdbg/phpdbg_list.c | 1 +
+ sapi/phpdbg/tests/bug78297.phpt | 16 ++++++++++++++++
+ 3 files changed, 22 insertions(+)
+ create mode 100644 sapi/phpdbg/tests/bug78297.phpt
+
+diff --git a/NEWS b/NEWS
+index ae6a3c5405d8..76e8f830a0bb 100644
+--- a/NEWS
++++ b/NEWS
+@@ -1,5 +1,10 @@
+ PHP NEWS
+ |||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
++?? ??? ????, PHP 7.3.8
++
++- Phpdbg:
++ . Fixed bug #78297 (Include unexistent file memory leak). (Nikita)
++
+ 18 Jul 2019, PHP 7.3.8RC1
+
+ - Core:
+diff --git a/sapi/phpdbg/phpdbg_list.c b/sapi/phpdbg/phpdbg_list.c
+index aab641cb5606..a9b0f4b815cf 100644
+--- a/sapi/phpdbg/phpdbg_list.c
++++ b/sapi/phpdbg/phpdbg_list.c
+@@ -248,6 +248,7 @@ zend_op_array *phpdbg_compile_file(zend_file_handle *file, int type) {
+ } else {
+ zend_message_dispatcher(ZMSG_FAILED_INCLUDE_FOPEN, file->filename);
+ }
++ return NULL;
+ }
+
+ data.buf = estrndup(bufptr, len);
+diff --git a/sapi/phpdbg/tests/bug78297.phpt b/sapi/phpdbg/tests/bug78297.phpt
+new file mode 100644
+index 000000000000..47b13ad60544
+--- /dev/null
++++ b/sapi/phpdbg/tests/bug78297.phpt
+@@ -0,0 +1,16 @@
++--TEST--
++Bug #78297: Include unexistent file memory leak
++--PHPDBG--
++r
++q
++--FILE--
++<?php
++include "does_not_exist.php";
++--EXPECTF--
++[Successful compilation of %s]
++prompt>
++Warning: include(%s): failed to open stream: No such file or directory in %s on line %d
++
++Warning: include(): Failed opening 'does_not_exist.php' for inclusion (include_path=%s) in %s on line %d
++[Script ended normally]
++prompt>
diff --git a/php.spec b/php.spec
index 594a688..6058e99 100644
--- a/php.spec
+++ b/php.spec
@@ -131,13 +131,13 @@
%global db_devel libdb-devel
%endif
-%global upver 7.3.7
-#global rcver RC3
+%global upver 7.3.8
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 3%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -192,6 +192,7 @@ Patch48: php-7.3.3-pdooci.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-bug78297.patch
# Security fixes (200+)
@@ -252,7 +253,13 @@ Requires(pre): httpd
%endif
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# httpd have threaded MPM by default
-Recommends: %{?scl_prefix}php-fpm%{?_isa} = %{version}-%{release}
+Recommends: %{?scl_prefix}php-fpm%{?_isa} = %{version}-%{release}
+# as "php" is now mostly a meta-package, commonly used extensions
+Recommends: %{?scl_prefix}php-json%{?_isa} = %{version}-%{release}
+Recommends: %{?scl_prefix}php-mbstring%{?_isa} = %{version}-%{release}
+Recommends: %{?scl_prefix}php-opcache%{?_isa} = %{version}-%{release}
+Recommends: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
+Recommends: %{?scl_prefix}php-xml%{?_isa} = %{version}-%{release}
%endif
@@ -946,6 +953,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .78297
# security patches
@@ -1885,6 +1893,12 @@ fi
%changelog
+* Tue Jul 16 2019 Remi Collet <remi@remirepo.net> - 7.3.8~RC1-1
+- update to 7.3.8RC1
+- add upstream patch for #78297
+- main package now recommends commonly used extensions
+ (json, mbstring, opcache, pdo, xml)
+
* Wed Jul 3 2019 Remi Collet <remi@remirepo.net> - 7.3.7-3
- rebuild 7.3.7 (new tag)