summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-07-03 14:45:36 +0200
committerRemi Collet <remi@remirepo.net>2019-07-03 14:45:36 +0200
commitf43fa65c5fd8383af3b5eb033f74d66db70a2ff4 (patch)
tree44a6af8b52f13b4267033643ab2015942d76e724
parentd32d7c1425cc7358edaa8b078ed97d2fd324ffa2 (diff)
rebuild 7.3.7 (new tag)
-rw-r--r--php-bug78230.patch59
-rw-r--r--php.spec9
2 files changed, 5 insertions, 63 deletions
diff --git a/php-bug78230.patch b/php-bug78230.patch
deleted file mode 100644
index 355f8cc..0000000
--- a/php-bug78230.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From 4892bbc167dfa0ea188baebbce538225f4a0455a Mon Sep 17 00:00:00 2001
-From: Nikita Popov <nikita.ppv@gmail.com>
-Date: Wed, 3 Jul 2019 10:19:31 +0200
-Subject: [PATCH] Fixed bug #78230
-
----
- NEWS | 8 +++++---
- ext/opcache/Optimizer/sccp.c | 1 +
- ext/opcache/tests/bug78230.phpt | 29 +++++++++++++++++++++++++++++
- 3 files changed, 35 insertions(+), 3 deletions(-)
- create mode 100644 ext/opcache/tests/bug78230.phpt
-
-diff --git a/ext/opcache/Optimizer/sccp.c b/ext/opcache/Optimizer/sccp.c
-index ac3247076eaa..1ec3a5153241 100644
---- a/ext/opcache/Optimizer/sccp.c
-+++ b/ext/opcache/Optimizer/sccp.c
-@@ -2204,6 +2204,7 @@ static int try_remove_definition(sccp_ctx *ctx, int var_num, zend_ssa_var *var,
- if (opline->opcode == ZEND_DO_ICALL) {
- removed_ops = remove_call(ctx, opline, ssa_op);
- } else if (opline->opcode == ZEND_TYPE_CHECK
-+ && opline->op1_type & (IS_VAR|IS_TMP_VAR)
- && !value_known(&ctx->values[ssa_op->op1_use])) {
- /* For TYPE_CHECK we may compute the result value without knowing the
- * operand, based on type inference information. Make sure the operand is
-diff --git a/ext/opcache/tests/bug78230.phpt b/ext/opcache/tests/bug78230.phpt
-new file mode 100644
-index 000000000000..38cc68499517
---- /dev/null
-+++ b/ext/opcache/tests/bug78230.phpt
-@@ -0,0 +1,29 @@
-+--TEST--
-+Bug #78230: Incorrect type check optimization
-+--FILE--
-+<?php
-+
-+function test($x) {
-+ $y = (array) $x;
-+ var_dump(is_array($y));
-+}
-+
-+$ary = [1, 2];
-+$ary[] = 3;
-+test($ary);
-+$ary[] = 4;
-+var_dump($ary);
-+
-+?>
-+--EXPECT--
-+bool(true)
-+array(4) {
-+ [0]=>
-+ int(1)
-+ [1]=>
-+ int(2)
-+ [2]=>
-+ int(3)
-+ [3]=>
-+ int(4)
-+}
diff --git a/php.spec b/php.spec
index d162c39..594a688 100644
--- a/php.spec
+++ b/php.spec
@@ -67,8 +67,8 @@
%global with_lsws 1
# Regression tests take a long time, you can skip 'em with this
+#global runselftest 0
%{!?runselftest: %global runselftest 1}
-%global runselftest 0
# Use the arch-specific mysql_config binary to avoid mismatch with the
# arch detection heuristic used by bindir/mysql_config.
@@ -137,7 +137,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 3%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -192,7 +192,6 @@ Patch48: php-7.3.3-pdooci.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-bug78230.patch
# Security fixes (200+)
@@ -949,7 +948,6 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
# upstream patches
# security patches
-%patch100 -p1 -b .bug78230
# Fixes for tests
%patch300 -p1 -b .datetests
@@ -1887,6 +1885,9 @@ fi
%changelog
+* Wed Jul 3 2019 Remi Collet <remi@remirepo.net> - 7.3.7-3
+- rebuild 7.3.7 (new tag)
+
* Wed Jul 3 2019 Remi Collet <remi@remirepo.net> - 7.3.7-2
- add upstream patch for https://bugs.php.net/78230
segfault with opcache enabled