summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-17 14:31:03 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-17 14:31:03 +0100
commitba6911a354710b3d4757fe15e9821169938a82f5 (patch)
treedb1c7747fae7938f3fe300e26ec3fd7c17b93f00 /php.spec
parent627d322a9ac3b086aa5bde0f04570959f73bd2a6 (diff)
PHP 7: again, build with --disable-huge-code-pages on EL-6
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec16
1 files changed, 15 insertions, 1 deletions
diff --git a/php.spec b/php.spec
index e84df0b..b613ca6 100644
--- a/php.spec
+++ b/php.spec
@@ -1026,11 +1026,19 @@ sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
# Some extensions have their own configuration file
cp %{SOURCE50} 10-opcache.ini
-%ifarch x86_64
%if 0%{?rhel} != 6
+cat << EOF >>10-opcache.ini
+
+; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
+; This should improve performance, but requires appropriate OS configuration.
+opcache.huge_code_pages=0
+EOF
+%ifarch x86_64
sed -e '/opcache.huge_code_pages/s/0/1/' -i 10-opcache.ini
%endif
%endif
+tail -n 5 10-opcache.ini
+
cp %{SOURCE51} .
sed -e 's:%{_root_sysconfdir}:%{_sysconfdir}:' \
-i 10-opcache.ini
@@ -1139,6 +1147,9 @@ build --libdir=%{_libdir}/php \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
+%if 0%{?rhel} == 6
+ --disable-huge-code-pages \
+%endif
--enable-phpdbg \
%if %{with_imap}
--with-imap=shared --with-imap-ssl \
@@ -1806,6 +1817,9 @@ fi
%changelog
+* Thu Dec 17 2015 Remi Collet <remi@fedoraproject.org> 7.0.1-1.1
+- opcache: build with --disable-huge-code-pages on EL-6
+
* Wed Dec 16 2015 Remi Collet <remi@fedoraproject.org> 7.0.1-1
- Update to 7.0.1
http://www.php.net/releases/7_0_1.php