summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--10-opcache.ini4
-rw-r--r--php.spec16
2 files changed, 15 insertions, 5 deletions
diff --git a/10-opcache.ini b/10-opcache.ini
index 8e127cb..84492a6 100644
--- a/10-opcache.ini
+++ b/10-opcache.ini
@@ -105,7 +105,3 @@ opcache.blacklist_filename=/etc/php.d/opcache*.blacklist
; Enables or disables checksum validation when script loaded from file cache.
;opcache.file_cache_consistency_checks=1
-
-; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
-; This should improve performance, but requires appropriate OS configuration.
-opcache.huge_code_pages=0
diff --git a/php.spec b/php.spec
index e84df0b..b613ca6 100644
--- a/php.spec
+++ b/php.spec
@@ -1026,11 +1026,19 @@ sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
# Some extensions have their own configuration file
cp %{SOURCE50} 10-opcache.ini
-%ifarch x86_64
%if 0%{?rhel} != 6
+cat << EOF >>10-opcache.ini
+
+; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
+; This should improve performance, but requires appropriate OS configuration.
+opcache.huge_code_pages=0
+EOF
+%ifarch x86_64
sed -e '/opcache.huge_code_pages/s/0/1/' -i 10-opcache.ini
%endif
%endif
+tail -n 5 10-opcache.ini
+
cp %{SOURCE51} .
sed -e 's:%{_root_sysconfdir}:%{_sysconfdir}:' \
-i 10-opcache.ini
@@ -1139,6 +1147,9 @@ build --libdir=%{_libdir}/php \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
+%if 0%{?rhel} == 6
+ --disable-huge-code-pages \
+%endif
--enable-phpdbg \
%if %{with_imap}
--with-imap=shared --with-imap-ssl \
@@ -1806,6 +1817,9 @@ fi
%changelog
+* Thu Dec 17 2015 Remi Collet <remi@fedoraproject.org> 7.0.1-1.1
+- opcache: build with --disable-huge-code-pages on EL-6
+
* Wed Dec 16 2015 Remi Collet <remi@fedoraproject.org> 7.0.1-1
- Update to 7.0.1
http://www.php.net/releases/7_0_1.php