summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-13 07:44:12 +0200
committerRemi Collet <remi@remirepo.net>2019-10-13 07:44:12 +0200
commitf08e17687f48ec0f62b0b496c39ed926ab878e15 (patch)
tree452d1e334d2047f540afe4703bea19a72c3c1f7b
parent113561657c54e0298a545dd74202dbb0bbf57a02 (diff)
v2.12..1
-rw-r--r--composer.json39
-rw-r--r--php-zendframework-zend-validator.spec11
2 files changed, 31 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index ded80c0..89fa4c7 100644
--- a/composer.json
+++ b/composer.json
@@ -1,16 +1,19 @@
{
"name": "zendframework/zend-validator",
- "description": "provides a set of commonly needed validators",
+ "description": "Validation classes for a wide range of domains, and the ability to chain validators to create complex validation criteria",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zendframework",
+ "zf",
"validator"
],
- "homepage": "https://github.com/zendframework/zend-validator",
- "autoload": {
- "psr-4": {
- "Zend\\Validator\\": "src/"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-validator/",
+ "issues": "https://github.com/zendframework/zend-validator/issues",
+ "source": "https://github.com/zendframework/zend-validator",
+ "rss": "https://github.com/zendframework/zend-validator/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
"php": "^5.6 || ^7.0",
@@ -18,7 +21,7 @@
"container-interop/container-interop": "^1.1"
},
"require-dev": {
- "phpunit/PHPUnit": "^6.0.8 || ^5.7.15",
+ "phpunit/phpunit": "^6.0.8 || ^5.7.15",
"psr/http-message": "^1.0",
"zendframework/zend-cache": "^2.6.1",
"zendframework/zend-coding-standard": "~1.0.0",
@@ -43,8 +46,19 @@
"zendframework/zend-session": "Zend\\Session component, ^2.8; required by the Csrf validator",
"zendframework/zend-uri": "Zend\\Uri component, required by the Uri and Sitemap\\Loc validators"
},
- "minimum-stability": "dev",
- "prefer-stable": true,
+ "autoload": {
+ "psr-4": {
+ "Zend\\Validator\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Validator\\": "test/"
+ }
+ },
+ "config": {
+ "sort-packages": true
+ },
"extra": {
"branch-alias": {
"dev-master": "2.12.x-dev",
@@ -55,11 +69,6 @@
"config-provider": "Zend\\Validator\\ConfigProvider"
}
},
- "autoload-dev": {
- "psr-4": {
- "ZendTest\\Validator\\": "test/"
- }
- },
"scripts": {
"check": [
"@cs-check",
diff --git a/php-zendframework-zend-validator.spec b/php-zendframework-zend-validator.spec
index 6990dd4..e5cdd83 100644
--- a/php-zendframework-zend-validator.spec
+++ b/php-zendframework-zend-validator.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 64c33668e5fa2d39c6289a878f927ea2b0850c30
+%global gh_commit 7b870a7515f3a35afbecc39d63f34a861f40f58b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-validator
@@ -22,7 +22,7 @@
# TODO switch BR to fedora-autoloader + tests
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.12.0
+Version: 2.12.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -52,7 +52,7 @@ BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
BuildRequires: php-composer(container-interop/container-interop) >= 1.1
%endif
# From composer, "require-dev": {
-# "phpunit/PHPUnit": "^6.0.8 || ^5.7.15",
+# "phpunit/phpunit": "^6.0.8 || ^5.7.15",
# "psr/http-message": "^1.0",
# "zendframework/zend-cache": "^2.6.1",
# "zendframework/zend-coding-standard": "~1.0.0",
@@ -213,7 +213,7 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php70 php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
$cmd -d memory_limit=1G %{_bindir}/phpunit6 --verbose || ret=1
fi
@@ -233,6 +233,9 @@ exit $ret
%changelog
+* Sun Oct 13 2019 Remi Collet <remi@remirepo.net> - 2.12.1-1
+- update to 2.12.1
+
* Thu Jan 31 2019 Remi Collet <remi@remirepo.net> - 2.12.0-1
- update to 2.12.0
- raise dependency on zend-stdlib 3.2.1