summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-01-31 11:38:39 +0100
committerRemi Collet <remi@remirepo.net>2019-01-31 11:38:39 +0100
commit113561657c54e0298a545dd74202dbb0bbf57a02 (patch)
treed05ac19c4898f997d557ef41d3417806410794e4
parentd0d57b777580d90373edae210699476f0c698340 (diff)
update to 2.12.0
raise dependency on zend-stdlib 3.2.1
-rw-r--r--composer.json6
-rw-r--r--php-zendframework-zend-validator.spec25
2 files changed, 18 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index fc08755..ded80c0 100644
--- a/composer.json
+++ b/composer.json
@@ -14,7 +14,7 @@
},
"require": {
"php": "^5.6 || ^7.0",
- "zendframework/zend-stdlib": "^2.7.6 || ^3.1",
+ "zendframework/zend-stdlib": "^3.2.1",
"container-interop/container-interop": "^1.1"
},
"require-dev": {
@@ -47,8 +47,8 @@
"prefer-stable": true,
"extra": {
"branch-alias": {
- "dev-master": "2.11.x-dev",
- "dev-develop": "2.12.x-dev"
+ "dev-master": "2.12.x-dev",
+ "dev-develop": "2.13.x-dev"
},
"zf": {
"component": "Zend\\Validator",
diff --git a/php-zendframework-zend-validator.spec b/php-zendframework-zend-validator.spec
index 1ae795c..6990dd4 100644
--- a/php-zendframework-zend-validator.spec
+++ b/php-zendframework-zend-validator.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-validator
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit f0789b4c4c099afdd2ecc58cc209a26c64bd4f17
+%global gh_commit 64c33668e5fa2d39c6289a878f927ea2b0850c30
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-validator
@@ -22,11 +22,10 @@
# TODO switch BR to fedora-autoloader + tests
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.11.0
-Release: 2%{?dist}
+Version: 2.12.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
@@ -45,11 +44,11 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
# remirepo:4
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
BuildRequires: php-composer(container-interop/container-interop) >= 1.1
%endif
# From composer, "require-dev": {
@@ -102,17 +101,17 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-stdlib": "^2.7.6 || ^3.1",
+# "zendframework/zend-stdlib": "^3.2.1",
# "container-interop/container-interop": "^1.1"
Requires: php(language) >= 5.5
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
# remirepo:6
%else
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
Requires: php-composer(container-interop/container-interop) >= 1.1
Requires: php-composer(container-interop/container-interop) < 2
@@ -127,6 +126,7 @@ Requires: php-composer(container-interop/container-interop) < 2
# "zendframework/zend-servicemanager": "Zend\\ServiceManager component to allow using the ValidatorPluginManager and validator chains",
# "zendframework/zend-session": "Zend\\Session component, ^2.8; required by the Csrf validator",
# "zendframework/zend-uri": "Zend\\Uri component, required by the Uri and Sitemap\\Loc validators"
+# remirepo:1
%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
Recommends: php-composer(psr/http-message)
Suggests: php-composer(%{gh_owner}/zend-db)
@@ -137,6 +137,7 @@ Suggests: php-composer(%{gh_owner}/zend-i18n-resources)
Suggests: php-composer(%{gh_owner}/zend-servicemanager)
Suggests: php-composer(%{gh_owner}/zend-session)
Suggests: php-composer(%{gh_owner}/zend-uri)
+# remirepo:1
%endif
%endif
# Autoloader
@@ -232,6 +233,10 @@ exit $ret
%changelog
+* Thu Jan 31 2019 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+- raise dependency on zend-stdlib 3.2.1
+
* Fri Dec 14 2018 Remi Collet <remi@remirepo.net> - 2.11.0-2
- update to 2.11.0
- add weak dependency on psr/http-message