summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-13 11:41:39 +0100
committerRemi Collet <remi@remirepo.net>2017-12-13 11:41:39 +0100
commitda4d12844adc0f5363473ad604185c825fe79edf (patch)
treecf3811f8fc046950c9a12e052d3008254735e297
parent098fed59c998378724312582296cd6268fee3b60 (diff)
clean
-rw-r--r--php-zendframework-zend-navigation.spec22
1 files changed, 5 insertions, 17 deletions
diff --git a/php-zendframework-zend-navigation.spec b/php-zendframework-zend-navigation.spec
index 981a4f5..5d81263 100644
--- a/php-zendframework-zend-navigation.spec
+++ b/php-zendframework-zend-navigation.spec
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -118,8 +117,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -139,28 +136,19 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:7
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
-fi
-%{_bindir}/phpunit --verbose
-# remirepo:1
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md