summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-23 10:28:05 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-23 10:28:05 +0100
commit098fed59c998378724312582296cd6268fee3b60 (patch)
treed40b0cacbcfb66c7dbafaa92722f44fbd79762aa
parent0e83fb4b0457d51add9db5f2dc5095dbaee20188 (diff)
v2.8.2
-rw-r--r--.gitignore2
-rw-r--r--composer.json15
-rw-r--r--php-zendframework-zend-navigation.spec27
3 files changed, 33 insertions, 11 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..68787b5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tgz
+*.src.rpm
diff --git a/composer.json b/composer.json
index 536f956..3016210 100644
--- a/composer.json
+++ b/composer.json
@@ -28,8 +28,8 @@
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
"zendframework/zend-uri": "^2.5",
"zendframework/zend-view": "^2.6.5",
- "fabpot/php-cs-fixer": "1.7.*",
- "phpunit/phpunit": "^4.5"
+ "phpunit/phpunit": "^4.6",
+ "zendframework/zend-coding-standard": "~1.0.0"
},
"suggest": {
"zendframework/zend-config": "^2.6, to provide page configuration (optional, as arrays and Traversables are also allowed)",
@@ -54,5 +54,16 @@
"psr-4": {
"ZendTest\\Navigation\\": "test/"
}
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "upload-coverage": "coveralls -v"
}
}
diff --git a/php-zendframework-zend-navigation.spec b/php-zendframework-zend-navigation.spec
index 2a6a353..981a4f5 100644
--- a/php-zendframework-zend-navigation.spec
+++ b/php-zendframework-zend-navigation.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 353f5c31aeaaecc2c12e7f949c3feb3dc255019b
+%global gh_commit bcf78525bcfdb7956a516f0a122e5b3fde649d97
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-navigation
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.8.1
+Version: 2.8.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -50,8 +50,8 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "zendframework/zend-uri": "^2.5",
# "zendframework/zend-view": "^2.6.5",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "^4.5"
+# "phpunit/phpunit": "^4.6",
+# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
@@ -63,7 +63,7 @@ BuildRequires: php-composer(%{gh_owner}/zend-permissions-acl) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.5
+BuildRequires: php-composer(phpunit/phpunit) >= 4.6
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
@@ -139,11 +139,17 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+# remirepo:7
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit || ret=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit || ret=1
fi
+%{_bindir}/phpunit --verbose
+# remirepo:1
+exit $ret
%else
: Test suite disabled
%endif
@@ -163,6 +169,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Mar 23 2017 Remi Collet <remi@remirepo.net> - 2.8.2-1
+- Update to 2.8.2
+
* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 2.8.1-1
- update to 2.8.1