summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-navigation.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-navigation.spec')
-rw-r--r--php-zendframework-zend-navigation.spec27
1 files changed, 18 insertions, 9 deletions
diff --git a/php-zendframework-zend-navigation.spec b/php-zendframework-zend-navigation.spec
index 2a6a353..981a4f5 100644
--- a/php-zendframework-zend-navigation.spec
+++ b/php-zendframework-zend-navigation.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 353f5c31aeaaecc2c12e7f949c3feb3dc255019b
+%global gh_commit bcf78525bcfdb7956a516f0a122e5b3fde649d97
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-navigation
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.8.1
+Version: 2.8.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -50,8 +50,8 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "zendframework/zend-uri": "^2.5",
# "zendframework/zend-view": "^2.6.5",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "^4.5"
+# "phpunit/phpunit": "^4.6",
+# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
@@ -63,7 +63,7 @@ BuildRequires: php-composer(%{gh_owner}/zend-permissions-acl) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.5
+BuildRequires: php-composer(phpunit/phpunit) >= 4.6
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
@@ -139,11 +139,17 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+# remirepo:7
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit || ret=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit || ret=1
fi
+%{_bindir}/phpunit --verbose
+# remirepo:1
+exit $ret
%else
: Test suite disabled
%endif
@@ -163,6 +169,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Mar 23 2017 Remi Collet <remi@remirepo.net> - 2.8.2-1
+- Update to 2.8.2
+
* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 2.8.1-1
- update to 2.8.1