summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-29 08:19:53 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-29 08:19:53 +0100
commit5cdc17e5a1ddd2cad55491372347cf555fdaa3d4 (patch)
tree1675aaaaee2b0537324f9f576a6360ecb629ec55
parent1f3811f1157f4a8548941bbe8f0ae957f4bea9bd (diff)
php-zendframework-zend-modulemanager: refresh patch
-rw-r--r--php-zendframework-zend-modulemanager-dev.spec171
-rw-r--r--php-zendframework-zend-modulemanager-pr33.patch (renamed from php-zendframework-zend-modulemanager-pr32.patch)22
-rw-r--r--php-zendframework-zend-modulemanager.spec6
3 files changed, 17 insertions, 182 deletions
diff --git a/php-zendframework-zend-modulemanager-dev.spec b/php-zendframework-zend-modulemanager-dev.spec
deleted file mode 100644
index 6dce80a..0000000
--- a/php-zendframework-zend-modulemanager-dev.spec
+++ /dev/null
@@ -1,171 +0,0 @@
-# remirepo/fedora spec file for php-zendframework-zend-modulemanager
-#
-# Copyright (c) 2015-2016 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%global bootstrap 0
-%global gh_commit fe5a156df1ae4245c7b4a7b2b9067545761f59d7
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-modulemanager
-%global php_home %{_datadir}/php
-%global library ModuleManager
-%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
-%else
-%global with_tests 0%{!?_without_tests:1}
-%endif
-
-Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.0
-Release: 1%{?dist}
-Summary: Zend Framework %{library} component
-
-Group: Development/Libraries
-License: BSD
-URL: http://framework.zend.com/
-Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
-Source1: makesrc.sh
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildArch: noarch
-# Tests
-%if %{with_tests}
-BuildRequires: php(language) >= 5.5
-BuildRequires: php-spl
-BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
-# From composer, "require-dev": {
-# "zendframework/zend-config": "^2.6",
-# "zendframework/zend-console": "^2.6",
-# "zendframework/zend-di": "^2.6",
-# "zendframework/zend-loader": "^2.5",
-# "zendframework/zend-servicemanager": "^3.0.3",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-di) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 3.0.3
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
-# Because of bootstrap
-BuildRequires: php-composer(%{gh_owner}/zend-code) >= 2.5
-# Autoloader
-BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
-%endif
-
-# From composer, "require": {
-# "php": "^5.5 || ^7.0",
-# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 5.5
-%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
-Requires: php-composer(%{gh_owner}/zend-eventmanager) < 4
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
-Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
-# From composer, "suggest": {
-# "zendframework/zend-config": "Zend\\Config component",
-# "zendframework/zend-console": "Zend\\Console component",
-# "zendframework/zend-loader": "Zend\\Loader component",
-# "zendframework/zend-mvc": "Zend\\Mvc component",
-# "zendframework/zend-servicemanager": "Zend\\ServiceManager component"
-%if 0%{?fedora} >= 21
-Suggests: php-composer(%{gh_owner}/zend-config)
-Suggests: php-composer(%{gh_owner}/zend-console)
-Suggests: php-composer(%{gh_owner}/zend-loader)
-Suggests: php-composer(%{gh_owner}/zend-mvc)
-Suggests: php-composer(%{gh_owner}/zend-servicemanager)
-%endif
-%endif
-# From phpcompatinfo report for version 2.6.1
-Requires: php-spl
-
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
-
-
-%description
-Zend Framework 2.0 introduces a new and powerful approach to modules.
-This new module system is designed with flexibility, simplicity, and
-re-usability in mind. A module may contain just about anything:
-PHP code, including MVC functionality; library code; view scripts;
-and/or public assets such as images, CSS, and JavaScript.
-The possibilities are endless.
-
-Zend\ModuleManager is the component that enables the design of a module architecture for PHP applcations.
-
-
-%prep
-%setup -q -n %{gh_project}-%{gh_commit}
-
-
-%build
-# Empty build section, nothing required
-
-
-%install
-rm -rf %{buildroot}
-
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
-
-
-%check
-%if %{with_tests}
-mkdir vendor
-cat << 'EOF' | tee vendor/autoload.php
-<?php
-require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\Loader\AutoloaderFactory::factory(array(
- 'Zend\Loader\StandardAutoloader' => array(
- 'namespaces' => array(
- 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
-))));
-require_once '%{php_home}/Zend/autoload.php';
-EOF
-
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-fi
-%else
-: Test suite disabled
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%{!?_licensedir:%global license %%doc}
-%license LICENSE.md
-%doc CONTRIBUTING.md README.md
-%doc composer.json
-%{php_home}/Zend/%{library}
-
-
-%changelog
-* Fri Feb 26 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
-- update to 2.7.0
-- raise dependency on zend-eventmanager >= 2.6.2
-
-* Thu Jan 28 2016 Remi Collet <remi@fedoraproject.org> - 2.6.1-1
-- update to 2.6.1
-- raise dependency on zend-stdlib ~2.7
-
-* Thu Sep 10 2015 Remi Collet <remi@fedoraproject.org> - 2.5.3-1
-- update to 2.5.3
-- raise minimum php version to 5.5
-
-* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
-- initial package
diff --git a/php-zendframework-zend-modulemanager-pr32.patch b/php-zendframework-zend-modulemanager-pr33.patch
index 5164755..49dae69 100644
--- a/php-zendframework-zend-modulemanager-pr32.patch
+++ b/php-zendframework-zend-modulemanager-pr33.patch
@@ -1,17 +1,26 @@
-From 34478c17ac6f9b94a3b9f4eaf68646682d8bdbea Mon Sep 17 00:00:00 2001
+From de4135de41a32e593119e1feed8f0416470f7721 Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Sun, 28 Feb 2016 17:53:09 +0100
Subject: [PATCH] remove uneeded AutoloaderFactory::unregisterAutoloaders()
---
- test/ResetAutoloadFunctionsTrait.php | 1 -
- 1 file changed, 1 deletion(-)
+ test/ResetAutoloadFunctionsTrait.php | 3 ---
+ 1 file changed, 3 deletions(-)
diff --git a/test/ResetAutoloadFunctionsTrait.php b/test/ResetAutoloadFunctionsTrait.php
-index 24e5e37..4a4d28c 100644
+index 24e5e37..25b4a4c 100644
--- a/test/ResetAutoloadFunctionsTrait.php
+++ b/test/ResetAutoloadFunctionsTrait.php
-@@ -52,7 +52,6 @@ trait ResetAutoloadFunctionsTrait
+@@ -9,8 +9,6 @@
+
+ namespace ZendTest\ModuleManager;
+
+-use Zend\Loader\AutoloaderFactory;
+-
+ /**
+ * Offer common setUp/tearDown methods for preserve current autoload functions and include paths.
+ */
+@@ -52,7 +50,6 @@ protected function preserveIncludePath()
*/
protected function restoreAutoloadFunctions()
{
@@ -19,6 +28,3 @@ index 24e5e37..4a4d28c 100644
$loaders = spl_autoload_functions();
if (is_array($loaders)) {
foreach ($loaders as $loader) {
---
-2.5.0
-
diff --git a/php-zendframework-zend-modulemanager.spec b/php-zendframework-zend-modulemanager.spec
index c471b35..e83e4b0 100644
--- a/php-zendframework-zend-modulemanager.spec
+++ b/php-zendframework-zend-modulemanager.spec
@@ -30,7 +30,7 @@ URL: http://framework.zend.com/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: %{name}-pr32.patch
+Patch0: %{name}-pr33.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
@@ -106,7 +106,7 @@ Zend\ModuleManager is the component that enables the design of a module architec
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .pr32
+%patch0 -p1 -b .pr33
%build
@@ -161,7 +161,7 @@ rm -rf %{buildroot}
%changelog
* Sun Feb 28 2016 Remi Collet <remi@fedoraproject.org> - 2.7.1-1
- update to 2.7.1
-- https://github.com/zendframework/zend-modulemanager/pull/32
+- https://github.com/zendframework/zend-modulemanager/pull/33
* Fri Feb 26 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
- update to 2.7.0