summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-28 18:02:54 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-28 18:02:54 +0100
commit1f3811f1157f4a8548941bbe8f0ae957f4bea9bd (patch)
treecfcb701921f5e3e0074e1a8b9e1750bf28693e38
parented7c93b64d15f73a2b3df8dfce248bc0aaef14ca (diff)
php-zendframework-zend-modulemanager: 2.7.1
-rw-r--r--php-zendframework-zend-modulemanager-pr32.patch24
-rw-r--r--php-zendframework-zend-modulemanager.spec54
2 files changed, 56 insertions, 22 deletions
diff --git a/php-zendframework-zend-modulemanager-pr32.patch b/php-zendframework-zend-modulemanager-pr32.patch
new file mode 100644
index 0000000..5164755
--- /dev/null
+++ b/php-zendframework-zend-modulemanager-pr32.patch
@@ -0,0 +1,24 @@
+From 34478c17ac6f9b94a3b9f4eaf68646682d8bdbea Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Sun, 28 Feb 2016 17:53:09 +0100
+Subject: [PATCH] remove uneeded AutoloaderFactory::unregisterAutoloaders()
+
+---
+ test/ResetAutoloadFunctionsTrait.php | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/test/ResetAutoloadFunctionsTrait.php b/test/ResetAutoloadFunctionsTrait.php
+index 24e5e37..4a4d28c 100644
+--- a/test/ResetAutoloadFunctionsTrait.php
++++ b/test/ResetAutoloadFunctionsTrait.php
+@@ -52,7 +52,6 @@ trait ResetAutoloadFunctionsTrait
+ */
+ protected function restoreAutoloadFunctions()
+ {
+- AutoloaderFactory::unregisterAutoloaders();
+ $loaders = spl_autoload_functions();
+ if (is_array($loaders)) {
+ foreach ($loaders as $loader) {
+--
+2.5.0
+
diff --git a/php-zendframework-zend-modulemanager.spec b/php-zendframework-zend-modulemanager.spec
index 4f5aab5..c471b35 100644
--- a/php-zendframework-zend-modulemanager.spec
+++ b/php-zendframework-zend-modulemanager.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-modulemanager
+# remirepo/fedora spec file for php-zendframework-zend-modulemanager
#
# Copyright (c) 2015-2016 Remi Collet
# License: CC-BY-SA
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 5d11387829cfc68359da7ea600dea835acb31a22
+%global gh_commit a2c3af17bd620028e8478a2e115e06623c4b6400
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-modulemanager
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.6.1
+Version: 2.7.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -30,6 +30,8 @@ URL: http://framework.zend.com/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: %{name}-pr32.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
@@ -39,37 +41,35 @@ BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
-# "zendframework/zend-config": "~2.5",
-# "zendframework/zend-console": "~2.5",
-# "zendframework/zend-di": "~2.5",
-# "zendframework/zend-loader": "~2.5",
-# "zendframework/zend-mvc": "~2.5",
-# "zendframework/zend-servicemanager": "~2.5",
+# "zendframework/zend-config": "^2.6",
+# "zendframework/zend-console": "^2.6",
+# "zendframework/zend-di": "^2.6",
+# "zendframework/zend-loader": "^2.5",
+# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "fabpot/php-cs-fixer": "1.7.*",
# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-di) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-di) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-mvc) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
# Because of bootstrap
-BuildRequires: php-composer(%{gh_owner}/zend-code) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-code) >= 2.5
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.5",
-# "zendframework/zend-eventmanager": "~2.5",
-# "zendframework/zend-stdlib": "~2.7"
+# "php": "^5.5 || ^7.0",
+# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
+# "zendframework/zend-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 5.5
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.5
-Requires: php-composer(%{gh_owner}/zend-eventmanager) < 3
+Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
+Requires: php-composer(%{gh_owner}/zend-eventmanager) < 4
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
-Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
+Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
# "zendframework/zend-config": "Zend\\Config component",
# "zendframework/zend-console": "Zend\\Console component",
@@ -106,6 +106,8 @@ Zend\ModuleManager is the component that enables the design of a module architec
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1 -b .pr32
+
%build
# Empty build section, nothing required
@@ -157,6 +159,14 @@ rm -rf %{buildroot}
%changelog
+* Sun Feb 28 2016 Remi Collet <remi@fedoraproject.org> - 2.7.1-1
+- update to 2.7.1
+- https://github.com/zendframework/zend-modulemanager/pull/32
+
+* Fri Feb 26 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
+- update to 2.7.0
+- raise dependency on zend-eventmanager >= 2.6.2
+
* Thu Jan 28 2016 Remi Collet <remi@fedoraproject.org> - 2.6.1-1
- update to 2.6.1
- raise dependency on zend-stdlib ~2.7
@@ -166,4 +176,4 @@ rm -rf %{buildroot}
- raise minimum php version to 5.5
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
-- initial package \ No newline at end of file
+- initial package