summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-17 07:31:41 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-17 07:31:41 +0200
commit5c019b0ba13915cbbdf8908794eb0fe54d2bf1ad (patch)
tree7797337680f86c7071aaa5547498e3622cdc0cf8
parent5cdc17e5a1ddd2cad55491372347cf555fdaa3d4 (diff)
php-zendframework-zend-modulemanager: 2.7.2
-rw-r--r--composer.json50
-rw-r--r--php-zendframework-zend-modulemanager-pr33.patch30
-rw-r--r--php-zendframework-zend-modulemanager.spec21
3 files changed, 62 insertions, 39 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..4e7c419
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,50 @@
+{
+ "name": "zendframework/zend-modulemanager",
+ "description": " ",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf2",
+ "modulemanager"
+ ],
+ "homepage": "https://github.com/zendframework/zend-modulemanager",
+ "autoload": {
+ "psr-4": {
+ "Zend\\ModuleManager\\": "src/"
+ }
+ },
+ "require": {
+ "php": "^5.5 || ^7.0",
+ "zendframework/zend-config": "^2.6",
+ "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
+ "zendframework/zend-stdlib": "^2.7 || ^3.0"
+ },
+ "require-dev": {
+ "zendframework/zend-console": "^2.6",
+ "zendframework/zend-di": "^2.6",
+ "zendframework/zend-loader": "^2.5",
+ "zendframework/zend-mvc": "^2.7",
+ "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
+ "fabpot/php-cs-fixer": "1.7.*",
+ "phpunit/PHPUnit": "~4.0"
+ },
+ "suggest": {
+ "zendframework/zend-config": "Zend\\Config component",
+ "zendframework/zend-console": "Zend\\Console component",
+ "zendframework/zend-loader": "Zend\\Loader component",
+ "zendframework/zend-mvc": "Zend\\Mvc component",
+ "zendframework/zend-servicemanager": "Zend\\ServiceManager component"
+ },
+ "minimum-stability": "dev",
+ "prefer-stable": true,
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.7-dev",
+ "dev-develop": "2.8-dev"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\ModuleManager\\": "test/"
+ }
+ }
+}
diff --git a/php-zendframework-zend-modulemanager-pr33.patch b/php-zendframework-zend-modulemanager-pr33.patch
deleted file mode 100644
index 49dae69..0000000
--- a/php-zendframework-zend-modulemanager-pr33.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From de4135de41a32e593119e1feed8f0416470f7721 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Sun, 28 Feb 2016 17:53:09 +0100
-Subject: [PATCH] remove uneeded AutoloaderFactory::unregisterAutoloaders()
-
----
- test/ResetAutoloadFunctionsTrait.php | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/test/ResetAutoloadFunctionsTrait.php b/test/ResetAutoloadFunctionsTrait.php
-index 24e5e37..25b4a4c 100644
---- a/test/ResetAutoloadFunctionsTrait.php
-+++ b/test/ResetAutoloadFunctionsTrait.php
-@@ -9,8 +9,6 @@
-
- namespace ZendTest\ModuleManager;
-
--use Zend\Loader\AutoloaderFactory;
--
- /**
- * Offer common setUp/tearDown methods for preserve current autoload functions and include paths.
- */
-@@ -52,7 +50,6 @@ protected function preserveIncludePath()
- */
- protected function restoreAutoloadFunctions()
- {
-- AutoloaderFactory::unregisterAutoloaders();
- $loaders = spl_autoload_functions();
- if (is_array($loaders)) {
- foreach ($loaders as $loader) {
diff --git a/php-zendframework-zend-modulemanager.spec b/php-zendframework-zend-modulemanager.spec
index e83e4b0..1ef3921 100644
--- a/php-zendframework-zend-modulemanager.spec
+++ b/php-zendframework-zend-modulemanager.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit a2c3af17bd620028e8478a2e115e06623c4b6400
+%global gh_commit 2a59ab9a0dd7699a55050dff659ab0f28272b46e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-modulemanager
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.1
+Version: 2.7.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -30,28 +30,27 @@ URL: http://framework.zend.com/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: %{name}-pr33.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
BuildRequires: php(language) >= 5.5
BuildRequires: php-spl
+BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
-# "zendframework/zend-config": "^2.6",
# "zendframework/zend-console": "^2.6",
# "zendframework/zend-di": "^2.6",
# "zendframework/zend-loader": "^2.5",
+# "zendframework/zend-mvc": "^2.7",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "fabpot/php-cs-fixer": "1.7.*",
# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-console) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-di) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-mvc) >= 2.7
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
# Because of bootstrap
@@ -62,10 +61,13 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
# From composer, "require": {
# "php": "^5.5 || ^7.0",
+# "zendframework/zend-config": "^2.6",
# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 5.5
%if ! %{bootstrap}
+Requires: php-composer(%{gh_owner}/zend-config) >= 2.6
+Requires: php-composer(%{gh_owner}/zend-config) < 3
Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
Requires: php-composer(%{gh_owner}/zend-eventmanager) < 4
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
@@ -77,7 +79,6 @@ Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# "zendframework/zend-mvc": "Zend\\Mvc component",
# "zendframework/zend-servicemanager": "Zend\\ServiceManager component"
%if 0%{?fedora} >= 21
-Suggests: php-composer(%{gh_owner}/zend-config)
Suggests: php-composer(%{gh_owner}/zend-console)
Suggests: php-composer(%{gh_owner}/zend-loader)
Suggests: php-composer(%{gh_owner}/zend-mvc)
@@ -106,8 +107,6 @@ Zend\ModuleManager is the component that enables the design of a module architec
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .pr33
-
%build
# Empty build section, nothing required
@@ -159,6 +158,10 @@ rm -rf %{buildroot}
%changelog
+* Tue May 17 2016 Remi Collet <remi@fedoraproject.org> - 2.7.2-1
+- update to 2.7.2
+- zend-config is now required
+
* Sun Feb 28 2016 Remi Collet <remi@fedoraproject.org> - 2.7.1-1
- update to 2.7.1
- https://github.com/zendframework/zend-modulemanager/pull/33